Port Forwarding Instructions for (Most) Fritz!Box Users

Here comes a step by step setup for Fritzbox and should work with most fritz routers.
There are two prerequisites:

  • ensure that your ISP allows access from outside via a public ipv4 address. This is mostly the case but in some cases you need to pay extra for that. This is discussed here and here

  • ensure that there are no other routers in between your router (fritzbox) and the roon core. If you have a setup with multiple routers or repeaters ensure that they are configured as a mesh that only the main router (fritzbox) controls the port sharing

1.) Get the ip of your roon core: Just open roon, goto Settings->Info: the ip address of the roon core is dispalyed here:

  1. Open your Fritzbox Web Interface. via http://fritz.box and enter your password to access the settings: Go to Internet->Permit Access and press the button “Add Device for sharing” on the Port Sharing tab

Now select the roon core as device. The drop down box will list your roon core by name or ip.
Then mark the checkbox to permit independent port sharing for this device and save the new entry.

The result on the Port Sharing overview should look like this.

you will probably see “0 enabled” because roon arc setup did not yet open the port. this will change after roon arc is ready.

That’s it. Now go to your roon settings for roon arc and press the update button. You hopefully see that roon arc is ready and a port has been choosen for outside access

If you are curious you can go back to your fritzbox and check the detail page of your port sharing again. you should see the same portnumber displayed in roon arc listed here as well.

That’s it. Have fun with Roon Arc

12 Likes

Hi @Chris_KA,

Your efforts here are magnificent and deeply appreciated by the team and testing pool alike. I’ve moved your post into a dedicated topic thread to highlight in our #early-access:port-forwarding-solved section for other Fritz router users.

1 Like

Thank you for the effort to write it down for everyone!

That’s basically what I did on my Fritzbox as well. ARC works flawlessly.

Fritzbox 7530 AX
ISP: 1&1

And I had zero disconnects or lag either with the normal Roon remote app.