ARC with Fritz!Box —> Topic new: ISP with port forwarding needed

I had the same problem and getting a static IP address from my ISP solved the problem. They had a NAT assigning my NAT a private IP address. Too many NATs!

didnt change anything else (upnp is on)

How do I get a static IP address?
I really have to contact my ISP now because Roon decides for a complicated update?
Why do I need to do this now, everything worked with “Roon 1.0”? I’m really baffled how I’m locked out of the product I’m paying for now. With no real support and a support page saying “please contact your ISP”… nice.

Set back to Factory default without any help.

This only applies to Roon ARC which is for access when you are away from home. You still use the standard Roon Remote apps to access Roon at home as you always have.

Roon ARC is for access when you are away from home on the go…

You call your ISP to get a static IP address…if you aren’t going to use Roon ARC away from home, you can ignore all of this.

Please see if these steps for correct port forwarding for a Fritz!Box setup will work for you:

Okay, thanks - Problem identified: DS Lite Tunnel IPv4 over IPv6, with dynamic IP from ISP : NetAachen / NetColongne.

So far I don’t find a solution - will check if ISP will Provide a static IP, but I don’t thonk so.
I think it will be easier to use qobuz app on mobile. :slight_smile:

I did the step by step guide. But I think the issue is that my ISP is Vodafone Germany. Like in the linked threads (Link 1 and Link 2), as a Vodafone Germany customer you don’t get a static IPv4 address, my Fritzbox uses a DS-Lite-Tunnel as IPv4. I’m no expert in this but this seems to be the problem according to the linked threads.

1 Like

I think you are correct.

Hope my ISP will offer me a solution…

Note that you don’t necessarily need a fixed IPv4 address. Just one that can be port-forwarded. (It’s possible that they only offer both in a package, but a fixed one is almost certainly more expensive unless you are lucky with your ISP)

Noted - thanks 4 Info

Für alle deutschsprachigen Fritzboxnutzer:

Es geht nicht um eine feste IP beim Provider!

Du kannst unter Netzwerk => Netzwerkverbindungen beim jeweiligen Gerät hinten auf den Bleistift klicken. dort „ Diesem Netzwerkgerät immer die gleiche IPv4-Adresse zuweisen“ und „ Selbstständige Portfreigaben für dieses Gerät erlauben“ anklicken.

Dann noch checken, ob Netzwerkeinstellungen => erweitert UPnP aktiviert ist. Dann Änderungen speichern.

Dann sollte es funktionieren.


Danke/Thanks. Ist bei mir alles so eingestellt, funktioniert aber leider nicht…
I get this error message:
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Maybe this helps to identify the issue?

1 Like

Like this? Tried it and still the error message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“MY_IP_ADDRESS”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

This seems to suggest that you have multiple NATs in your network…

Es ist anscheinend Providerabhägig ob die Lösung funktioniert oder nicht.

Yes, it seems so. After checking via Google, i understand that My ISP (Vodafone) provides a DS-Lite that doesnt allow port forwarding…

Some kind of funny, after waiting for years for big changes with Roon 2.0 ……
For all users with ISP that do not support port forwarding Version 2.0 is the Version with no change. Little disappointing.

Indeed it is not about a fixed IP address. However, you need one that allows port forwarding, and not every ISP provides that. E.g., Vodafone Germany uses DS Lite, which shares an IPv4 address between several users, so it can’t be used for port forwarding. (See above links)