ARC doesn't work over internet despite network sharing default port 55000 (Fritz!Box 6690)

Roon Core Machine

macOS Monterey 12.6
MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports), 2,7 GHz Quad-Core Intel Core i7, 16 GB 2133 MHz LPDDR3, Intel Iris Plus Graphics 655 1536 MB

Networking Gear & Setup Details

Router: Fritz!Box 6690 Cable, WiFi-Repeater: Fritz!Repeater 2400 connected to router via Ethernet, MacBook Pro on WiFi

Connected Audio Devices

Number of Tracks in Library

22,000 tracks

Description of Issue

Hi, team Roon,

I don’t get Roon ARC running ‚over the Internet‘ in my network setup. I would use the default port, 55000 (as you can see below). First, I shared that port on my router manually. After that didn’t work, I followed these instructions: Port Forwarding Instructions for (Most) Fritz!Box Users. But this also doesn’t work, I always get these diagnostics:

{

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 37.5.246.155:55000, response code: undefined, body: undefined”},

“external_ip”: {“actual_external_ip”:“37.5.246.155”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.178.1”,“found_upnp”:true,“error”:“<?xml version=\"1.0\"?>\n <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n606\nUnknown Error Code\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>”}

}

The only remarkable detail about my network setup: I don’t use the router’s Wifi capability but instead use a repeater connected to the router via Ethernet. This repeater, a Fritz!Repeater 2400, doesn’t have any settings for port sharing, as it is strictly not a router, just a Wifi repeater. There is no concurrent NAT also, so this shouldn’t make a difference, really.

Hopefully, you can make anything out of the diagnostics.

Can I ask you how you find the external port in your Mac? I am trying to configure but cannot find this information. Sorry to be a bother

Hi, Scot,

the external port is (or should be) visible in your network router’s configuration, not on your Mac - it is the device that presents your Roon Core to the Internet and the external port is the port it listens to on the Internet. Commonly both numbers are the same (I for one just map Roon Core port 55000 to external port 55000), that’s typically the default on routers.

Cheers
Heiko

I have a similar issue. I think it could be down to port forwarding on my ISP router as I have configured my internal mesh to fwd to my Roon Intel NUC.

My error codes is:

{

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 45.66.39.151:55002, response code: undefined, body: undefined”},

“external_ip”: {“actual_external_ip”:“45.66.39.151”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}

}

Same Problem here.
noi solution yet.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“95.223.184.46”,“router_external_ip”:“”},
“status”: MultipleNatFound

,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.178.1”,“found_upnp”:true}
}