ARC not working - though I followed manual for my router posted here

Roon Core Machine MacBook 12


Networking Gear & Setup Details

Fritz Box 4040

  1. Who is your internet service provider?
    A1 Austria

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?
    there is a fibre cable to lan box where I attach the Fritzbox

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I followed this manual Port Forwarding Instructions for (Most) Fritz!Box Users but it did not work. I checke my IP, it says it is an ipv4 address.

Any ideas? here is the log:

"connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: write EPROTO 140218259597120:error:1409442E:SSL routines:ssl3_read_bytes:tlsv1 alert protocol version:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1536:SSL alert number 70\n, response code: undefined, body: undefined"},
"external_ip": {"actual_external_ip":"","router_external_ip":""},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"","found_upnp":true}

I am just a user but it looks like the complaint is in regard to ssl version 1.
it also indicated a 502 error. I’d bet they are related.

What port are you trying to use? The EPROTO error returns people asking then changing ports.
Stay over port 1024.

1 Like

Hi @AlexderK,

It’s possible that your ISP has reserved the port assignment range to which Roon defaults. I recommend taking the following steps:

  1. First, try toggling UPnP on/off in the Fritz!Box and attempting to auto-configure port forwarding.

  2. Do you know if the fibre box you’ve mentioned above is functioning as a modem/router combination? If there’s a web administration for this device, make sure it’s in Bridge mode.

  3. Lastly, as other users have helpfully suggested above, try manually typing in a different port number in Roon → Settings → ARC. If you’re setting a manual port forwarding rule in the Fritz!Box, make sure it matches the updated port. This will help us verify if your ISP has in fact reserved a certain port range.

We’ll keep an eye out for your response. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.