When selecting composer album missing [Ticket In]

Core Machine (Operating system/System info/Roon build number)

Windows 10 / tower PC / 1.8, build 831, 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Everything over wired Ethernet (except of course the iPad remote) - this is not a network problem…

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert connected by Ethernet

Description of Issue

I have an album in my library with the credits clearly showing that Johann Sebastian Bach is the composer.


When I search in composers and display only the albums in my library the album does not show.
What am I doing wrong?


2021-11-20T23:00:00Z

It’s probably still to early (not holiday season), but not sure if this is intended to affect the discography tab.
If the album becomes visible at some time during the next month, Roon’s hiding of holiday music seems related to what you encounter. :upside_down_face:

Not sure if it helps if you enable the display of hidden content in Roon’s settings meanwhile.

Thanks, BlackJack. Creative idea, but not the solution - sorry.
Look forward to hearing from Roon @Support

Hey @Robert_Sonderegger,

Thanks a whole lot for getting in touch about this. We’d love to help :nerd_face:

Thanks @BlackJack for chiming in and sharing what could be causing this. It also prompted me to ask: if you click on the ellipsis (next to the album) and select Edit, under Visibility in Roon (on the pop up window), is by any chance the album (Bach: Weihnachts-Oratorium) hidden?

Thanks for getting back to me Rebeka.
This is what the Edit/Visibility looked like:


Unfortunately one cannot tell what the status is, so just to be on the safe side I clicked Unhide Album.
I also made sure the general setting was set to display everything:

I also did a library clean up in setting just in case, but no joy.
The album does not appear - there are still only the same 19 albums showing:

What should we do next?
Regards
Robert

Sadly I’m having the same issue. I can’t get all the albums of same composer to show together, for the life of me I, tried 2 hours today. I get everything related to some name only if I do a basic search, but not when I click on the composer’s link.
Either we do something wrong (unhide doesn’t help anything) or there is some bug.

Hi Jaccuse, glad to hear that I am not the only one with this problem.
Roon @support is looking into this now and I hope they will soon have a solution.
Regards
Robert

While we are waiting for a real solution, I realized something: after clicking on a composer, while on a composer’s page, we can see a number of albums “Composed by” (excluding some that we cannot see, as reported here), say 13 to give an example, if one clicks on the dots next to name and then “View albums in library”, it then shows presumably all of them in a list (17 albums now, in my case, see the last picture). Indeed, those albums that I couldn’t find earlier (and still can’t find after the simple click) are now included in this list.

Hi Jaccuse, this is - as you say - a good work around, thank you very much for sharing. Since my wife is less technophyl she does not like work arounds but expects to find the albums when the focus is set to “Library” :slight_smile: .
@support can you get back to us with your plans for a real fix or let us know what we are doing wrong?
Thanks to all
Robert

I, too, am having this issue. The composer metadata field has the correct information, and Roon is interpreting it, because it shows the composer in composer view, yet there are no albums/pieces/etc. listed when I select the composer (in this case there are two total albums in my collection by the composer in question). Most composers/albums work fine—there are just a couple that don’t seem to work.

Hey @Robert_Sonderegger,

Thanks for continuing this conversation and for actually bringing up the topic. I’ve taken your case to our team and they’ve been able to reproduce the behavior on their end as well. They’re now investigating.

I’ll get back in touch as soon as I hear back :nerd_face:

Hey @Robert_Sonderegger,

I just heard back from our QA team. They have created a ticket for this issue that will be released in one of our subsequent releases.

It looks like the error is caused by the artist being credited as both the Primary Artist and Composer.

In the meantime, if you know of an affected album, you can remedy this by removing primary artist credits:

  • Go to the album details page
  • Select all tracks
  • Click Edit in 3-dots-button menu on the selection bar
  • Switch to “Edit Tracks” tab
  • Click “+” button for “Remove” option for CREDITS
  • Remov the composer’s name
  • Save
2 Likes

Hi Rebeca, I have the same problem for a while.
It is not a matter of primary artist.
My album Tchaikovsky “The complete symphonies” from Leonard Bernstein are not listed under composer Tchaikovsky. Primary artist is Leonard Bernstein only. Composer is Tchaikovsky.
If I select the tab “compositions” instead of overview, all tracks are listed.
Thanks
Regina

Thank you very much for looking into this and getting a fix on the way, Rebeka!
Looking forward to seeing the update in the near future.
Best regards
Robert

1 Like

Hey @Digigina,

I appreciate you so much the fact that you took the time to expand our context. We’d love to gain more insight into what is happening. Would you be able to upload an album that exhibits this behavior in our drive?

Thanks a lot @beka for your support!
I just uploaded 2 albums. Berlioz and Tchaikovsky.
Hopefully you can get any information out of this.
I’m sure I would find a lot of others if I would looking for :wink:
Cheers
Regina

Wow! That’s amazing, @Digigina. We’re grateful for the very quick reply and your willingness to help.

I’ve passed it on to our QA team and will get back to you as soon as I hear back from them myself :nerd_face:

Is there any news about this? Five months have passed since the last reply.