White noise with DSD playback-Update

Roon Core Machine

iMac (Retina 5K, 27-inch, 2020)
Processor Name:6-Core Intel Core i5
Processor Speed:3.3 GHz
L2 Cache (per Core):256 KB
L3 Cache:12 MB
Memory:32 GB
OpSys: Mac Monterey 12.2.1
Music on 6TB external HD drive via USB 3

Networking Gear & Setup Details

Google/Nest mesh (incoming 200 mbps speed)

Connected Audio Devices

I have tried the following – none of which solved it

A) iMac core->long USB cable (15 ft) → Gustard X16 DAC
B) Same as above but with better USB cable
C) iMac core → WiFi–> Raspi 3/DietPi → Short USB cable–>Gustard X16
d) iMac core → Ehernet–> Raspi4/Ropieee 2.2 → short USB cable → Gustard X16

Current configuration is D)

Number of Tracks in Library



Description of Issue

Occasionally, I get white noise when playing DSD. Usually it is DSD 64. I was pretty much convinced it was my USB cable and first bought better cables (twice) and then I went through the various setups above (A to D) without success. This never happens with MQA, FLAC, etc. Only DSD. Or DSD upsampling of FLAC, etc. If I switch to non DSD music - MQA, FLAC, etc…it works fine. If I switch to any DSD it pours out white noise again. If I turn the DAC power off and on, everything works again for a few days or weeks before it happens again.

Then I thought it was the DAC and I contacted the manufacturer. They sent me a new DAC with the latest firmware and it did the same thing.

I have tried various settings in Roon. Native and DSD over PCM and various resync delays.

Instead of playing DSD music from my library (on hard drive) I tried upsampling non-DSD files (CD quality from Tidal) to DSD using Roon. And I got white noise again.

When this happens - I can fix it in two ways. I can turn the DAC on and off or in the case of upsampling, switching to PCM rather than DSD works.

When it is fixed, I have no trouble playing any DSD for a while. Sometimes it works great for a week or two, but eventually it happens again.

I have a video showing this and can probably share via You Tube unless you can give me another way.

Then I searched the Roon community and several times white noise comes up with DAC makes other than Gustard (for instance Topping). Maybe the same chip? Don’t know. But that points to something other than the Gustard.

I know a few people on line with the same hardware setup as me (except the core computer) and have not had this problem and have the same Roon device settings as I have.

I have tried

DSD over DoP
DSD native
Sync delays (several up to 4000)
Numerous different settings with upsampling.
Different cables
WiFi vs ethernet vs direct USB

So what can it be? The iMac? I use the computer browser and the core at the same time frequently. I was going to buy a Mac Mini for a stand alone core but that’s getting expensive for a troubleshooting step.

UPDATE: I made a brief video of the problem here

I’m using a SMSL M300MkII DAC with a dedicated Win10 core PC, using remote Win10 laptop or Android11 mobile to control Roon.

I’m having the occasional glitch which sounds like very loudly and strongly hard clipping the music, but only when skipping between differing sample rate pieces, may they be PCM or DSD.
It never happens when there’s a transition from one piece to the other with differing sampling rates.

I thusly try making it a habit to always stop before skipping, which eliminates the problem.

Currently, I’m going USB direct via a true USB isolator from server to DAC, but had RPi setup before where the behavior was happening more frequent - no matter if Ropieee or Diet-Pi or plain vanilla RPi-OS with Roon bridge.

Problem does not occur at all with RPi/HiFiBerry HAT, though.

I gather it’s related to the DAC, and no, a dedicated server doesn’t seem like a solution, unless, maybe, it’s a ROCK or Linux box…

I thusly try making it a habit to always stop before skipping, which eliminates the problem.

I had one case where I didn’t use Roon for a few days and the first song I played was a DSD and I got the white noise.

I also tried changing the delay time between music.

I would think a handshaking problem would be repeatable…my noise comes and goes…I can’t pin it down.

MatrixAudio element M connected by CAT6 via powerline adapter with Windows10 core plays native DSD256 as well as up-sampled FLAC to DSD256 absolutely flawlessly. I did have problems you describe when the DAC was on WiFi.

Hey Dennis,

trying to figure the issue here, can you try to set up a core on another computer with some DSD file and direct usb connection to your dac (short cable if possible) to see if you will have the same issue?

Power off the DAC when you’re not using it. Power it on only when you need to use it.

Turning the DAC on and off was a similar solution suggested by Gustard tech support. I don’t think I’d remember to physically flip the switch and I’d probably need to buy a remote controlled power outlet or something.

But I can’t figure out what triggers the problem…so turning the DAC off is a solution when it happens but there is no guarantee it will solve the initiation of the noise.

My wife has a Mac Book pro. I’ll see if I can talk her into using a tablet for a few days. As I said above, I think buying a Mac Mini or NUC would be something to try but expensive.

Another test I can do is ---- I have jRiver installed and I can put the DAC as I originally had it with a 15 ft USB cable. I can see if a different player has the same issue. Gustard had wanted me to try a different player.

Right now, I bought two new short USB cables and I’m testing them one at a time. So far everything is OK but it’s only been a few hours.

Which to try first? JRiver or laptop?

PS: If I change cores, will be album edits return when I switch back?

I don’t think using a different Mac is going to solve your problem if you have already tried Pi. Windows with native DSD driver may be slightly more worthwhile to try (but I’m not hopeful this will solve your problem).

I used to think it was a handshake problem at the start of the tract. But as shown near the end of the attached video above, switching to PCM and then back to DSD mid-song returns DSD to normal.

The rational here is to isolate elements, the only thing didn’t change in your various experiments was the iMac. a fresh simple core with a direct USB link to the dac to see if that can help, another player would be another route to explore.

OK…I’ll give it shot with a new core on the laptop maybe a dozen DSD files on an SSD and Qobuz upsampled to DSD.

Probably a week will work.

I have also tested a different DAC although not for very long. My Oppo HA-2 DAC is 5 or 6 years old but is DSD capable and I have never had noise with it. It is hooked up directly with a 5m USB cable but all else the same.

PS: Can I leave the old core untouched and use my phone to play tunes on the new core? I’m also wondering if I should backup my current core and delete it and reinstall.

yep, run a back up, you can run a fresh core on a new computer to test theory here, if it works, restore the back up on the new one to see if it is linked to the database to decide if you want to start all over.

the fact your other dac works, pointing strongly to compatibility of gustard x16.

… pointing strongly to compatibility of gustard x16.

Way back when, my first thought as well.

Others on the Gustard Owners blogs (eg Audio Science) have Roon with heavy DSD recordings, the same DAC and do not have my white noise problems…(although I’m not sure about Mac vs. Windows). I have the latest DAC firmware updates.

It just occurred to me that I have Windows 11 and Windows 10 on my Mac (using Parallels) and can put the core there. That would keep the Mac hardware the same but change the OS. I just set up a new core on Windows 11 with Qobuz and a handful of DSF files

The first song I player (Adele 21 upscaled to DSD 128) played OK for a bit and then there was a short dropout.

I’ll try it for a day or so.

Hello @Dennis_Laslo,

When I saw the Oppo in your video I was about to ask if you have these white noise issues on that player. Since you don’t things seem to be pointing toward the Gustard.

I noticed the blurb below on this website. You may want to test using Windows 10.

USB input supported operating system: WIN7 SP1/WIN8/WIN10 32-64bit; macOS; Linux

No. I don’t use the Oppo for SACD anymore - just DVDs. It has an HDMI output to my AVR receiver.

Well, after I posted the problem last week ……I changed three things at once and have been noise free for days now. Fingers are crossed that I found the problem

The three things are
1)I bought a new, shorter USB cable (this is the third one I’ve tried)
2) I changed DSD to native to DoP (I tried this before but I’m including it here because I changed it. A few days later, however - I changed back to native).
3) I changed the volume on the DAC down a few clicks. Since I was using the preamp volume control and not the DAC’s - I had kept it at maximum and fixed volume.

I’ve tried DSF files up to DSD 256 and also upsampling to DSD 512 and so far so good.

I’m leaning to the DAC volume control as the culprit. I’m going to shoot a question to Gustard on this.

Update: Gustard says the volume control won’t do that.

moved here

Hey @Dennis_Laslo

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones: