Why does Roon "hang" and I have to do a Restart?

Often I have to reboot/restart my Mac to get Roon to work. This is after I have been using Roon for a while. I have not been able to isolate when this is required however it is related to leaving Roon paused possibly. Roon never “hangs” during the execution. I know that I am not closing my Mac (putting it in sleep mode).

Any recommendation or ideas?

  • Should I always quite Roon when I pause to avoid this issue? This would be a little annoying but maybe better than a restart of my Mac.
  • Avoid pausing for more than 15 minutes?
  • Always quite Roon before you close the Mac or put it to sleep. I know that it has “hung” without closing the mac however.
  • Upgrade the OS to Catalina. Note: I will be upgrading to the 64 bit only Catalina OS in the future. I just completed my analysis and think I am good to go with this update.

I will continue to try to see exactly what scenario causes this condition but I thought that I would post a question.

Mac Book Pro 2015
Mac OC 10.14.6 Currently
Roon 1.7 (current)
Roon core is running on my Mac
I either use my Mac or a remote iOS device like an iPad or iPhone.
I have a DAC/AMP connected via USB to the Mac

Hi @Carl_Cullison,

How exactly is Roon hanging in this case? Are you able to press any buttons and they don’t respond? Does the Roon app turn white and all test goes missing?

Does exiting out of Roon and back in resolve this issue each time? Are any Roon remotes you use able to properly connect when this issue occurs?

Good questions:

  1. How exactly is Roon hanging in this case?

  2. Are you able to press any buttons and they don’t respond?

  3. Does the Roon app turn white and all test goes missing?

  4. Does exiting out of Roon and back in resolve this issue each time?

  5. Are any Roon remotes you use able to properly connect when this issue occurs?

My explanations:

1-3 In the Roon playlist view or the queue the song icon on the left will show the icon and the small little graph that the the selected song in playing however … At the bottom of either view, the selected song will show for example 32 seconds into the song and will freeze at 32 seconds (just an example) and of course no sound or music will be heard. Not the Roon app does not turn white.

4 Backing out (exiting, quitting) Roon has no impact. Re-launching or executing Roon will display the same view. I can select all the options, different playlist, whatever music options but no music will play. The same view if selected will display, and no music.

5 I will try to use a remote Roon the next time this happens, I have not tried this.

Other information:

  • Today when Roon hung, I did not shut the Mac, ie., it did not go into sleep mode.
  • My attached headphone DAC/AMP via USB may have gone into its sleep mode but my thinking is that it is downstream and no impact on this issue.

Thank you for investigating. Carl

ps. The good thing is every time (knock on wood) that Roon core has hung up, a Mac Restart has resolved the issue and I am solid state now so it is not a terrible delay. Still it would be nice if there is anything I can do to prevent this from happening…

Well, actually it maybe causing issues. Roon keeps tabs on audio devices even if not playing and if the DAC is going to sleep, Roon might be interpreting that as a disconnect which cannot then reconnect without breaking power, which a reboot would do. Next time try unplugging and re-plugging in the DAC and see if it works instead of a reboot.

Ok good, that would make sense, I will try to unplug and re-plug the next time it hangs.

ps - It has been working for the last 24 hours perfect. I did notice the DAC/AMP went to sleep while Roon was active but song was paused. I then started the song without waking it up, Roon started playing fine…Then I woke the DAC/AMP up and it was still fine. I know this is not what you said.

Every manufacturer, it seems, decides differently on how to talk to other devices. So if it works for you keep on doing it is the best advice.
This drift from standards is why roon wrote their own network protocol in the first place displacing upnp (Universal plug and play)- because it was never universal or plug and play.

1 Like

Great, unplugging worked when it hung today… After the unplug and plug I just had to unplug the USB … then it worked…

Thanks a lot… Carl

1 Like

Hi @Carl_Cullison,

Glad to hear that unplugging the DAC and plugging it back in resolves this issue when you are in this state.

I’m looking over the thread and I don’t see you mentioning what type of DAC this is, what is the model/manufacturer? Have you confirmed that it’s up to date on latest firmware?

When this issue occurs, are all your other audio endpoints working as expected? If so that would further point to this issue being DAC-specific.

  1. I am using a Focal Arche DAC/AMP and no I have not yet checked to see if it has the latest firmware. I recently purchased this and it is on my list to check.

  2. It is a good idea to check my other endpoint when this happens again for further confirmation. Currently I only have one Apple TV that I use with a nice sounder/sub woofer. I guess I can also try the internal mac phone out and the internal speaker/blue tooth to external speaker. I have more equipment planned in the future.

I am pretty sure you nailed the issue so it will save some frustration.

I appreciate the help. Thank you. Carl


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.