Will not output 16bit to Naim DAC-V1 using Exclusive Mode [Resolved - build 247]


I have a Roon Server setup on a 2012 Mac mini that is connected via USB to a Naim DAC-V1.

I have enabled Exclusive Mode within Roon’s settings for the Audiophilleo driver for the DAC-V1 and have selected this as my output zone.

When I play any 16bit audio, the Signal Path says that it is Lossless and the source is ‘FLAC 44.1KHz 16bit 2ch’ and the Output is ‘CoreAudio Exclusive Mode’ but when I look at the status screen of the DAC-V1 it says that it is receiving 44.1KHz 24bit data. If I look within the MIDI app on the Mac Mini it also confirms that the connection to the DAC-V1 is 24bit. If I stop the audio from playing and manually change the MIDI output to 44.1/16 as default, it immediately changes back to 44.1/24 when Roon starts playing.

If I disable Exclusive Mode then Roon outputs 44.1KHz 16bit to the DAC-V1 with no problem so it seems to be related to Exclusive Mode.

I am running the latest stable release of Roon and OSX 10.12.2

Hi @Chris_Ellison ---- Thank you for the report and my apologies for the troubles here.

Could you please provide a screen shot of the audio settings you are using for this zone so I have a better understanding of your configuration?


There is no problem here. As long as you are not engaging any processing, such as volume control or leveling, your audio is lossless, bit perfect. The 16 bit words just are being padded out to 24 bit words with eight zeros concatenated as LSBs.


Hi Eric,

Here are my settings:

I hear what you are saying but that data obviously isn’t bit perfect if additional bits are being appended to the stream even if they are padding. The DAC-V1 is capable of decoding 44.1/16, Roon is capable of playing 44.1/16 and the source material is 44.1/16 so I would expect the bitstream to be 44.1/16 to keep things bit perfect.

Naim provide sample wav files to test different sample rates & bit depths as bit perfect and 44.1/16 is failing. 24 bit files are fine as you would expect.

If I disable Exclusive Mode then the files pass as bit perfect and the DAC-V1 shows 44.1/16 as expected but this obviously negates any advantages that Exclusive Mode brings to the party.

No, the audio still is bit perfect. Adding zeros as LSBs does not alter the audio data. It is no different from adding zeros in front of decimal numbers (e.g. 000000005 still is 5).

Anyway, as I recall, CoreAudio typically is set for 24 bit output, padding with zeros as needed. That just seems to be standard. So, I fail to see why you are so concerned about it.


Can you please stop hijacking this thread. I am very happy for you that you fail to see any issues with the implementation described.

I personally do I have a problem hence why I opened a discourse with the developers.

It is currently not possible for me to ascertain if the data is bit perfect as the data stream is being converted from 16 to 24 bit. You say that it is simply padding and that the audio data integrity is in tact but how are we to prove this if bit perfect test files will always fail? I am not prepared to blindly trust your assumption and this is why the test files exist in the first place.

Core Audio does not always output in 24 bit resolution. You can manually select a default bit depth and sample rate or when in Exclusive Mode, Roon can change the output as required (as it does for all other combinations that I have tested outside of 16bit).

Furthermore, Roon can successfully output at 44.1/16 when not in Exclusive Mode. Audirvana can when in its Exclusive Mode.

Currently, when I play back a 44.1/16 file my DAC is operating in and decoding the file in 44.1/24 mode. I (and I safely assume you) have no idea what effect this may have within my DAC. I am struggling to understand what you are not grasping here.

I am not “hijacking” this thread. I have provided information about how bit padding does not affect bit perfect output and how CoreAudio operates.

But that is not what you want to hear, apparently. Instead, you get uppity about it. So, I will let someone else set you straight.


What you have also said is that “there is no problem here” which I do not agree with and why I started the thread in the first place.

Hopefully Eric and the Roon team will be able to identify what is going on as I do not believe that Roon should be handling 44.1/16 data files in this way with my particular setup.

It’s a fair question - if the files 44/16, it should arrive at the DAC as 44/16 regardless of exclusive mode or not. Sounds like a possible bug in either Roon or the Naim. Since this hasn’t come up much before to my knowledge, it could well be the Naim.

I’m definitely not ruling out Naim but Exclusive Mode works correctly with 44/16 files in Audirvana (assuming that all Exclusive Modes are equal).

Unlikely to be the Naim then. Have you tried without max buffer size set? That’s not normally required, maybe there’s something there?

Can’t think of anything other than that.

Roon always tells you what it’s doing via the signal path, so I don’t expect they’d ever pad with zeros without telling you. What do the signal paths look like with and without integer mode, anything unusual?

I’ve tried disabling the max buffer size setting and the issue still persists.

The signal path always shows the correct bit depth and sample rate but this doesn’t match what is actually being sent to the DAC when it is a 16bit file.

This is puzzling – I’ve never seen Roon’s signal path not being right. Could you post a screencap of the signal path that is showing 16-bit in Roon and 24-bit on your Naim?

Don’t expect miracles on a Sunday night, but let’s flag @support here to follow up for you.

Hey @Chris_Ellison

None of my DACs are able to report bit-depth so I’ve never noticed this before…

But when I play a 16/44 track in Roon, the MIDI Audio Setup on my iMac reports a 44/24 stream. Roon is set to Exclusive mode and the Roon signal path indicates it is 16 bit.

I can pause the track and change the bit depth in MIDI to 16 bits. Once I restart the plaback, it jumps to 24.

It isn’t the NAIM but I’m seeing it too, just never noticed it.


The signal path on my system is the same as posted above and I also have the additional information displayed on my DAC that confirms the 44/24 signal.

Hi @Chris_Ellison ----- Thank you for your follow up and continued feedback. My apologies for the slow response here.

I wanted to touch base with you because I have left a note with one of my developers asking for some feedback in regard to this behavior you have noticed. Once they have updated me with their thoughts I will be sure to reach out to you ASAP.

Your patience is appreciated!


And ? Has there been any news since Jan 17 ?

Afraid not. I have provided two sets of logs highlighting the issue but have had no feedback regarding the issue and when it might be fixed. Bit disappointed actually.

That is indeed disappointing.