Win 10 client stuck at Initializing

ROCK (1.8 build 764) on a celeron Nuck, but all the other clients (Android, iOS, Mac) are working OK.

Uninstalled Roon Client and removed all firewall rules, then reinstalled and gave TCP and UDP allows for both raatserver and roon exe. Also tried with disabled firewall. Still stuck at Roon Core Initializing.

Where should I look for logs or errors?


What is the make model of the NUC you are using?

It’s Intel® NUC Kit DCCP847DYE

But the core is fine, I can connect to it from an Android phone, iPad and Mac.

Hi Can,

Fellow user here.


  1. Try temporarily turning off all Firewalls and Anti-virus on the Win 10 client and see if that helps. If so, then add Roon, RoonServer, Raatserver processes to the firewall approved list.

  2. If you are running ROCK on that NUC, then you are using it in an untested and unsupported environment. ROCK is made specifically for the hardware listed on the supported hardware list. See here.

Now, that doesn’t mean it won’t work, just that you are doing so at your own responsibility, as that is considered Tinkering.

I had Roon Remote problems on 2 Windows 10 Pro 64 Bit PCs this week - both of which are entirely different in spec & set-up.
The only thing that worked - for both PCs - was a complete de-installation of Roon, including all directories, then re-installing the latest version from the website.

Aaand back to normal. Didn’t change anything, it just works now.

Thank you for the replies.

Have fun,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.