Window position not saved anymore on Roon 1.7

Core Machine (Operating system/System info/Roon build number)

Mac mini MacOS Mojave
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TEXT GOES HERE

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TEXT GOES HERE

Description Of Issue

Hello there
Since updating, the window of Roon doesn’t stay where it should be: it goes on the left bottom corner. It is not very important but I like to have it in the middle of the screen. Is there something I can do to avoid this issue? I shutdown every night Roon. I added Roon to open automatically at startup in System Preferences. I tried removing and adding again Roon but still an issue.

I tested with my iMac running High Sierra and found it works properly. I even tried with Roon starting automatically. What monitor are you using?

Maybe someone running Mojave can test.

Most support personnel are having Thanksgiving, so there may be a delay helping.

Cheers, Greg

Hello @Gigatoaster,

When you quit and re-open the Roon app, does the same behavior occur? Or is this only when you reboot the computer?

-John

It happens only when I reboot. Only Roon is moving to the corner. Opera stays always at the same position. Other programs, too.

Hello @Gigatoaster,

Could you provide the following setup details?

A) Resolution of external display
B) “Scaled” setting in System Preferences > Displays
C) Do you have Dock Auto Hide enabled or disabled

-John

Hello @john

Thanks for looking into this case.

A) Panasonic OLED 55 inches 3840 x 2160
B)Scaled at 1920 x 1080
C) Automatic Hide and show the Dock: disabled

Now the window is taking the full screen. It appears after updating.

@john , any updates by any chance?

10 characters

Julian if you don’t rescale the screen in Mac settings and next time restart everything with the window open when you shut down does it still move?

Hello mate

Thanks for your message. I tried what you advised but after restarting the window goes back to the left bottom of the screen. :thinking:

I don’t have any external tv”s or monitors on my macs to test. At least not till maybe late next week when I get an lg c7 (foc) that I might be able to hook up to a mini.

See if @john comes back with any clues.

@john Any updates, by any chance? It is a serious bug but I was wondering if someone was looking into this issue.

I updated and still the same issue. Not sure it is Roon related or MacOS. However only Roon is acting like that.

Is @john still around? I haven’t heard from him. Anyone from @support could help?

Hi @Gigatoaster,

Apologies for the delay, I will discuss this issue with @john at our next meeting. Can you confirm if you have any “Hot Corners” set up on this Mac?

Thanks. Yes, I use Hot corners, only one. Always used it. I disabled it and restarted but still facing the same issue.

Hello @Gigatoaster,

We are unable to reproduce this using macOS Catalina 10.15 running on an LG C9 scaled at 1920 x 1080. To attempt to reproduce the issue, we

A) Added Roon.app to the “Login Items” in System Preferences > Users & Groups.
B) Opened Roon.app and set the window size.
C) Restarted the computer.

Once the computer rebooted, Roon.app re-opened in the same window position that it was left in previously.

You could try deleting the Roon entry in the macOS saved application state directory. Close Roon.app and locate the folder named com.roon.Roon.savedState in the ~/Library/Saved Application State/ directory and delete it.

-John

That didn’t work, unfortunately. I am thinking of deleting everything & restarting from scratch but it’s too much hassle just for this kind of bug.