Windows 10 can no longer access \\ROCK\ in file explorer

Roon Core Machine

Intel Nuc i7 1.1 GHz Intel Core i7 6-Core (10th Gen), 16gb RAM
Version 1.8 (build 831) stable

Networking Gear & Setup Details

Netgear X10 router with direct ethernet wiring

Connected Audio Devices

dCS Rossini, ethernet connection

Number of Tracks in Library

30,000 tracks

Description of Issue

My Windows 10 PC recently stopped being able to view or interact with the Roon NUC on the network when using File Explorer. I suspect the change could be due to a Windows update. Note that I can still use the Roon Remote software on my PC to control and play music from the NUC.

Here are the steps I’ve tried so far, but with no success:

  • enable SMBv1 client function
  • disable firewall from virus protection software
  • disable VPN
  • Changed Group Policy setting: Computer configuration\administrative templates\network\Lanman Workstation And “Enable insecure guest logons”
  • Rebooted PC and NUC
  • Tried to add the NUC to the network as a drive

Thanks in advance!

Have you tried both “\\rock\” and “\\IP address\” to try to access the drive in explorer?

Thanks for your suggestion - I tried both and get the same message “Windows cannot access…”

Can you try rebooting the modem (if there is one), then router/switch, then PC/NUC. This has helped me in the past. Let them all get new start on life (get IPs reassigned in an orderly manner). sometimes windows does not want to let go of a bad connection for some reason.

might try this?:

Thanks again. I tried rebooting each device in sequence, from the modem to the NUC. Then reset the network stack per the linked article. Still the same situation.

I can ping the Nuc as normal, but still don’t see it in Windows explorer. The error code I see in Windows Explorer is 0x80004005

Check toske sure you have SMB 1.0/CIFS File Sharing Support enabled. Windows likes to turn it off sometimes when updating.

1 Like

take a look at this. it might help?

The PC does have SMB 1.0/CIFS File Sharing Support enabled (and within that option, only Client is selected, not Server or Automatic Removal).

OK, I just tried those two procedures (Permissions Settings and System File Checker Scan).

1 Like

Did they fix the issue or find any issues?

If not have you checked Network discovery and file and print sharing are turned on?

  1. Open the Control Panel.
  2. Go to "Network and Sharing Options:
  3. Go to “Change Advanced Sharing Settings”
  4. Select “Turn on Network Discovery” and “Turn on File and Print Sharing”

I am running out of ideas for you. May need to wait for help from Roon Support.

No luck so far. I tried everything listed here. Thanks for your suggestions.

The only interesting thing to note is that every time I go to “Network and Sharing Options” and select “Turn on Network Discovery” and save the changes, when I go back in to that menu, network discovery has turned off.

Here is a thing to try. However this is a registry edit, so it depends on how confident/comfortable you are with it. Use at your own risk…

There was more on a “” site but they were pushing “driverfix” program too much for my comfort level. Google “network discovery turns itself off” and you will see it.

1 Like

My windows 10 still sees my Rocks storage on latest version on Surface 3 laptop

Awesome, thanks a million! Regedit did the trick. So frustrating that these deep settings can change without a user’s knowledge.

Use regedit to find:


Double click the Start value in the right hand window and change the value to 1.

This will change the startup type to System.

Make sure you turn on Network Discovery in Change Advanced Sharing Settings.

1 Like

Mine (custom built desktop with Win 10 Pro) still sees it too, but it has been flaky in the past with some of the updates. There have been challenges getting Windows to see Rock storage and my TrueNAS storage and be able to map the drives, also. Nock-on-wood, it is working now and has been for me for a while. We now also have a list of stuff (see above) to try the next time network locations disappear… :stuck_out_tongue_winking_eye:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.