Windows 11 Upgrade

Roon Core Machine

Intel NUC i5, 8M, Roon ROCK

Networking Gear & Setup Details

ROCK to Switch to PC

Connected Audio Devices

Number of Tracks in Library


Description of Issue

After upgrading PC to Windows 11, I’m unable to connect to shares on the PC, I can connect to shares on the Synology NAS and other machines are able to connect to the shares on the PC and I have no problem with connecting to audio devices on the PC.

I initially had an error that “This drive is not available” when I lost the files in the library and now when I try to add the folder I get “There was an Unexpected Error: UnexpectedError”

I’ve uninstalled Roon on the PC and reinstalled, turned off the firewall and still no success.

@raf - Not quit sure I understand your problem. But can it be that you need to enable SMB:

Here is good one (only in German)

Thanks Torbin but that wasn’t the issue SMB is enabled, I started to think it was a permissions issue, even though I was putting the correct details as they hadn’t change so I thought I’d turn off Password Protected Sharing in Advanced Sharing Settings on the Win 11 PC and straight away the share became available in Roon, I then turned it back on again and it stayed connected, just to be sure I disconnected it and was able to connect to it again so problem solved but what caused it?

Hi @raf,

It’s hard for us to say from our side but in looking at others issues surrounding SMB and Windows 11, you’re not the first to report this. There are multiple reports of this happening outside of the Roon ecosystem and the fix has been to either install it via Windows features or to disable/reenable the features to spur change.


Thanks for reply Wes, it does on the surface appear to be an issue outside of Roon but it’s seems to be only Roon that has the issue, my BluOS controller didn’t have an issue, Universal Media Server didn’t have a problem nor did other devices I used to connect to the share.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.