Windows Can't Find NUC

This is definitely a Windows issue, not a Roon issue, but I’m hoping someone has an easy fix.

Win 10, latest build; Roon ROCK running on an Intel NUC; ROCK set up as a networked drive as in the NUC setup instructions.

When I boot up the main desktop,Windows loads, all the apps load including Roon. Once everything has finished loading, Roon runs just fine (i.e. Roon accesses the NUC and can find the library, No problem so far.

The library Roon accesses is an iTunes library that resides in the NUC internal storage. I run iTunes from the desktop PC to input new music or do preliminary editing tasks. I have iTunes access the iTunes Library through the same path as Roon, i.e. This PC=> storage (\rock\data) (Y:)=> NUC internal storage

Even though Roon sees the library just fine, iTunes regularly tells me, “Can’t Find iTunes Library”. When I try to show iTunes the path, the network folder is inaccessible through iTunes. If I use Windows Explorer, it can’t follow the path either. Only after I log onto the NUC through the browser does something click inside Windows, which then allows Windows Explorer and iTunes to see the path.

This happens every time I start the desktop. Once I force it to find the NUC, it stays connected until the desktop shuts down. Next day, same thing.

Operationally this isn’t really a huge problem since I do have a work around, but it shouldn’t ave to do this.

Any ideas? Thanks.

Hi @robert_vanarsdall,

You are saying that you can’t access the ROCK Database Location at all when this happens? Even other folders like the Logs folder? Or does it only impact when trying to access the Storage folder?

Do you mean using your web browser to access the Web Administration page of the ROCK/NUC? Or something else?

You say you are using the latest build of Windows (version 2004?). On earlier versions of Windows 10, I did notice that my ROCK/NUC networked drive did not always show as being online in Windows File Explorer (the icon showed with a red cross overlaying it), until I clicked it in File Explorer. However, now with version 2004, I haven’t seen this occur again.

I may have inadvertently fixed this myself.

In trying to get a screenshot of the path from the desktop to the library on the NUC, I disconnected the path (Win Explorer=>disconnect). Unfortunately, I then couldn’t find a “reconnect” as the path had disappeared from Win Explorer.

So to add it again I used Win Explorer to “Add Network Location” under My Computer. I added the “Storage” folder on the NUC and it appears to be connected even on reboot.


Hi @robert_vanarsdall,

It sounds like mapping the drive sorted the issue out :+1:, I’ll go ahead and mark this one as [solved] but if you run into any other Roon issues, just let us know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.