Windows Defender Antivirus Cannot Enable Audio Devices

I just had to “allow access” when the windows defender program prompted on whether to allow RoonBridge access.

I’m getting no prompts, I need to tell my IT which program and ports for them to unblock.

Worth double checking “RoonBridge” is actually running via the task manager before you start Roon and also have a look at the ruleset in the Windows Defender Firewall settings in relation to Roon. Unfortunately the rules for Roon are inserted into the windows firewall as tcp&udp any/any which I suspect your IT department may not like.

Here’s a snapshot of mine…

Could you just clarify your network a little…where is the Roon Core actually running and when you say IT allowed Roon ports through the firewall which firewall would you be referring to?

The Core is on my NAS (LAN) and the firewall that IT is configuring is on my work machine. My internet firewall at home is configured by me.

I see that the exe file is called roonbridgehelper.exe but are there specific ports that they should open for this file?

Currently IT has opened ports UDP port 9003 and TCP 9100-9200. I can ask them to open all ports for these apps but I’m not sure if they’ll allow that on a permanent basis. Thoughts?

I’m also wondering, would HQPlayer be an option as well? Say, if I had it running on another machine in the network?

Ah ok…so everything is effectively on your home network, so the only firewall between the Core and your work machine is the firewall on your work machine, correct?

I’ve never found a definitive list of ports for Roon (but many posts) but I suspect you need more than what you have specified. I would also include udp/1900. Having said that its strange that it worked with Symantec. It would at least definitely be worth asking if they could open up all ports on the firewall for the Roon applications at least just to prove whether or not that is the problem (or better still just switch it off for a short period)

Correct, the firewall is on my work machine (Windows Defender). I had them allow the RoonBridge and add all the ports mentioned in this thread:

There is no difference so far. He has asked me to give him the firewall logs to see which ports are being dropped. I will do this next.

Any update from your investigations with your fellow Roon staff?

Hey @J_B ,

Roon uses quite a few ports, including randomized ones. While firewall logs may tell you the current ports, new features may get added that require different ports, so it is not a definitive list.

I’d like to see what your Roon logs show when you are in this state, can you please reproduce the issue and then use these instructions to upload a log set here immediately after the issue occurs?

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

Thanks

1 Like

Ok done. I couldn’t upload a zip because it was too large. Let me know if you need anything else.

Hi @J_B ,

Thank you for sending logs over, and for your patience while we’ve had a chance to review them.

It looks like you are making use of Realtek ASIO drivers according to the logs, we have sometimes seen these drivers cause similar behavior.

Can you please uninstall any Realtek drivers from your Windows Device Manager and instead try to use the Windows system default one’s and see if this helps to restore functionality? Let us know when possible, thanks!

I will try to disable them. But I was wondering, originally I was using my AQ DragonFly Black v1.5 and it was working fine. But now when I plug it in and try to enable I get the same problem (Roon interface crashing). Do you think that the DragonFly wouldn’t be having these problems if the Realtek ASIO drivers were installed? Or are they not related to each other?

Ok, I tried to uninstall, there is no difference. I should note as well that every time the computer reboots it re-installs the Realtek drivers again. Weird, but since Roon used to work properly before the firewall was switched I’m not sure the driver is the culprit.

Also, I was wondering if HQPlayer might be a possible work-around. It wouldn’t be a cheap workaround though…

Hi @J_B ,

As the next test, I suggest trying to wipe out the RAATServer install and start fresh, please use these instructions:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Ok, I tried it on both the laptop and the core and there was no difference. In fact I didn’t even lose the Audio Tab settings. It did create a new folder though (on the laptop not the core). But again, no difference otherwise.

Hi @J_B ,

Thanks for trying the Realtek ASIO driver uninstall. I looked over your case again and I noticed you mentioned this:

Roon requires more ports than just those to function properly and sometimes even uses randomly-generated ports, have you asked IT to see if they can add application-level exceptions in place, even temporarily?

They said they cannot do it on a permanent basis. I can ask for temporary to see what they say…

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.