Windows Defender Antivirus Cannot Enable Audio Devices

Roon Core Machine

Endpoint: Windows 10 Laptop

Networking Gear & Setup Details


Connected Audio Devices

AQ DragonFly Black
Logitech WASAPI Device
Internal Audio (Realtek WASAPI)

Number of Tracks in Library


Description of Issue

I’m been using Roon on my work laptop which has worked well over the past year or so. I’m grateful that the player software didn’t need admin rights to install (otherwise I wouldn’t be able to install it at all). The player just worked with no special configuration up until last week when my company switched from Symantec AV to the Windows Defender AV and firewall. When they switched to this I suddenly was not only unable to play music on my machine but I couldn’t even see the devices connected to the machine. (I can however still see the players elsewhere on my network and control them.)

My IT dept was graciously able to allow the roon and raatserver programs through the firewall and had them enable some UDP and TCP ports that people were talking about on the forums. Then I was able to see the devices in my Audio Setup (see image) but cannot enable them. It just says ‘Enabling…’ and when I try to rename the device Roon crashes.

Do you know why this is? Do you think it has something to do with multicast? I have it enabled on my router and, like I said, everything else works. However, I noticed a firewall rule blocking multicast:

And when I inquired about it and asked to remove the block, my IT said that since it is a corporate-wide setting that cannot be changed. They also mentioned that this rule existed with Symantec so they don’t know why it isn’t working now when it did before. So the multicast thing may be a red herring.

Are there any other options or workarounds here? I’ve searched around in the forums but haven’t found anything yet.

Thank you in advance.

Hey @J_B,

Sorry to hear that you’re having trouble on your work laptop with Roon. This does sound like it has to do with the security settings. Are there any other antivirus programs installed other than Windows Defender by chance?

Let’s start with a simple reboot of the machine and see if that helps. Power down, unplug, wait a minute or two, then give it another go. Then let us know if you see any change. :+1:t2:

No change. No other AV programs installed.

Do you have RoonBridge running and allowed through firewall?

No, would that help here? I can install it if it can be without admin privileges. But I don’t want to reach out to IT to allow thru the firewall until I know it is a possible solution.

I had a similar problem re. the enabling of local audio outputs and it turned out that ensuring the RoonBridge software was running seemed to fix the problem.

Ok, I installed it but there is no change. What ports or executables do I need to enable?

I just had to “allow access” when the windows defender program prompted on whether to allow RoonBridge access.

I’m getting no prompts, I need to tell my IT which program and ports for them to unblock.

Worth double checking “RoonBridge” is actually running via the task manager before you start Roon and also have a look at the ruleset in the Windows Defender Firewall settings in relation to Roon. Unfortunately the rules for Roon are inserted into the windows firewall as tcp&udp any/any which I suspect your IT department may not like.

Here’s a snapshot of mine…

Could you just clarify your network a little…where is the Roon Core actually running and when you say IT allowed Roon ports through the firewall which firewall would you be referring to?

The Core is on my NAS (LAN) and the firewall that IT is configuring is on my work machine. My internet firewall at home is configured by me.

I see that the exe file is called roonbridgehelper.exe but are there specific ports that they should open for this file?

Currently IT has opened ports UDP port 9003 and TCP 9100-9200. I can ask them to open all ports for these apps but I’m not sure if they’ll allow that on a permanent basis. Thoughts?

I’m also wondering, would HQPlayer be an option as well? Say, if I had it running on another machine in the network?

Ah ok…so everything is effectively on your home network, so the only firewall between the Core and your work machine is the firewall on your work machine, correct?

I’ve never found a definitive list of ports for Roon (but many posts) but I suspect you need more than what you have specified. I would also include udp/1900. Having said that its strange that it worked with Symantec. It would at least definitely be worth asking if they could open up all ports on the firewall for the Roon applications at least just to prove whether or not that is the problem (or better still just switch it off for a short period)

Correct, the firewall is on my work machine (Windows Defender). I had them allow the RoonBridge and add all the ports mentioned in this thread:

There is no difference so far. He has asked me to give him the firewall logs to see which ports are being dropped. I will do this next.

Any update from your investigations with your fellow Roon staff?

Hey @J_B ,

Roon uses quite a few ports, including randomized ones. While firewall logs may tell you the current ports, new features may get added that require different ports, so it is not a definitive list.

I’d like to see what your Roon logs show when you are in this state, can you please reproduce the issue and then use these instructions to upload a log set here immediately after the issue occurs?


1 Like

Ok done. I couldn’t upload a zip because it was too large. Let me know if you need anything else.

Hi @J_B ,

Thank you for sending logs over, and for your patience while we’ve had a chance to review them.

It looks like you are making use of Realtek ASIO drivers according to the logs, we have sometimes seen these drivers cause similar behavior.

Can you please uninstall any Realtek drivers from your Windows Device Manager and instead try to use the Windows system default one’s and see if this helps to restore functionality? Let us know when possible, thanks!

I will try to disable them. But I was wondering, originally I was using my AQ DragonFly Black v1.5 and it was working fine. But now when I plug it in and try to enable I get the same problem (Roon interface crashing). Do you think that the DragonFly wouldn’t be having these problems if the Realtek ASIO drivers were installed? Or are they not related to each other?