Windows-program crashes


(Roy van de Graaf) #1

@support
Being new here and having tried Roon now for 2 weeks (the latest version), I like it a lot, but the program on my core (Windows 10, 64 bit, 8GB memory Acer desktop) becomes inaccessible from time to time and then requires a restart.

I operate Roon usually from my Android phone, being downstairs, where the Roon endpoint is a Bluesound Node2, and that works well, everything being part of the same home network.

But from time to time the Android app reports it can’t find the core. This can only be solved by going upstairs, where my Windows computer is that serves as a core, then close the Roon program and start it again. (Reboot the computer is not necessary.) After that all is fine again.

The crash of the program does not seem to be triggered by anything, nothing that I have noted. I play music from Qobuz.

Thanks for any help.

Roy


(James Antognini) #2

I too occasionally find that my Roon app (on an Android phone or an Android tablet) cannot find the Roon core. I can usually cure the problem by rebooting the phone or tablet (killing the Roon app tends not to fix things). I’ve never had to reboot the Roon core computer.


(Roy van de Graaf) #3

Rebooting the Android phone doesn’t help, I really need to go to the attick, where my core is, close the program and start it again.

(The music however will continue to play as long as there is something in the queue. I can even pause the music using the Bluenode app, but I cannot start any new music.)


(Dylan Caudill) #5

Hi @Roy_van_de_Graaf,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

When the Android device isn’t able to connect to the Core are you able to connect from other remote devices?


(Roy van de Graaf) #6

Downstairs the network has a Fritzbox modem. The internet/network signal is transferred upstairs, to where the core is, by a Devolo powerplug downstairs and one in the attick. This all remains working, also when the Roon program has become inaccessible via the Android app.

I have no other device to remotely connect to the core. (My iPad won’t install the roon app, because that requires iOS 11.)


(Mr Fix It ) #7

If you move the core downstairs do you see the same issues? Power plug lan connections can be rather temperamental at the best of times


(Roy van de Graaf) #8

I could try that for testing purposes, but the desktop just is in the attick - and also operates Roon there on my Sonos. So it wouldn’t be a solution.

Also the network works fine for everything else. It is just that the Roon program on the Windows desktop computer becomes inaccessible for remote operation.


(Dylan Caudill) #9

Hi @Roy_van_de_Graaf,

Thanks for the info here. As wizardofoz suggested, we often see that powerline adapters are not the most reliable (which is noted in our networking guide). While it may not be a permanent location, it would definitely help to test without the powerline adapter in place so we can narrow down where this behavior is stemming from.

When the Android device is unable to connect are you able to use Roon on the Windows PC? Or are you unable to use it there as well?


(Roy van de Graaf) #10

I can still use it on the Windows PC, but in order to again have remote access from my Android phone, I close the program and restart it.
Being able to restart it remotely would also be a good solution…


(Dylan Caudill) #11

Hi @Roy_van_de_Graaf,

Since the Windows remote still works it definitely sounds like there is some networking trouble that is causing the Android remote to not be able to connect. I would definitely try with the Core connected to the router directly and see if there is any change. Knowing how things work in this configuration will help us narrow down where the behavior is stemming from.