Windows Roon Startup and Display Issues

Roon Core Machine

Windows 11 PC, running a 7950x3d, 4090 FE
32 GB of gskill RAM
All drivers for these things are up to date and so is windows.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue


I have been having issues running Roon, every time I try and try and open Roon on my computer I cannot get it to launch.

followed all the steps here

The only thing that got it to work was uninstalling the display drivers and reinstalling but that was only temporary. It still will not open at all.

It also makes my displays flicker when it is in use and this is over the course of multiple graphics drivers that I have been having this issue.

Any guidance on this would be appreciated.

Your Roon Core is on the Windows machine, not a separate Core like a Nucleus, ROCK, or a separate computer with a Core running?

And how does the Roon Bridge come into play that you mentioned in the topic title? It doesn’t appear anymore in your description. Are you sure you are using Bridge?

Just using the normal roon app on windows but I resolved the issue by deleting appdata and reinstalling just now.

Well it is doing is not loading again the standard Roon App on windows worked for a bit but stopped even after deleting the app data. Also having issues when it works with causing display flickering probably due to my adaptive sync

I edited the title of the topic and removed „Bridge“ because Roon Bridge has no GUI and hence doesn’t flicker :slight_smile: Just to avoid people getting the wrong idea

1 Like

Thanks that was my bad seemed to have mistyped in the title. Still not able to get Roon to work properly on Windows. Seems that uninstalling and installing again will get it to work but if I close the app or reboot the system it will not work again. Currenly have it running and will not close it but this is inconvenient. I have the roon log of the crash not sure if any guidance can be provided I would love to fix this issue so I dont have to uninstall and reinstall roon every time I want to use it

Yeah sounds annoying. Let’s see what support says but it may be a few days until they get to this thread

Hey support any updates on this??

Hi @Andrew_Kling ,

Apologies for the slow response here.

It sounds like you have multiple monitors for your Core setup, is this correct? I wonder if you could be running into the saved_window_pos issue, please see the solution for this in this thread: