Windows Server 2012 R2 [Solved]

When i try to run the program on my ESXi server with Windows 2012 R2 it wont start it just gives me a “Fatal Error”

GL_ARB_framebuffer_object OpenGL extension is required. Your OpenGL drivers need a upgrade or video card is not supported.

i only need my win2012r2 as a server the players will be my 2 computers and my iPad and my Android phone!

I have the same error.
I’m guessing you have the native windows display driver, not a ’ real’ one, like me.
I didn’t install the real one for my NUC, as it killed running it headless without a dongle. Now need to see if it works with the full driver set and if so, dig out the dongle.

We don’t explicitly support Windows Server 2012, and we don’t test on that platform either.

mfplat.dll provides the media subsystem, which (for obvious reasons) Roon relies on. It seems that on server builds of windows, this isn’t necessarily included.

Try installing this package, and let us know how it goes:

yes its a headless server without a “real” GPU its just a supermicro server motherboard with a “Matrox G200eW 16MB DDR2 graphics”


it can’t be installed it wants me to add a new server rule called “windows server essentials experience role” it includes webserver IIS and .net and like 20 other functions i don’t need.

Unfortunately this is the only workaround I can offer and you’ll have to install the required components. Server versions of windows are missing required audio and video components and the package I pasted above is the best bet for you to get this to work, but again, we don’t officially support server versions of Windows. Sorry for the inconvenience!

I got it to work, streaming to my Meridian 861 ID40.
Installed the package suggested by @kevin but that didn’t do it.
Next I ran the NUC graphics drivers and… lift off.

Now just need to see how i can get it to run headless again (and test it on local audio out).

Will also remove the server role and package to see that the only thing needed is the graphics driver package.

Removed the media package and role… Roon starts, no messages, however, music not added to queue and no sound.
Which means, as @kevin already suggested, it needs the media package and role (with all the associated nasties of domain install etc).

But still for me the problem still remains. i run my win2012r2 as a virtual machine. that means a virtual graphics card.

IMHO the OpenGL problem cant be resolved by adding that role. it will however resolve the functionality of Roon when its actually starting.

i just want to first get rid of the OpenGL error. then if i have to i will give the server role path a test.

the only computer in my appartment thats always on is my server and my Meridian MC200 so i still need Roon server to run on my server to access my music stored on my virtual win2012r2 (raid card)

I have an Intel NUC 54250 running Server 2012R2. I get the same error message as in the beginning of this thread.

So it appears from the other posts here, that I need to install the Server Essentials Experience, and then the patch from Microsoft.

start with graphics driver from Intel.

Have the latest driver installed - May 2015 Pack. Same issue.

Ok, here is where I am at:

  • Running Windows Server 2012 R2 on an Intel Nuc D54250WYP
  • Installed the Windows Server Essentials Role
  • Installed the wsemp package as suggested by @kevin
  • Installed the latest Intel Graphics driver
  • Installed the latest nuc bios
  • Installed Roon on the Nuc
  • Installed splashtop streaming server
  • installed splashtop personal on my ipad
  • Installed Roon on my imac set to connect to remote

And… it works.
Negates the purpose of running server 2012 (light footprint etc) as it now runs a whole stack of stuff I don’t need, but it works.

Roon will not run under remote desktop as that doesn’t support opengl.
Which means you cannot start it with remote desktop even if you want to use it as a remote ’ core’ service (hence splashtop to log in remote and start it).

I found the same thing with RDP and trying to run Roon. RDP generates the OpenGL error.

Once I hooked it up to a monitor/keyb/mouse, then Roon would start. But as soon as I tried to add a folder, I got: You need or missing MFPLAT.DLL (part of server experience).

So still deciding if I want all these other features on 2012 just to run Roon…

I tried installing Experience Feature, but getting an error, so looking into that too…

I also got an error on the experience feature, just ignored that, you need it installed to install the media package, it doesn’;t need to run (perfect).

Try splashtop personal so youc an remove the monitor.

Thanks…With my error, Experience is not being installed. Looks like issues with the component store and a reload will fix that. More to consider.

I may just install Roon on another computer to play around with it for my 13 day trial.

still nothing i got my Matrox (integrated) card working but still get the OpenGL error… damn i want to give Roon a try but i’m starting to lose hope…

there should be a server-only part of Roon that don’t need OpenGL then everyones windows server problems would be gone. Most raidcards only got Windows Server drivers so… yeah…

Hi guys

i’ll have a look at it over the weekend.


1 Like

did you find anything?

NUC54250 Kit - May 2015 Bios and Video Drivers

I changed from Server 2012r2 Standard to Server Essentials - I was running a trial, so changing not a big deal and when I do purchase license, it will cost less.

Any way, after essentials, I put in Experience, then the Essentials Media Pack. Then changed accounts (two accounts/logins - removed the Experience account and profile files)) so now I just use my main Admin.

Got Roon up and running as the CORE on my NUC. Using Wadia Di122 DAC (Wasapi) drivers. Music plays file (24-192) even when still importing. Tried playing from Remote PC, music played.

I have had a couple of instances where the music just stopped playing. I was poking around the interface/settings on NUC and from Remote both times it stopped. Funny as I just typed that sentence, the music just stopped again, but I was not doing anything with settings. I will have a look at the logs and see if it says anything.