Won't Launch Unless I Unplug 2nd Monitor

Core Machine (Operating system/System info/Roon build number)
I built a new computer and restored my Roon backup from my old core machine. Fresh Windows install, all new components.

Windows 10
32gb ddr4 ram
Nvidia 2080 Super
Samsung 970 ssd

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Using wifi built into Asus Strix z390-e motherboard. Router is Netgear Nighthawk X4S.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Schiit Modi 2 Uber for computer speakers
Schiit Jotuneim with headphones

Description Of Issue
I have two monitors I use with my core machine. A Dell and an Asus, both 27" 1440p. If I only have my main monitor plugged in, Roon loads and works without any problems. Anytime my 2nd monitor, the Dell, is plugged in, Roon will briefly display the initial splash screen on my main display, then open the app on the 2nd monitor but only shows a black screen and won’t launch or display anything. Clicking on the window gives the “Roon is not responding” error message. I have tried reinstalling Roon several times. Unplugging the 2nd monitor makes Roon work fine, and shows the splash screen on the main screen, then loads the app on the main screen.

Try updating your video drivers? Especially for that second output, if it’s a different card. My guess is Roon is hanging because it uses a video game shell that may somehow not like the video drivers.

Did you have the same monitors and video card(s?) on the old machine where Roon Core ran and from which you took the backup?

In any case, I’d try uninstalling (not turning off) the second monitor (use Device Manager, C:\Windows\System32\devmgmt.msc, targeting the Monitors node). Then you might try starting Roon; then you could try re-installing the second monitor (again via Device Manager). Once the second monitor is reinstalled, see if Roon behaves as you expect.

I have tried both the newest Nvidia Game Ready driver and the Nvidia Studio Ready driver and neither of them worked. I initially thought I was having issues because one monitor was 1440p and the other 1080p, so I bought a 2nd 1440p monitor but that didn’t fix it.

Messed around with the monitor drivers, no luck.

I “fixed” it by starting over from scratch and not importing a backup. Now it is working fine, although I have to reconfigure all my devices and settings. Not a huge deal though, thanks for the help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.