Wrong Roon version for database

Roon Core Machine

Intel Nuc: 7i3DNK1E / 8G RAM / 256 SSD running ROCK
2018 Mac mini / 16 G RAM / 250 G storage
Music stored on Bluesound Vault

Networking Gear & Setup Details

Ethernet via Netgear CAX30 (Comcast service) / No VPN

Connected Audio Devices

Bluesound Powernode 2i via ethernet / Bluesound Node 2 via ethernet / Peachtree DAC-IT via USB

Number of Tracks in Library

5,000 tracks in library. Mainly stream via Qobuz

Description of Issue

I just bought a used Intel Nuc so I could run Roon via ROCK. The installation seemed to go smoothly until I needed to migrate my music files and settings. I couldn’t get Roon on my Mac to connect to the ROCK machine after trying to use the backup usb. I also updated Roon via a prompt that came when accessing the ROCK machine via the Mac mini. Now I am getting this message when I start Roon on the Mac:

Please advise the next steps. I appreciate your time. Thank you.

What versions are being shown for your ROCK? I know you said it prompted for an update, but go to http://rock in a web browser. What versions does it show? (post a screenshot).

You can also click the Reinstall button under Operating System which will update everything


It’s 2.0. I think the problem may be with this used Nuc- it might not be compatible with 2.0.

We need to know the build number. Please post a screenshot

That would not cause a database incompatibility.

Manufacturer: Roon Labs
Model: Roon Optimized Core Kit
RoonOS 1.0 (build 256) production
Serial: 54B20315016B
Hostname: ROCK

Let me know if you need some other screenshot- thank you for the prompt reply!

On the admin web page (http://rock) of the ROCK there are two version numbers, one for the RoonOS, which in your case is 1.0 (build 256) production - which is OK. And then there is the Roon Server Software, which is 2.0 as you said - but there should be a build number too. Should look something like this (but yours will be different):

1 Like

Got it:

OK, thanks, I was kind of afraid of that after you posted the RoonOS build number, which was already current. Because this one is current, too. But it’s good to have it confirmed.

In most cases like this, the issue is simply that the ROCK is not fully up to date, because the installer in the download is not the very latest version, and so it can’t load a database that was created with a more recent version.

Your case is different, though, and I am not sure what’s going on. What exactly where your steps that brought you to this state? I can’t really follow what you wrote in the first post. Did you follow the steps from here (or what did you do differently, if not?)

I installed ROCK on the Intel. Before that, I backed up the latest files to a flash drive.

I started Roon on the Mac. I never had to log back in, so I did not get the link to restore. When it connected, there were no music files so I tried to install the saved files without success. Each time after I tried to use the saved files, I could no longer connect to the ROCK. I would quit Roon, restart and reconnect to the ROCK and try to install the saved files again. It never worked.

After another failed attempt, I ended up with the “wrong version” message and am no longer able to connect to ROCK…

Update: solved. I deauthorized the ROCK and turned it off, then reconnected my old setup- which worked fine. Then I disconnected the old system, reconnected the ROCK Nuc, deauthorized the old system. Then I restarted Roon on the Mac and voila- everything connected and the files were included. Not sure what caused it to work. Thank you for your time and patience.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.