Yet another Rock won't play Tidal MQA thread

I’ve probably read every single thread and tried every suggestion made there without positive results. Using Tidal within Roon with a Roon Rock as the source to play Tidal MQA simply will not play anywhere near reliably (“loading too slowly, connection or networking problem”) and yet it WILL play just fine using Tidal alone on the same devices. More details:

Rock is an Intel NUC7i7BNH, 256 GB SSD and 8 GB RAM with my library stored on a 2 TB internal disc.

Rock has a wired connection directly to my router.

Config 1 is to a PSAudio Direct Stream DAC, also via a wired connection directly to my router. Signal path here:

Config 2 via a Roon endpoint playing via the Roon:

Playing Tidal directly (using Mconnect) to the PSAudio DAC is perfect. Similarly, playing MQA files Tidal on the Windows PC (WinPC in the picture) is perfect.

It simply does not play MQA files. I’ve tried changing the buffer size (everything from 0ms to 500ms) to no effect. DNS server is google (, I’ve also tried Neither had any effect. I’ve tried making the PSAudio DAC a renderer only.

Nothing I’ve done has yielded any positive benefit.

Appreciate any tips.

I am in the same boat. I am running Roon via the Nucleus, and regular Tidal Flac files play just fine. Anytime I play an MQA album or track, the endpoint (a Logitech SB3 feeding a Musical Fidelity DAC) and Roon show the track as playing but the DAC starts blinking, meaning it isn’t receiving any digital signal. Switching back to a Flac file results in no sound. I then have to power off/on the SB3 and then FLAC plays normally again but nothing on MQA files.

The MQA threads noted that the endpoint needs to have MQA disabled but I’ve tried all the settings and nothing works. Multiple reboots too. MQA seems to not like my setup.

Hoping to figure this out.

This is definitely frustrating.

I think it’s highly likely that what is going on is conflicts between Roon and Tidal in terms of their demand on the network to satisfy what are probably different buffering strategies. Admittedly, my broadband connection isn’t the fastest in the world (I live in the sticks and have a DSL broadband connection) but it’s obviously sufficient to satisfy Tidal MQA alone. My wired LAN is gigabit with a very fast router (Asus) and the other devices in question (PSAudio, NAD 758, etc) are certainly fast enough.

Interestingly enough, I have a small Digital Audio Player (a Pioneer XDP-02U) that will play DSD and other hi-rez audio formats and it will play Tidal MQA over it’s own internal WI-FI perfectly even when it’s own WI-FI signal strength indicator shows a very weak signal so it doesn’t seem to be a network bandwidth issue but rather conflicting buffering strategies as I theorized above.

Frustrating, to say the least.

I have a Direct Stream DAC with a Mac Pro and Tidal. I had to select the volume control on the bottom right, then select the setup icon on the right of the pop up, then Device Setup. Select Advanced and then disable Enable MQA Core Decoder and the problem goes away. I hope this helps someone.


Martin Power

Take a look at this post for more information.

OK, my buffering theory is blown but the problem remains…


I’ll experiment with Roon doing the first decode and the Bridge II doing rendering only later today. I think I’ve tried this in the past without success but I’ve tried so many things I’m not certain. I’ll report back once I’ve tried it.

I did try this setting. No joy.

I don’t think so. MQA files are huge compared to normal CD files, so with Tidal playing through Roon you have to buffer the whole before playback begins, the size is causing your incoming network bandwith to choke, hence, “loading to slowly”.


Although it makes sense that “huge” MQA files might exceed my network bandwidth wouldn’t that also be the case for Tidal standalone? As I said in the OP, this works flawlessly.

It appears to me therefore that there is some interaction between Roon/Tidal buffering and/or their demands on the network.

Edited to add: and before someone asks the obvious so why don’t you just play Tidal directly and not use Roon, the answer is twofold:

(1) This doesn’t work for the system that’s directly connected to the Rock (Rock can’t play Tidal standalone).
(2) I have a lifetime Roon license and prefer the interfect

Not really, Tidal standalone as far as I understand, streams the file in smaller pieces and begins playing after a few seconds of buffer, Roon is doing a total download first, then playing the file.

If this is the case, then it appears I’m correct that it’s an interaction between Roon/Tidal buffering and their demands on the network. It would seem to me that a reasonable flow control algorithm between Roon and Tidal would accommodate their different buffering strategies i.e., if Roon wants the whole file but Tidal downloads in smaller chunks that either Roon would pause playback at the start of a new track until Tidal had downloaded the whole file or Tidal would download larger chunks when demanded by Roon. They are supposed to be “integrated” after all.

Personally, I’d be willing to wait between tracks for the entire track to be downloaded if that’s what it takes for uninterrupted playback inside Roon.

I’m still hoping there’s some solution to this. I want to use Roon and I want to use Tidal, including Tidal MQA inside Roon.

I can sympathize. For what it’s worth: a year ago I had the same problem, until one day it vanished. I concluded it all happened upstream of my router.

Hello @Greg_Smith1,

I’m sorry to hear you’re having trouble with this, I see you’ve already tried a few troubleshooting steps and haven’t been able to get things working yet. I’m going to request a set of diagnostic logs from your Roon Core for further investigation by the tech team. I will be sure to reach out once the logs have been uploaded and the tech team has had a chance to take a look. Hopefully, they’ll be able to definitively say where in your playback chain the issue is occurring so we can focus on getting this working for you.



Thanks for your reply. When you say “I’m going to request…” does that mean I’m supposed to be providing them or do you have access to them via some other means?

They get them.

Hello @Greg_Smith1,

I have checked our diagnostics system and I see that the report from your machine has still not reached our servers. Is your ROCK still powered on and connected to the internet? I have re-submitted the request for diagnostics but if it still does not come through, can we please ask you to manually send us the logs from your machine using these instructions?


Hi Noris,

I was hoping that the upload of the logs would happen more quickly. I’m not at home and won’t be until early April. I will upload the logs at that time.

Since this forum automatically closes threads with no activity in 30 days, do I need to keep posting updates to keep it open or is there some other way of tracking this problem and (hopefully) it’s solution?

Hello @Greg_Smith1,

If this thread gets auto-closed, you can PM me directly and I will re-open it when you are ready to continue troubleshooting. Safe travels!


Hi Noris,

Following up on this thread as I still have the problem (more below) and have some time to try to resolve it.

The situation with Roon/Tidal is essentially unchanged from what I’ve described above. I can play Tidal MQA fine using the mconnect app but not within Roon.

I recently signed up for a trial of Qobuz studio. I tried to play some hi-resolution files inside Roon without success. I also tried playing them via mconnect. I can play 24-bit, 96 Khz just fine within the mconnect app but higher sampling rates won’t play without problems. I therefore set the max sampling rate to 96 Khz in the mconnect rate and it downsampled and played any and all files without difficulty.

Based on that experiment, I tried the same thing within the DSP settings on Roon. No joy, any higher resolution files I tried to play failed to play entirely through without buffering problems and skipping to the next track.

Note that I’ve downgraded my Tidal subscription to regular resolution (not hi-res) since it didn’t make much sense to pay more for something I couldn’t play through Roon. I’ll likely do the same to Qobuz once my trial ends unless this can be resolved.

Hope I can get some resolution on this. It’s clear that even given my slow broadband that I can play Qobuz (or Tidal) hi-res via the mconnect app, I just can’t do it with Roon.