Zen stream to USB dac - no dsp volume option in Roon

I’m setting up a Zen Stream to replace my Allo USBridge, which I connect via USB to a Holo May dac. With the USBridge I used the dsp volume setting in Roon, but when I connect through the Zen Stream, Roon only gives me the option of fixed volume or device volume. As the Holo May dac has no volume control and I don’t use a preamp I have always used dsp volume control in Roon.

I tried the various volume settings in the Zen Stream app, but none made any difference as far as Roon was concerned.

Has anyone else here had this problem?


Thread about it here I think

That’s a know bug or maybe a deficiency of Zen Stream software.

That worked fine until firmware 2.30.7. Rollback to that version will let you use DSP volume in a normal way. I’m staying at 2.30.7 for that reason.

On the newer firmware (both offcial and beta) you can setup in ifi console Mixer Type to Software and in Roon set endpoint volume control to Device volume. That will work fine until you switch off your DAC :slight_smile:
Then ifi Mixer setting resets and you have to configure it again.

1 Like

Thanks Piotr. Much of the reason behind my decision to try out the zen stream was that I was getting tired of the need to tinker every so often with my USBridge or raspberry pi. Having to roll back to a previous firmware to keep a core, for me, functionality doesn’t fill me with confidence going forward that this device will be problem free.

Good to know the cause of this issue though, and thanks for sharing you solution.


Thanks Ged, I’m not sure if that is what’s going on here, as I thought Roon’s dsp volume control was a Roon function not an OS function, and that Roon claims that there is no degradation in quality while using it.

On the other hand it could be exactly what’s going on here and ifi have intentionally disabled dsp volume control within Roon when connecting to a usb dac. Either way the Zen Stream seems to be incompatible with my use case.

Thanks for sharing the post from ifi, I was unable to find anything like that on their website.

I wasn’t sure if it was relevant or not. Sounds like @Piotr_Pekala knows far more.

I fully understand that. It’s really frustrating to deal with such problems. Software quality is definitely not ifi’s competitive advantage…

I’s even more frustrating to deal with ifi support that doesn’t care about that much. It might be worse than Roon support :wink:

What I find especially frustrating is that I waited to purchase it until I saw that Roon were promoting it in there store and that it had received Roon Ready certification.

I don’t understand the point of Saying it is “Roon Ready,” when it is clearly not.

No biggie, I’ll return it and go back to my previous setup.

As far as I can see Roon ready mainly applies to using RAAT the exact specs on volume control etc are up to the manufacturer.

If your using a streamer or DAC then volume control is pretty much out unless they allow control of it, most devices that are purely digital don’t offer a volume control. DSP volume relies on the host device being able to run it as its done on the device using the RAAT SDK not via the core if I remember rightly.

That seems to be true, when using a Roon bridge device.
or any Roon ready device

But my USB DAC (SMSL M300MkII) is directly connected to the core with DSP volume available and working, handled by the core in this case.

Your core is the RAAT endpoint in your example though.

You’ve got a point there


I seem to be only able to control Zen volume with roon DSP when the device is in AIO/setup mode 1.

When I switch to Roon Ready mode 2, the volume control defaults to fixed and seems no matter what I do, I cannot find a hardware or roon setting to re-enable roon volume control.

Anyone found a solution to this problem?

Really perplexing/disappointing and seems a bit odd that ifi would intentionally disable the 64bit/lossless volume control built into roon.

I guest it can work:

But I’m still on older version to avoid that problem at all so cannot test it.

I use only mode 2 (Roon) (v:2.31.7), not sure what to test. Roon DSP Volume? It works, but not for DSD
For DSD I get only:

So change settings in browser:

and it works
Screenshot 2022-12-09 at 16.28.43
Signal path when using dsp volume:

Hope it helps

That was an answer to the Jack_Neber’s post above and not to you :slight_smile:

Ops… Sorry. I did not read closely, Zen Dac is in my topics but not dsp volume :slight_smile:
All the best

Thanks Piotr!

I’m using spdif output. I will try your solution. any advice on how to revert to older firmware should I again run into a dead end?

Best -

With that linked trick you should be able to change Volume from Fixed to Software. That will work (until you switch DAC off…) as DSP volume.

To revert to version 2.30.7 you need to have an image based on older firmware and some software to reflash device. I’ve got it from ifi support.