1.2 no longer plays on Metric Halo LIO-8 [solved]

I use headless mac mini with a metric halo lio8 for a dac. Music stored on a sinology NAS with ethernet connection. All was well until the upgrade. Albums all show but when you elect to play -all songs on the album seem to stream by very quickly at bottom bar but no play. A new small box near the bottom shows playing tracks and undo but nothing plays. If you choose the radio function an endless listing of of songs are near the bottom bar displaying but no play.

Thanks Robert

Mac mini is using OS X EL CAPTAIN

Hi @Robert_Dibble – can you let me know how your DAC is configured? Screenshots like the ones here would be great.

Let me know how you have things set up and we’ll figure this out. Thanks!

Don’t know how to screenshot but it is set with: Not in Private mode/ device volume control /0s resend delay/Exclusive mode/max sample disable/max bit disable/dsd convert to ppm.

Hope that helps

Have you tried to power-cycle DAC, restart Roon?
Can you also try to enable Integer mode ? – You can find this option right under the Exclusive mode.



Tried restarting and actually taking the lio8 out of the mix. Won.t play on just the mac mini and system output. The album and radio just flashes all the items on the list but no play–after displaying all the tracks, the play button on the lower bar is greyed out. so no play ability

9 posts were split to a new topic: Mac System Output doesn’t play when connected to 48k-only Bose USB Device

I took a look at your logs, and I see the problem. When Roon asks your device what formats it supports, it tells us that it is a monaural device. This is why Roon doesn’t know how to play to it. We are expecting stereo or more.

1.2 included some re-architecture work, and among those changes, we started asking audio devices “what can you do” and using the answers that came back. Roon in 1.1 didn’t rely on devices telling us the truth, but that limited our possibilities both now and in the future as we add more DSP features and that approach had some crude side-effects that we’ve moved past from.

Since this is clearly not a monaural device, it’s likely that the device is mis-reporting its capabilities to us, perhaps due to a buggy driver or device implementation.

Do you have any idea why it might be telling us it’s a monaural output? This looks like a pro-audio product. Sometimes those things have extra settings or control panels that can be tweaked with.

The first thing I’d try is upgrading the drivers or firmware for the device if they’re not already up to date. Maybe we get lucky and Metric Halo have already fixed the problem.

If that doesn’t work, we have options on our end to work around the device behavior, but they are not pretty. Lets see if we get anywhere with the device/driver/settings/firmware before we go there.

I updated the drivers but no change. I contacted metric Halo and tried changing some settings but still no go. He said you could contact him directly to work something out. enclosed is Jon’s message:

Dear Robert,

Thanks for your email. The current software can be downloaded from this page under “Current”:


The current version of MIO Console is 5.6.07d219, and the current driver is 5.4d232.

What might be happening here is that the Roon software may be making assumptions about how the drivers are presenting audio streams. The LIO-8 driver does stream 18 mono streams which provides the fully routable MIO mixer with maximum configurability and flexibility. Software host applications should be able to recognize and parse mono streams.

A useful test would be to remove the firewire assignments from any mono strips in the MIO mixer, and to assign FW 01/02 at the direct out on the Main bus of the MIO Mixer. This should send a two-channel stream to where it needs to go.

Please let me know how this goes. We are open to fielding any questions that Roon may have regarding this.

Best regards,

Jon Stern
Metric Halo Support

Thanks. He’s right–we read the capabilities off of stream 0 of your device and ignore the other ones. We did that in 1.0 + 1.1, too, but we didn’t act as strongly on the data we got back.

Multi-stream devices are only really a thing in the pro audio world–which isn’t where we focus most of our effort. It doesn’t help that pro audio companies usually won’t send us gear for testing/eval because they are in a different market.

I’m sure we can get this working…need to give it some thought how we’re going to get there. We’ll also reach out to them and see if they can send us a unit.

Thanks, they are quite good folks and he said he would wait to here from you. I don’t suppose I can roll back somehow to 1.1 so at least I can have music until this works itself out?


There seems to be some confusion. I have Bose 5 speakers, consumer products sold for $400. There is no driver - these are just consumer USB speakers, not pro equipment. I’m not sure what Metric Halo would have to do with my speakers… Thanks

No confusion here. I moved your posts to a separate topic because it is clear that these are unrelated issues.

OK. I got a response from you about my problem talking about Metric Halo. Not sure what that was about. Thanks.

Ah, I think you are still subscribed to this thread because you posted here before–so you’re getting updates. There’s a little Tracking dropdown at the bottom of the page that you can use to turn that off:

I too have a Metric Halo LIO-8, and like Robert, would like to know if it’s possible to roll back to 1.1 while this issue gets sorted out?

Also, for interest’s sake, if Roon is ‘looking’ at stream 0 in the expectation of sending or to verify that it can send a stereo signal down that stream, when Roon actually sends data are there headers on the data packets that distinguish right channel from left, or ?

I’m really showing how little I know about how the data is sent from Roon (or any DAW/player) to the DAC…

In case anyone else is having any similar issues, I just wanted to let the forum know that @mike has been in touch to check what version/OS/etc I’m running, preliminary to sending specific instructions for rolling back, and I would imagine he’d be happy to do so for anyone else with this problem.

I know this has been mentioned many times elsewhere here, but I too am very impressed with the quality, speed and tenor of the support provided by all at Roon. Uniquely responsive, in my experience, so thanks very much.


Build 128 is out.

While it’s hard to be 100% sure that this is fixed without access to the hardware, we put a workaround in place based on our understanding of the problem.

We’re in touch with Metric Halo and are encouraging them to send us some gear to add to the our collection. We’d love to add one of their products to our testing line-up so that we don’t break them accidentally again.

Thank you all. So far build 128 is working well. Thanks so much for your patience and expertise. I know it is for a small subset of your subscribers but this is above superb customer service.

1 Like

I’m echoing Robert’s comment - 128 working here, too. Thanks for the very quick resolution to this - very happy indeed.

Cheers, John