1.3 install - windows 10 - Surface Book - white screen - both GPUs

@support I am new to Roon - just installed - on an i7 Surface Book.
100300196 1.3 (build 196) stable

Says install was successful - when I run - as user or admin - with the default intel gpu or the NVidia. Have approved firewall requests. Have tried with external monitor and also with just the Book’s monitor.



1 Like

It looks like a known issue with some graphics cards/drivers. For some reason, the screen does not get redrawn under certain conditions. Have you tried resizing the window to see if that kicks the redrawing to occur? It’s a workaround that works for some of us, but I agree it’s annoying.

No love there - if I resize this is what I get - running a ton of other stuff, have never had this problem.

Confirm it will install and run on other machines, but no love on the Surface Book. Is there any logging or other things I can do to help determine the issue?

Anything I can run to determine driver compat.


@danny, I think this is for you to investigate. I know that we had this problem with some older GPUs, but the Surface Book isn’t old.

I’m having the same problem on an i7-3770K CPU and that is still a very popular CPU today.

It is working fine on my i7 surface book

I haven’t any problems with i7 surface book and roon 1.3, too.

Are you using a beta version of Windows 10?

Yes - I am on the Fast Ring - but that should not have any effect - no changes in video drivers

For the others who have it working - were you running Roon prior to 1.3 - or prior to Windows 10 - I am starting from scratch here

@support - I am still using the trial here - can we make sure that I get 15 days of trial time… after the application starts working for me?

Absolutely. Drop me or @kevin a message when things are stable (or if your trial is close to running out) and we’ll make sure you get a full trial period to use Roon once things are resolved.

1 Like

I thought so, Nick. I’ve seen problems with the last two builds and non-Roon OpenGL apps (e.g. Zwift), so I don’t think this is Roon at all. You should report it to Microsoft as well…

Reported the problem - am seeing others report it too for other applications. Can you tell me more about what version of OpenGL you are using?

@support @kevin suggested that I tag this thread - I have cancelled my trial until the OpenGL issue resolves. Will happily come back and give Roon a solid try when the fix arrives - from where ever. Best, Nick