1.8 has serious bug on Android

Memory insufficiency I guess could perhaps be a factor. That is something that the developers should know, I would think. If it is a problem, that should be called out as a requirement, right? You know, when 1.8 runs, it runs very well, quite a bit snappier than 1.7 on the pickup after it has shut its screen off, and screen is activated by the power button push. On the whole, I quite like the new version in a lot of ways. I never have a problem, until I switch back to main page or another app, and then attempt to come back. Then all hell breaks loose…

Jan have a look at this thread, it explains what you need to do to change you’re phone from finding core by name to finding core by IP address

Hopefully this will help

Mike

Jan yes I think this is becoming more of an issue.
I had no issue before 1.7 with my 1st gen 11" iPad Pro swapping out, but a combination of Apple and Roon means it is constantly swapping out when I have not used it for 2 minutes.
Thankfully my OnePlus Android phone allows me to fix this and I have no issue at all, as I have locked it in memory and disabled battery optimisation.
I just wish this was more reliable all round

Mike

Sadly, no. I don’t seem to have a help option on that choosing a Roon Core screen, so no way to specify the IP address.

Jan in that case Uninstall and reinstall the app as you should be able to press help and enter the ip address just like in the link I shared with you.
This screen normally appears when it client can’t find the core.

I have had many people go through this and it hasn’t worked for all of them, but it has for many

Mike

Nope, no help screen. Just the usual screen that shows my core machine name, the OS it is running (Linux), ip address, and a nice blue connect button. No help.

Jan can you send a screenshot?

Just to be clear, the last post was after uninstall and reinstall. If help only appears if you can’t find a Core, it make sense that it wouldn’t show when I install, because it clearly can find a Core without me doing anything.

Yes, I think I can without showing any sensitive data.


Visible, I hope.

Jan I just installed Roon on my wife and sons phones and both came straight up and worked instantly, so I cannot get the screenshot I was going to send you.

Mike

Is that an Android tablet screen?
So your device find the Core right away, and what happens after when you press connect?

Yes, that’s my pixel C screen. After I press connect, I get the welcome screen with a button that asks what audio zone. The welcome screen shows how many albums, artists, etc in my library, what I last played, all from the core I chose, I guess.

Do if you select your zone what happens?

I have just grabbed my Pixel C, which I have not turned on in the last year. It’s now on charge

Somebody else was asking a question about it yesterday

Jan I just got my Pixel C going again and uninstalled Roon and reinstalled it again

I get this screen as expected.

If I pick my Core it just starts up and asks me to select an Audio zone to play music

Then I just start playing music

So what do you see differently?

Mike

I am using a Samsung tablet running android 8.1.0 and 2 GB of memory. I have no problems at all. What does strike me is that most, if not all people reporting problems are running their core on some computer or other. I have a Nucleus. Could that be a factor? Are there nucleus owners out there with similar problems using tha app on android? I’m just sayin’…

So I got the trusty OLD Pixel C out of storage and it works fine.
It is soooooo slllloowwwww though and the WiFi on it keeps disconnecting, but Roon works perfectly as long as WiFi is connected

I literally removed almost 90% of the apps on it , doesn’t even lose connection after I turn it off for a few minutes.
I might just keep it running as a Roon Remote to test how the changes improves things over the next couple of months

Mike

Leo that’s exactly what I was trying to work out for Jan but it works perfectly on everything I have, even this 7 or 8 years old Pixel C.

I think some of it is networking and some of it is Android and some of it is Roon
But generally when you get someone to follow all the steps is eventually works

Thanks for your input as well

Mike

Yep thats the way my app works too. The problem occurred when I switched to the home screen to start another app, like take a look at my weather station, then back to home screen, and connect back to Roon again. In 1.7 the music would be playing continuously during all this. The problem showed up when the music stopped if I went back to the home screen. Everything else seems to follow from that.

I don’t think there is a difference between Nucleus and my NUC really - the amount of work Roon needs from me (no audio processing) means the load on the Core machine is extremely low, less than 10% at all times.

OK, that’s interesting. It appears to be acting correctly now.

All right, what did you guys do?! Seriously, all I did today was restart the tablet once, and delete and reinstall the app a few times. Nothing else.

Thanks to all for the info and suggestions. I’ll keep an eye on this though, because there was no real fix here. See if it recurs, and I’ll repost if it recurs.

Jan well good news for now then and I have an old tablet back from the Dead for a while at least

BTW none of us work for Roon, we are just users trying to help other users out

Mike

Hi @Jan_Martin

I’m glad that things seem to be working now! If you see any issues return let us know the time that you see it and share a screenshot, we’ll enable diagnostics and take a look at what is occurring at that time.