2018 Mac Mini High CPU Usage

I’m having similar issues here with a 2018 Mac Mini (i7, 16GB, 1TB SSD). I’m running Roon Server and there doesn’t seem to be any rhyme or reason to when and why it decides to jump to the top of Activity Monitor, spiking the CPU temp and fan speed. The only way to resolve it is to reboot the system entirely. Shutting down Roon Server returns things to normal, but as soon as I restart Roon Server (without a reboot), the CPU temp and fan speed spikes right away. It happens even if I haven’t been using Roon or running a client.

I recently migrated from a 2012 quad core Mac Mini and didn’t have any issues with that machine, but that machine was only on Catalina for a very short period of time before I replaced it with the 2018 Mac Mini. My library size is 10,469 tracks that are located on a Synology NAS network share. I’m streaming from Roon to either a USB attached Schiit Fulla 2 or a network attached Sonore µR in Roon Ready mode. Roon is fully updated and there is no file analysis or db backups occurring.

Note: I don’t recall this issue occurring after a reboot, but before the system has gone into sleep mode. My 2012 Mini was headless and set to never sleep.

Other than the fan on the Mac Mini blasting at ~4,440 RPM, everything else seems to work fine. It’s doing it now, but wanted to post this before shutting everything down and rebooting.

CPU temp / fan spike with no streaming, no Roon clients open:

edit: second screenshot shows what things look like running normally after reboot, Roon client open on same machine and playing a stream from Tidal on the Fulla. CPU temp minimal and fan running steady at ~1700 rpm:

I’m on a wired connection with WiFi disabled. Regardless, next time this happens I’ll try toggling WiFi on and off and see if it has any effect.


@support Me neither, toggling wifi (off/on/off) had no effect. The issue cropped up again tonight after applying the latest update earlier today. Restarting Roon Server didn’t help, I had to reboot the machine.

Same issue still occurring. Wired connection only.

Hi @mrvco,

I have split your posts into its own thread.

What we’ve heard from others is that turning off/on the WiFi adapter seems to resolve this behavior, but this seems not to be the case for you here.

How often would you say you’re seeing this issue? Once a week? More/less?

Are you doing anything immediately before this behavior occurs (such as navigating to a specific page in Roon or starting playback to a zone in particular)?

If you temporarily disable your Synology NAS, do you see the same behavior occurring with no NAS active?

@noris After a reboot, it takes multiple days at least for it to reoccur. It has occurred without using or interacting with Roon since the last reboot, just Roon Server running in the background. The next time it occurs, I can try disconnecting my NAS from the network and see if that changes anything.

1 Like

Had it happen this morning. I tried disconnecting the NAS from the network and that did not have any effect on the Roon Server process spiking the CPU+fan. I brought the NAS back online, Roon reconnected, re-scanned my library and was back to the same state. I rebooted and CPU+fan are back to normal now. Thanks!

Hi @mrvco,

Is this behavior still occurring on your end? If so, I would like to propose a test here, if you switch the Core back to the 2012 Mac Mini and keep just the Roon Client on the 2018 Mac Mini, are you still seeing the high CPU usage occur?

It hasn’t happened since the post on March 19th. Fingers crossed. Not sure I’ll have the time or energy to migrate Roon back over to the 2012 Mini, but I’ll see how things go this week.

This does happen far less frequently than in the past, but I did have another occurrence last night. I shut down Roon Server and the fan dropped to minimum and the CPU temp when down by half. Just restarted and everything is back to normal.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.