24 bit downsampling - how can I keep it "full fat"?

Core Machine (Operating system/System info/Roon build number)
Latest version of Roon running on an intel PC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
USB connection to DAC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Furutech ADL A1

**Description Of Issue"
When playing 16/44 files, the signal path is direct.

When playing 24 bit files, the signal is downsampled to 16 bit. The signal path shows this step and the “light” is green.

If I use DSP, I can send DSD to the Furutech. So it does recognise it as a hires device.

How can I get it to play 24 bit PCM?

It *could * be a simple settings change. Try this…

Settings>Audio >Furutech ADL A1>Device Setup>Show Advanced>Max Bits Per Sample (PCM)

If it is currently set to “16” change it to “24.” If that’s not it, I’m sorry I probably won’t be able to help.

Good luck!

Hey. You were right…but.
I have changed the setting to 24bit/192. Applied the settings. Turned off and on again.
I was convinced you had found the problem.
Green light still showing. Still downsampliing :-(.
I have checked, and it has retained the updated (correct) settings.
At least we have eliminated one problem.
I will keep searching. Thanks.

What is the DAC connected to and what os. If it’s an android phone forget it, Roon does not support anything higher than the devices system audio regardless of a DAC being attached. If not Android then it’s likely a driver issue. The DAC on my Hiby R5 will only go to 192/24 using WASAPI but sees the full spec up to 384/24 and DSD using ASIO.

Its a Furutech ADL1 connected to a Windows 10 PC (via USB).
I am sure it used to play 24 bit.
It is strange, because it downsamples the bit depth, but still sends at 44/96/192 frequency.
If I use the Roon DSP I can send DSD 128 to the ADL, so it does recognise it as a hires device.
But the green light shows it downsampling PCM to 16 bit.

Can you post images of all your settings in Roon for DSP, and audio settings for the device as well as signal.path. We might be able to spot something that might help.

If you are using ASIO, then verify the bit depth is not set to 16.

See this thread…

Al Schmidt got me to the audio settings.
Via jRiver I can access the ASIO menu, but the only available setting is buffer size.
Interestingly jRiver tells me it plays at 24bit.
I am grateful for all these suggestions. I am trying them. It is a learning curve

Do you have exclusive control on in Audio settings, in Roon for the device. I can’t see that section in you images.

Well, the bit depth of ASIO is dictated by the ASIO driver, you need to set it in the driver’s control panel. The use of JRiver in the linked thread to set bit depth was a workaround because their driver did not come with its own control panel program. Look and see if you have a control panel program with the ADL software, my Asus device’s ASIO software came with its’ own ASIO control panel software, for example

I’d shoot a text to ADL tech support and ask them about setting bit depth of their ASIO driver.

(Note During the writing of this I went and downloaded the current driver install, I did not install it, but in the install there is the following shown)

See if you have a VIA ASIO control panel already installed.

And, I am assuming that you are using the ADL driver for your specific device and not some other ASIO driver.

You wont, by definition ASIO is exclusive. So, no option.

1 Like

Did not know that. Another lesson learned. Shows I seldom use windows for audio output other than remote control of Roon.

1 Like

I am trying to keep up.
Through settings, the tab in the photo I already sent is ticked and says it allows exclusive control by another device. But that is not the ASIO driver itself.
I have checked I have the up to date (2014 vintage) driver for the ADL. The control panel is very limited

So I am learning. But still a green dot.

The latest driver on the ADL website, gives a data of 2015. It also states it is a VIA control panel, not DirectKS. Did those drivers come with the hardware or are they from a different software.

I would, like I mentioned previously, contact ADL tech support and ask them directly about which drivers to use and how to set them.

I used the 2015 link from ADL.
The jRiver just accesses the same control panel (which just gives the buffer size).
Why did it used to work in 24 bit in Roon?
Why does it work at 24bit in jRiver but not in Roon?
Surrly that suggests the device and driver are OK. Roon is downsampling before it reaches the output.
I understand the ADL is an older device and is not Roon ready, but it is usually a hidden setting somewhere.

I downloaded the 2015 ASIO drivers from ADL. I installed them even though I don’t have the hardware.

  1. On the desktop, the install program will create an ADL ASIO icon.


  1. Windows Search on Programs, type in ADL and you will get this.

If you are not getting either, then you need to talk to ADL tech support because the driver seems to not be installing correctly.

Remember, you will probably need to uninstall all previous ASIO drivers first.

You are right. I did have to uninstall the app before I could reinstall. But I already had the version you have. The icon is on my desktop and I can open it like you suggest. But it only allows setting of the buffer size.
I can select the different bit rates in the settings. The test lights up the 192kHz light on the DAC and all reports are showing healthy.
When playing jRiver it ouputs 24bit.
Of course, like most DACs, the ADL does not show the bit depth, so I cannot be sure.
I am not sure if in fact Roon is outputting 24 bit. However, it is still showing the green light. And I am sure it didnt until recently.

Dan, I did of course follow your advice. I am waiting for a response from Furutech/ ADL.
You can tell I am not quite understanding the problem. I suppose that is why devices are certified “Roon Ready”. To minimise these conflicts.

Well, to clarify, Roon Ready and Roon Tested mean very different things. In your case, the correct certification would be Roon Tested. Roon Tested means that the Roon QA guys had the DAC and ran it through its paces, smoothed out any issues with the manufacturer, like potentially the 16 bit issue.

Roon Ready means that the DAC has an Ethernet Port and can be plugged directly into the network and will work with Roon as the device is running Roon’s RAAT code.