26 second glitch/drop-off

Core Machine (Operating system/System info/Roon build number)
PC as Core, using the latest iteration of Roon.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Bluesound Node 2i, connected to an Usher pre-amp and power amp
Denafrips Venus DAC.

Description Of Issue
Started having a glitch/brief drop-off in sound, regularly, every 25 seconds or so.
Happens if I’m wired or wireless. Happens if it’s Tidal, Spotify, or files from my hard drive.
If I stream Tidal from the PC using the BlueSound app (and not Roon) to the Node 2i, no glitch.

Any suggestions appreciated.

Hello @Michael_Grande, you mentioned this is also happening with Spotify? Also, do you see this when playing to other endpoints/system output or just the Node 2i?

It happens when I stream from Tidal and when I’m playing flac files from my computer. The only other endpoint I have is my desktop PC/NAD amp. It does not happen then. But, again, if I don’t use Roon and use the BlueOS app to stream to the Node 2i, it doesn’t happen.

Hello @Michael_Grande,

Could you please connect the Node 2i directly to the router and see if this improves things?

Same thing happens is it’s wireless or connected directly to the router.


Sorry. Same thing happens if it’s wireless or if it’s connected directly to the router.

Hello @Michael_Grande, could you please reproduce the issue one more time and reply here with a timestamp (your local time) when you do? I’d like to enable diagnostics for your account and create a report for our team.

I’m in Taiwan so it’s 8:30 in the morning here now and I’m at work. When I get home I will fire it up and send you an email with the time. Probably be around 7 pm my time. Thanks for your help.


So, I’m playing through Roon right now. Taiwan time (GMT+8) 19:35. I’m playing files from an external hard drive on my PC. The glitch/drop-off is happening about every 25 or 26 seconds.


I’ll keep playing for a while. Around 20:00 I’ll switch to playing Tidal.

Just wondering if you’d gotten any ideas/information. Thanks for your help.


?? Anybody there?

Hello @Michael_Grande, my apologies for the delay here. It was my clerical error that caused your thread to be missed. I wanted to clarify a few points and discuss our findings:

You mentioned earlier that this also happens when playing Spotify, which is outside of Roon. Is that accurate?

Also, in reviewing the log files we didn’t see anything particularly of note other than Roon consistently picking an ASIO driver and reporting errors. Could you please reinstall that driver or try different drivers to see if things change?

Reinstalled the driver - still happening. Anyway, wouldn’t the problem with the driver also show up when I use the BlueOs app (which it doesn’t)? Should I reinstall Roon? Any suggestions appreciated. Having purchased a lifetime membership to Roon, this is really frustrating.

Hi @Michael_Grande,

Thanks for giving that a try.

Moving forward, I’m hoping you can clarify something for us — Is this only happening in Roon? You mentioned Spotify having similar issues previously, and if that is the case, it sounds like this is a bit broader of an issue (even if BluOS is working). Either way we’re happy to give some advice, but understanding the scope of the problem will be crucial for knowing where to go next.

Forget that I mentioned Spotify - that was in error. It’s only happening when I use Roon, with either Tidal or with files on my external hard drive or Windows OS desktop. When I use the BlueOS app, it never happens. And it never happens when I play music on my desktop to computer speakers, using Roon. So only when I use Roon to play music through my Node 2i - wired or wirelessly. Hope this helps.


Thanks for confirming, @Michael_Grande. Knowing that this is specific to Roon, I’m going to check with the team and I’ll get back to you soon on next steps.

Hello @Michael_Grande,

  1. Can you hear these glitches if you use the Analog outputs on the Node 2i? You can also try the headphone output on the Node 2i to check this.

  2. Go to the Settings > Audio screen in Roon and disable the Node 2i AirPlay zone listed under “Other Network Devices”. Make sure that the Node 2i zone listed under “Roon Ready” is enabled.

  3. Do you hear these glitches if you play to the “System Output” zone on a Mac or PC?


1 Like
  1. Yes, I can still hear the glitches when I use the headphone output on the Node 2i. Exactly the same intervals - around every 25 seconds or so.

  2. I disabled the Node 2i AirPlay zone. The Node 2i zone listed under Roon Ready is enabled. Same glitches.

  3. No glitches when I play to the System Output on my PC.

Any other ideas appreciated.


OK . . . . my solution was to take my Windows OS out of the loop. I took the plunge and bought a Nucleus+. It’s powered up, connected to my network, but everytime I open the Roon app and the Nucleus is on . . . . the app crashes. Happens on my ipad, happens on my desktop. Trying to make the Nucleus my core but can’t. Again . . . . and suggestions appreciated.