3:rd gen Chromecast

Hi. I just bought the new 3:rd gen chromecast but I can’t activate it in the settings. It is discovered as usual but when I press the activate button nothing happens. I can however activate it as a display but not for sound. All my other chromecasts (1:st gen, 2:nd gen, ultra and audio) work just fine. I even tried to remove them and then add them again and they all work. So, it has to do with the new gen. Any ideas?

Hi @Henrik_Rendahl,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since experiencing this issue have you tried rebooting the Chromecast and your Core machine?

Yes, I have restarted them both.

Server: Roon Core 1,5 on a Synology NAS
Client: iOS 12.1, Android 9, Windows 10
Storage: Tidal stream
Gateway: Ubiquiti Unifi Security Gateway (latest firmware)
Access Point: Ubiquiti Unifi AP AC Pro (latest firmware)
Switch: USG on Unifi Switch 8 - 60W and AP + Roon on Unifi Switch 8 - 150W
Connection: Core on wired LAN and clients on WiFi
Tidal Country: Sweden
Tidal Account: Hifi
Output: Chromecast Ultra, Chromecast 1st gen, Chromecast 2nd gen, Chromecast 3rd gen, Chromecast Audio, Bluesound Powernode 2, Bluesound Flex and Bluesound Pulse Mini.

Thanks for the info, @Henrik_Rendahl.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more (try activating the Chromecast device) and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

There is no error message but I did as you described. The time was 19:36 at central european time with daylight saving.

Thanks, @Henrik_Rendahl.

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Have you had any reports of a working 3rd gen? I’m asking since the product only been on the market for a month or so.

Hi @Henrik_Rendahl,

I spoke with the team about their investigation and we were hoping you could provide some additional information for us.

When you try enabling the 3rd gen CC, does the device disappear from Roon? Do any other devices disappear from Roon? Does anything happen at all when enabling?

We are hoping that you can provide the output of the chromecast debug console when enabling the device. Please see the steps outlined below:

  1. Open the Chrome browser on any machine on your network
  2. In the Chrome browser, enter the following in the address field to reveal the list of Cast-enabled devices on the network: chrome://inspect
  3. Press ‘Inspect’ button in front of the CC3 to open new window with the debug console for that device
  4. Try to enable CC3 in Roon again

Once you’ve tried enabling the CC3 in Roon, copy the output of the debug console into a text file and send us that file. Ideally, you can send the file via a shared dropbox link. If you don’t have Dropbox or need another way to send the file, just let me know.

@dylan / @Henrik_Rendahl

I purchased two of the 3rd gen chromecast devices a few weeks ago to use for Roon displays. While they both showed up in Settings / Audio I had not enabled them. After seeing this thread today I went ahead and tried to enable one. As you can see from the image below I was able to enable the OFF CC device with no issues:

I then selected OFF CC as the zone to play to and sent music to it. It played through the TV speakers and to my surprise it also functioned as a display. I was planning on trying to turn it on as a display but it started automatically.

Not sure this helps solve Henrik’s issues other than confirming that he should be able to enable a 3rd gen chromecast as an audio device.

FYI … I use Netgear Orbi devices for my network, my Windows 10 Roon core is connected via Gb Ethernet to a Cisco SG200 switch and then via Gb Ethernet to my Orbi router. All my Chromecast devices are connected via WiFi to my Orbi Router or to one of my two Orbi Satellites.

I also tried the chrome://inspect link and got this display:

I don’t see any 'Inspect" buttons. They may have been replaced by the DevTools app but I did not try it.


Thank you Tim. I will continue the search for a solution but it’s a great help to know that it at least should work. Do you run the server on a Synology NAS as well?

I have tried to find the inspect button but as Tim said it doesn’t show up.

Since yesterday I can’t see ANY of the Chromecasts not even the ones that worked before. So, at the moment Chromecast support is not working at all. My Bluesound units still work fine. I have tried to restart all the devices and server.

I run my core on a Windows 10 Home NUC that is also my Plex server. I’ve been using it for about 6 months with no issues until this week when it stopped logging in automatically after a reboot. Probably a Windows Update issue that hopefully can be fixed.

Good luck solving your issues … Tim

Hi @Henrik_Rendahl,

Thank you for the update, and apologies for the continued difficulties here. I’d like to propose a test that should give us a little more information about what may be occurring here.

If you temporarily use your Windows 10 remote as a Roon Core, are you able to see and enable your Chromecast devices?

Hi. I now tried the server on Windows and it finds the Chromecast without any trouble. I also tried the same Docker container on Linux and that also works fine so my conclusion is that it has to do with my Synology or their implementation of Docker. Any ideas?

Hi @Henrik_Rendahl,

Do you have open vSwitch enabled on the Synology Core? If so can you try disabling and see if there is any change?