300 Albums missing in Roon

Hey there,

I’m currently evaluating Roon with the intention to purchase, In fact I had planned to purchase last week but realised that a selection of my albums (and possibly tracks?) seem to be missing.

System info: storage is a Synology DS1815+ NAS, Roon (1.3 build 262) is installed on a Mac Mini (late 2012) running OS X 10.12.6

Music storage path is set to \Diskstation\Audio\iTunes\Music

iTunes has 7605 albums, Roon has 7303 albums. I’ve searched the forums and tried all I can think of to resolve the issue, but can’t figure it out. I’ve deleted the library and started from scratch, tried disabling and enabling the default music storage location, disabled playlist import, hidden albums is set to yes, forced manual library rescan multiple times, and of course, turned it off and back on again.

For whatever reason the albums just aren’t being imported at all.

As I say I’d like to purchase Roon, but given the issues I’m having and the price, I’m not quite sold on it, but I’d like to be :slight_smile: I’m also very conscious that my trial is fast running out, going to be difficult to evaluate if I can’t solve the issues I’m experiencing.

The most likely reason is that the file paths for those albums contain characters that are valid in macOS but that Roon does not accept, for cross-platform compatibility reasons, see https://kb.roonlabs.com/Skipped_Files.

‘Skipped files’ feature in Roon does indicate that there are some tracks that have been skipped, but it amounts to about 4 albums total.

I see reading further that music with unrecognised characters may not appear on the skipped tracks list, so may still be part of the problem. However I know that at least some (if not most) of the files that should be importing don’t contain any of the listed characters, nor do the folders those files are stored in.

As an example, an album ‘8’ by the band ‘Ufomammut’ is in the following storage location:


None of the track names contain unrecognised characters either, e.g. track ‘01 Babel.m4a’

Appears and plays in iTunes and all other applications, but the entire album is missing in Roon.

Could be protected media of older iTunes purchases?

No iTunes purchases on my account, don’t believe in it :slight_smile:

Appreciate the help and suggestions guys, please keep it coming!

@support might want logs…this will get some attention for you.

As a test convert the ufomammut album 8 to flac and see if it the flac version bets recognized

Great suggestion, here’s a link to the logs

Thanks for the suggestion Rugby, tried and failed, the FLAC files weren’t recognised after forced rescan.

What I did get to see though is that Roon is clearly finding tracks and seemingly trying to add them. As you can see in the screenshot below, “Adding Music To Library” shows 11 tracks, 0 added, 0 identified. At other times Roon seemed to find clusters of tracks (70 or more) but not add them in the same fashion.

I’ve no idea, but presume this is the sort of behaviour to expect when Roon finds files or folders with unrecognised characters? That may also be the case, but as I explained earlier, in the case of the example (Ufomammut album 8), as far as I can see there are no unrecognised characters being used.

For clarifications sake, the FLAC files were created from the exiting ALAC files and stored in the same folder location.

So how does one attract support to respond? By saying @support ?


Thanks Rugby, but I’ve no idea what that means…

I was saying that using the "at"support will automatically send a note to Roon’s support team. The “/10char” is just an internet standard to pad out a response on a message board where the minimum characters allowed are 10 characters, hench /10char

Good tip, thanks.

iTunes and Roon clump tracks into albums according to different rules. I would not expect the numbers to match, and depending on what your collection looks like, they might have quite a discrepancy.

For example, Roon makes a more thorough effort to treat multi-disc sets as a single album. Roon also makes an effort to re-assemble albums that might have been “broken up” by poor directory structure.

It would be much more useful to compare the count of tracks. I don’t generally expect an exact match of this number either–since sometimes other software imports files that we would consider corrupt.

Finally, try looking in Settings -> Library -> Skipped Files. That should show a list of any files that Roon knows it skipped during import, with a reason why.

@brian thanks but I believe already answered all of your suggestions above, none have solved the issue. I have a number of specific albums that just don’t appear in Roon at all regardless of all I have tried (again, example above).

In terms of tracks, iTunes has 71,292 and Roon is 68,757

I had a very small number of skipped files, but have since deleted them from my system. Roon now displays 0 skipped files after rescan of library.

Actually I may have figured out what’s going on here, and it seems it could be related to characters that Roon doesn’t like after all.

The folder structure I use is \Diskstation\Audio\iTunes\Music\Ufomammut\8

One of the albums in the artist folder of “Ufomammut” was titled “Oro: Opus Alter”

I was looking for an issue with the “Ufomammut” album titled “8” because I was struggling to see anything wrong with it, so I figured it was a good case study. However it seems that any folder contained within the artist folder that has a character unrecognised by Roon will cause all other albums in the same folder to be skipped by Roon.

As a test, I changed the album title within iTunes from “Oro: Opus Alter” to “Oro - Opus Alter”, which automatically updated the file structure and folder names because I use iTunes “Keep iTunes media folder organised” functionality. Once updated I forced a rescan in Roon and all the Ufomammut albums appeared as newly added content.

Thanks for all the help and suggestions BTW guys, hugely appreciated.

So I presume I have other versions of this going on for other artists and albums, my question now is, how the hell do I go about finding all of them to fix this seemingly very Roon-specific issue?

Hi, @Poo, Roon doesn’t import DRM files, so that might be the cause of your problem, could you please look if you have any of them in your Watched folder? BTW, I found in your logs ~500 corrupt files, so here’s the question, you said you deleted corrupt files, did you perform this action after sending your logs to us?



Thanks @Ivan, could you please let me know how to go about identifying which files might be DRM? To the best of my knowledge I have very little DRM content (if any), but I’d rather be sure.

Thanks also for looking into the logs. I deleted all files Roon specified in the “Skipped files” report, but it wasn’t a large number (roughly 40-50 tracks or so). I believe I generated the logs after deleting these files, but have exported logs again in case it helps.