5,000 song shuffle limit?

I am very interested in this string. I love shuffle. And I noticed this 5,000 thing right off, too, with 1.8 unless 1.7 was also doing this but we didn’t realize it. What gives here? We need true randomization involving our entire library. Why can’t that happen, Roon folks?

4 Likes

I use shuffle fast always. I love to discover that way my 370k library. In Version 1.3 was the shuffling also horrible, I wrote the a script to parse my library and created aevery day a shuffle playlist with 1000 songs. That was a cool workaroumd, but today with tidal integratiom it doesn‘t work anymore. I hope it will be fixed the next few days and not months

1 Like

I have 150,000 tracks and enjoy using the shuffle mode. When I start the shuffle there is a brief display stating that Roon is shuffling 5,000 tracks. Can you see those tracks? Change the number of tracks or which tracks are shuffled?

Thanks!

1 Like

I sure don’t have that much music, but I shuffled my Albums, and it put 4957 tracks in the Queue, for 18 + days of music playtime, now that’s crazy.

So I’d say you have bigger problems than Roon not shuffling all 150K tracks.

You could try playing around with Tracks and using Focus to zero in on some music, but better yet, try this:

Goto Tracks, Focus on your library, I have Tidal & Qobuz, so you may not need this step.

Pick any ole track you like, and play that single Track, next goto the Queue and using the 3 dots in the bottom right, select Limit to your library, again you may not need this.

This will start Roon Radio, which picks a new song, modeled after what it played last, and randomly should go through your music collection, in your case, possibly forever :slight_smile:

I have the same Issue as mentioned in a 2 other posts.
@Support could you help?

1 Like

Similarly, I realized last night that my rather large focus lists were not only limited to shuffling 5,000 tracks, but also… the tracks chosen appear to all be chosen by Album Artist from the beginning of the alphabet when the track population is rather evenly spread across all Artists A-Z. For instance, I just did a shuffle of my favorite classic rock tracks (total # of tracks in the focus = 12,220) and the first results were: Alpha To Omega, Dickey Betts, Chris Bell, Amazing Rhythm Aces, America, Alameda, Alan Parsons Project…

In 1.7, shuffle was truly random. It is no longer… and I wonder if the shuffle itself is limited to the first 5,000 tracks in the focus.

Hoping this is resolved soon, along with the Boolean logic issues with focus itself.

1 Like

@support similarly, if I go the the “tracks” view (sorted by artist, then album by default) and hit “shuffle” the behavious expected is to shuffle from the whole library.

Instead I get a shuffle from the first 5,000 tracks (only artists beginning with the letter A or numbers, in my case).

Is there a way to play the whole library on shuffle? It seems like a normal use case.

Thanks

1 Like

@support Before this update the shuffle mode appeared to play a random selection from all of the tracks on my music drive (not from a streaming service).

Now shuffle is restricted to a 5,000 track sample, with all the track titles beginning with the same letter!

When I was using the shuffle mode a week ago it was like I was on Ellis Island, one hundred years ago.

Using the shuffle mode with V1.8? Stuck in a bus station somewhere in the midwest. Not much variety.

2 Likes

Getting used to the new Roon and enjoying it so far, a lot of good new things to discover. however one change I’ve noticed which is a tad annoying is how shuffle all tracks works. I have 30K plus songs in my collection and previously when I shuffled it would just randomly play all (as far as I could tell). On the new Roon shuffle all tracks appears to select just 5,000 tracks and after multiple shuffle attempts it appears to just shuffle artists in the alphabetical range A to K nothing from L onwards. is there a hidden setting somewhere to alter how shuffle works? I’m sure it is something I’m missing or doing wrong

I’m using a macbook pro 2020 with latest MacOS installed Big Sur 11.2.1

thanks for any help

Andrew

Before the update, when I clicked the Tracks tab, then selected Shuffle, it would shuffle all my library’s tracks (270k+). Now, it only shuffles from 5000 tracks. I’m using Windows 10, latest build, on a Dell XPS-8930 desktop. Any ideas on what is going on, and how I can get it back to the way it was?

4 Likes

Same issue as me and others appear to be experiencing. For me, when shuffling from Albums list, only the first 5000 tracks in order of artist name are grabbed for shuffle.

1 Like

@support
With the new update how do I shuffle through my entire track library as I used to be able to do and is the 98% my use of Roon? Now when I select Tracks>Shuffle it creates a queue of 5000 tracks. What tracks are those? How do I shuffle through my whole library? Also the tracks selection used to display how many tracks I had in my library (IIRC about 13,000), that is no longer there.

I have a large library that I used to love to shuffle until this new release. I used to able to shuffle my entire library. With this release, it limits song to 5000. And what is maybe even worse, it starts in the beginning of the alphabet and continues in alpha order. If this continues, I will be on the letter A for six months. So in 1 year I will have listened to 3 or 4 letters. Ar you kidding me.? If this isn’t fixed I am out of here… 1 angry customer

It wasn’t intended to work this way.

You should be able to choose shuffle and get a random selection of music from your library, not just the beginning of the alphabet (or whatever your current sort mode is).

Thanks for flagging this everyone – we appreciate the feedback and we’re working on a fix. It should be in the next release.

25 Likes

Thanks Matt! Delighted to hear that and looking forward to the fix. In the meanwhile James_Hobson has kindly provided me with a temporary bandaid.

Cooch needs a hug

Have about 147,000 tracks
Like to just set to shuffle
Now with 1.8 it tells me “shuffling 5,000” tracks.
Only other change to my setup aside from upgrading to 1.8 is I just started using a nucleus + today.

1 Like

Thanks! This is very good news!