5 minutes to load a single track since 2.0 Build 1211

Roon Core Machine

WS2019 running Audiophile Optimizer with i9-10900K processor, EVGA RTX 2080Ti video card (for HQPlayer convolution and upscaling using Roon as control); 32 Gb RAM

Networking Gear & Setup Details

Orbi router and six satellites; have tried solving issue below with and without NordVPN running on my iPhone or a Roon control PC; UniFi switches

Connected Audio Devices

Ethernet from server through a UniFi switch to Ethernet-to-optical converter and optical-to-Ethernet converter to microRendu to USB input on Okto dac8pro

Number of Tracks in Library


Description of Issue

I updated to build 1211 this evening from build 1202. Build 1202 was working well for me after I switched over to Production 1202 from Early Access Build 1208, which exhibited the same issues noted here for build 1211.

After the 1202 to 1211 update, it took 3 minutes for history to pop up, and then only for the first 120 of 28,000 tracks on my history. All others are “unavailable”, now 12 minutes waiting. I selected one track from history to play and it took 3 more minutes for the track to start. A second track took nearly 5 more minutes to start up. A search for the Beatles took 3 minutes to get to the link for the artist page and 6 minutes more to get to the album list page.

Clearly, something has gone quite awry here. I will upload my log files. I look forward to your assistance in resolving this untenable situation! Thanks in advance. JCR

There’s a lot to go awry in your setup. Have you restarted your network or simplified things to confirm the issue is with Roon?

Hi Martin. I’ve restarted the network, the server and RoonServer on the server. Ookla Speedtest shows internet at 922 mbps download speed. Because I play Roon out through HQPlayer, I can test the server and network capacity by bypassing Roon and using the same infrastructure to play digitized vinyl upscaled at DSD64 and Apple Music spacial at DSD128 through HQPlayer. No problem.

But this is my big system.

A simpler test is for my master bathroom system, which is merely a wireless rpi4 Roon endpoint 15 feet from an Orbi satellite, outputting to an iFI Zen DAC v2. I cannot even get lossy Roon Live radio to work. (Edit: Roon Live radio started up after 10 minutes.)

So, Roon is the issue. JCR

This doesn’t have much relevance here, since the problem is within your home network.

Unlikely, since it seems to only affect your setup. As I said earlier, try to simplify your network to eliminate potential issues.

Otherwise, wait for Roon support to respond.

Understood re external network speed. Do note that I edited my comments to indicate I have tested with a really simple server to DAC via an rpi4 setup, and while KNPR radio is now streaming just fine, it did take 10 minutes to startup. That just simply isn’t normal.

I certainly recognize that Roon support likely needs to help out on this one. Thanks, @Martin_Webster. JCR

One other unusual point. On the Roon home page, to the left of the bookmark in the upper right, I have a spinning semicircle. Upon clicking it, it says it is adding 0 of 506 tracks to my music library. I have no new tracks and it doesn’t advance at all. I wonder if this needs to be shut down, if it is hogging things over the local network trying to add files. But, I don’t know how to stop it, if it actually matters. JCR

I agree this isn’t normal.

You usually see this when new music is being analysed. You could try restarting, but I’d be inclined to disable your storage locations to see if streaming services perform as expected. If it does, that rules out a few things, and we can focus on what is potentially hogging resources. Likewise, check Windows logs and events to get an insight into the issue.

@Martin_Webster , you are on to something. When disabling my storage location (my Synology 1813+ NAS), TIDAL loads up quickly and I can stream music properly, including MQA decoding, without undue delay. So, something is indeed hogging resources, as you suggest. I have opened Windows logs via the cmd command eventvwr, Over the past 24 hours, I see a warning about failure to initialize Lantern Rock SDK, but this appears to be because telemetry is not opted in. I also see multiple application and .net runtime errors late last night relating to ASUSVerifyJWT.exe, but none of those during the day here or as related to Roon. The security tab shows all “audit success”’ so nothing there, and nothing seen under the setup tab as well.

However, under the system tab, there is an error at 7.28a this morning labeled DNS Client Events, ID 1014, “name resolution for the name push-manager.roonlabs.net timed out after none of the configured DNS servers responded”, but only at that time and not at present (2.10p local time).

NordVPN and Windows Defender are both shut off. I rebooted the NAS. Same result just now – can’t load anything up, including TIDAL.

So, Martin, I assume you now have some additional ideas? Thanks. JCR

Unfortunately, I have no recent experience with Windows, and none with Synology.

The DNS error could be a red herring, but dig push-manager.roonlabs.net on my laptop returned the IP in 300 ms, so you may want to check this query again. I use Cloudflare’s DNS servers rather than my ISP, as they are significantly faster and more reliable. That’s worth a try.

However, my primary focus would be on the NAS, and why performance is poor. Are core and NAS on the same switch? Do file transfers perform as you expect?

On Linux, I sometimes increase fs.inotify.max_user_watches when apps using the filesystem performs poorly, e.g., Dropbox. Since Synology runs on Linux, you may want to check the current value and try increasing it.

Seems likely that the DNS error is not related, given that it occurred but once and clearly not timed relative to accessing the NAS for Roon. Core and NAS are on the same switch and I just finished a lengthy project of backing up my entire NAS to four 16Tb drives to store outside of our home. That went fine with the drives connected to another PC on the network, also connected through the same switch.

I set up my NAS for SSH control and tried to see what the inotify is set at, but I can’t seem to figure that out. I’m not much of a Linux guy…JCR

You could try this:

echo fs.inotify.max_user_watches=100000 | sudo tee -a /etc/sysctl.conf; sudo sysctl -p

A quick search suggests that this should work; reports of it not persisting after a reboot look like user error, unless Synology reset at boot. But worth a try.

Thanks, @Martin_Webster. Is that a single command, or where the | and ; are located, are those breaks between commands? (Sorry, Linux stuff I don’t know….) JCR

Edit: I tried as a single command and was asked for my password, and then I got a kernel.panic=3 message. In any event, no improvement. Sigh.

I just checked the spec of the NAS, and it looks like it has 2 GB memory. The memory usage for watches is small, but comes from kernel space.

Since you didn’t receive a syntax error, you could try a smaller number.

I’m wondering if the NAS is struggling with IO relating to music analysis. However, I don’t have experience of NAS although it’s evident the NAS has an old Atom D2700 processor.

It may be worthwhile post a question in the #roon:qnap-synology category.

Thanks, Martin. I do note that the spinning semicircle on the Roon home page does indicate that Roon is trying to analyze a set of tracks. It’s constantly going and it always says 0 of some number of tracks, currently 0 of 484. Is there a way to shut it off to see if that helps? In library, I’ve turned off background audio analysis speed and on-demand audio analysis speed and yet the semicircle is still spinning, trying to analyze the 484 tracks. I also note that on the services page, another semicircle is spinning to the left of the edit button for TIDAL. These both must be hogging some resources?

For the watches, what number lower than 100,000 do you think appropriate to try? JCR

Edit: I tried JRiver Media Center 30 and find that it loads any file — 6 channel DSD included — instantaneously off my NAS. This once again turns me back to Roon as being the culprit, and not my NAS, for I should have the same I/O problem with JRMC as with Roon, and yet I do not.

I have same problem, there is a spinning wheel to analyze set of track. And also load times for album is 10 minutes.

[Moderator Edit: Support topic now created, see …]

@Roman_Petru, please open a separate #support thread, and complete the template provided. Thanks.

If you go to Roon > Settings > Library, you can change the background audio analysis speed, and on-demand speed, but not disable this. What settings are you currently using? Furthermore, what do you see under Clean up library?

Regarding watches, try using the following commend instead, as this doesn’t persist after a reboot (the other should have persisted.) Start with, say 10000, and increase until (if) you observe any improvement.

sudo sysctl -w fs.inotify.max_user_watches=12288

Martin, I tried in increments up to 60,000 watches, with no effect.

Again, since JRMC pulls files from the NAS with ease, I can’t see how this is a NAS problem. JCR

I am currently trying an experiment. As I had just completed a full backup of the 43Tb of data on my NAS to four 16Tb drives, I have disabled my NAS entirely from Roon and have set the four new drives alone as my music file source (all connected via USB directly yo my Roon server). At this point, I’m about halfway imported into Roon (now, about 116K tracks). So far, Roon is acting very well, with searches and tracks loading up and playing quickly.

We will see when I have double the number of tracks re-loaded into Roon, but if this keeps up, it will suggest that the issue is some interaction problem between Roon and my Synology 1813+ NAS, particularly as the NAS works fine for JRiver and for otherwise accessing data via Windows Explorer. JCR

Any update on this???