7i7BNH USB to Yggdrasil - No device config

I’m a newbie in my trial period & I’ve run into a problem enabling a Yggdrasil.

I have a 7i7BNH with an updated bios & the latest version of ROCK installed. Whenever I try to enable my new Yggdrasil (USB5), the “Enabling” icon on my iPad or Windows laptop never goes away to indicate that the USB connection has been enabled. It just stays in the “Enabling” state.

If I hook my Windows laptop to the USB cable, then I can play music through the Yggdrasil. So the USB on the DAC is good. I can stream music from my 7i7BNH to my iPad so I know my NUC can play music.

But each time I try to enable the 7i7BNH to the Yggdrasil USB, the following message appears in the log file (about 10 times so far):

10/03 01:30:29 Trace: [jsonserver] [] GOT[LL] [2] {“request”:“enable_device”,“device_id”:“hw:CARD=Y5,DEV=0”,“subscription_id”:“2”}

10/03 01:30:29 Warn: [raatmanager] can’t start device without a config

10/03 01:30:29 Trace: [jsonserver] [] SENT [2] [nonfinal] {“status”: “DeviceInitFailed”}

Research has led me to one other instance of another user getting the same “device without a config” message but he was able to solve his problem by updating the software to the latest version. I’ve done all of the obvious things: reinstall the OS, warm boots, cold boots, turn off all the equipment, use different USB ports, etc. After four hours of banging my head against the wall, I’ve run out of ideas.

This Yggdrasil was backordered at the beginning of September and just arrived today. So it was just built. I’m assuming that there hasn’t been any hardware changes for the USB from earlier models that would have caused an incompatibility.

If anyone has any ideas other than rebooting or reinstalling software, I would appreciate something new to try.

PS - After posting this I realized I forgot to mention that I was able to stream music to the Yggdrasil by using the Groove media player on my laptop. The Windows 10 OS recognized the Yggdrasil as an audio output. If I ran the Roon Windows desktop app, it could see all of the music on my 7i7BNH core and Roon recognized that the USB cable ran from the laptop to the Yggdrasil. But trying to enable the USB connection to the Yggdrasil fails as well from the laptop. On the Windows machine, I get a similar error message as from the NUC:

10/02 23:13:25 Trace: [raatmanager] retrying changed wasapi device {}.{e17e6230-4612-4f3a-a0b4-fd68ad845ec6}

10/02 23:13:25 Warn: [raatmanager] can’t start device without a config

You may need an endpoint. I use Allo DigiOne.

Thanks for the suggestion. Unfortunately since I’m new to this product, the terseness of your reply created additional questions.

If the goal is to connect to an Allo DigiOne from my 7i7BNH via USB and then continue on to the Yggdrasil via SPDIF/BNC, then basically I’m adding an additional piece of equipment to convert the signal simply to use a different interface. If the Roon software can go USB to the Digione, why can’t it go USB to the Yggdrasil? It’s done it for other users in the past. Was a decision made to not support this hardware via USB anymore? These are of course rhetorical questions that only a Roon engineer might be able to answer. I’m just thinking out loud. I would prefer not to do additional manipulation of the signal unless absolutely necessary. But I appreciate having a possible solution to consider.

I’m assuming you weren’t suggesting to replace the 7i7BNH since I pulled that model straight out of the documentation as a recommended NUC. When you see two devices with a common interface, there’s generally an optimism that they’ll be able to talk to one another. Except of course in this case…

You should be able to use the USB on the ROCK machine without an additional endpoint.

It used to be that WIN10 needed a driver that one could download from the Schiit web site. It looks like that may no longer be necessary, dunno.

Did you look on the Schiit web site in the section that talks about USB problems?

Oh yeah, one other thing. Did you select the correct input on the Yggy?

Since Roon’s bespoke Nucleus Server used USB (and not SPDIF/BNC), I was hoping that another NUC device would have good USB support as well. It’s nice to have that confirmed. Thanks.

My Windows 10 laptop recognized the Yggdrasil as soon as I plugged the cable in. No problems.

I did read the Schiit page on USB problems but was unable to use their hints to reach a solution.

I do have the correct input on the Yggy because I simply move the upstream USB connection from Groove on Windows where it works to the NUC where it doesn’t. The Yggy end of the cable doesn’t change settings-wise. Just the source does.

The Windows Roon app & the NUC ROCK both log " can’t start device without a config" and “{“status”: “DeviceInitFailed”}”. But Windows 10 has no problem connecting via USB and streaming audio to the DAC. The Roon software on the same platform can’t enable the USB that’s already working just fine at the OS level. It’s puzzling and obviously a bit frustrating because the solution feels annoyingly close. I’m going to bring a MacBook from the office when I get home later today and see if that behaves any differently in an effort to get additional clues.

Thanks for trying to help me out.


Hi, if you want Windows to use it you have to configure it to use exclusive mode. If it works automatically with Windows based hardware then in all probability Windows has seized it and won’t let anything else work. I am sure you have read that UAC2 capable Linux distros should be OK and ROCK falls into that category. But hopefully the dev team have a gen5 enabled Yggdrasil to test for you.

Thanks for the feedback. I had read about UAC2 and was hoping that ROCK would “just work”. It seems a bit like a black box with little that I can do to tweak it at a low level. The way it upgrades, this would probably not be a good solution anyway as it lacks permanence.

I was unaware of the exclusive mode on Windows. When I get back home, I’ll check that out. Since both versions of the software were giving basically identical error messages, I just assumed it was the same problem. But it’s possible that it will work on Windows if I change some settings. It’s nice to know that it might be an option.

Now to be clear, exclusive mode wasn’t necessary on a PC if you used ASIO drivers as they are exclusive by definition. But if you are using plug and play drivers you may need to make a device exclusive.

Thanks for the clarification. Now that I know an item to consider that I wasn’t aware I was ignorant of, I’ll spend some time to educate myself about its various nuances. A useful tip to help me debug this.

Sorry, misread your OP. Slim is correct. You don’t need two endpoints.

I attempted to use Roon on a MacBook Pro running Mojave and I got the same error message in the log file that I got on the ROCK & Windows 10:

10/03 13:56:26 Trace: [raatmanager/mac] FOUND id=AppleUSBAudioEngine:Schiit Audio:Yggdrasil Gen 5:14200000:1 usb_id=0d8c:0004
**10/03 13:56:26 Trace: [raatmanager/mac] vendor=Schiit Audio name=Yggdrasil Gen 5 outname= **
10/03 13:56:26 Trace: [jsonserver] [] SENT [1] [nonfinal] {“status”: “DeviceAdded”, “device”: {“type”: “coreaudio”, “device_id”: “AppleUSBAudioEngine:Schiit Audio:Yggdrasil Gen 5:14200000:1”, “vendor”: “Schiit Audio”, “name”: “Yggdrasil Gen 5”, “usb_id”: "0d

10/03 13:56:37 Trace: [jsonserver] [] GOT[LL] [2] {“request”:“enable_device”,“device_id”:“AppleUSBAudioEngine:Schiit Audio:Yggdrasil Gen 5:14200000:1”,“subscription_id”:“9”}

10/03 13:56:37 Warn: [raatmanager] can’t start device without a config

10/03 13:56:37 Trace: [jsonserver] [] SENT [2] [nonfinal] {“status”: “DeviceInitFailed”}

I am unable to Enable the USB connection to the Yggdrasil because there isn’t a config file. So I get a DeviceInitFailed error.

I sent an email to Schiit Audio asking if their latest Yggdrasils that were built this last month had any hardware changes for the USB that could be causing a problem for Roon software. They specifically did not answer that question and sent me a copy of the Roon documentation that says to click the “Enable” button.

The Roon setup guide has the following statement:

"If your device has been automatically identified by Roon, all of the correct settings should be applied automatically without any extra configuration by the user needed."

My Yggdrasil is automatically identified by Roon:

The problem as I see it (and this analysis may be totally wrong but it would be useful if someone could tell me why) is that the automatic configuration file for this device is failing to be created once the Roon software identifies the connected device. If you can enable a device using this automatically created configuration file, then by clicking the Gear icon, you can manually override the automatically selected options. If the initial config file creation fails so that no config file exists, then there is no way for a user to manually create one from scratch. The user can only modify a config file that has been already been created by the Roon software. But for me, this never happens.

I’m stuck in a Catch-22. The device won’t Enable because there’s no configuration file created and I can’t create a manual configuration file on a disabled device. The only option I have once the device fails to initialize is to Disable it. I can’t go into the Device Setup until the Device is Enabled.

If Roon software for Linux, Windows & OSX all fail on the same message on three different machines, then my hopes of using Roon start to dwindle. The log messages and documentation on this specific error is too sparse for me to make any meaningful headway. I know the USB connection on the Yggdrasil works because I’m listening to music as I type this. I just can’t seem to get any of that music to go through any version of RoonLabs software.

I appreciate all the help everyone has tried to give me. It seems like a nice forum. I’ll be patient and see if someone has an epiphany that can get me over this hurdle before I go looking for alternative solutions. So far Roon was the only software that I’ve looked at because I assumed it would work with my DAC. At this moment I’m not sure what the alternatives are.

I am sorry, I can’t help further.
@support can you look into this? The solution shouldn’t be hard to find. It is a Roon issue or a Schiit issue.

I appreciate all the help you did give. If I put my error message in quotes and search the forums for it, only my post comes back. So I’m assuming this problem is not common. Google has not been my friend. I have found no insightful information about the particular error messages I keep seeing. I have some suspicions and theories but unfortunately no conclusions based on actual technical knowledge.

If you haven’t already, with the Windows 10 laptop, install the Schiit Drivers available on their website. http://www.schiit.com/drivers. The new Windows 10 USB drivers never worked well with any of the Schiit DACs I’ve used, although I don’t have a Yggy. I had to use their drivers to get any output in Windows using Roon.

Thanks for the suggestion. I did download the Schiit drivers a couple of days ago and extracted them to the Downloads folder. But when I run Setup.exe, it gets to the following dialog box requesting me to attach a CMEDIA USB2.0 Audio Device. The Yggdrasil is connected and I can play music out of it. But the installation program doesn’t recognize it. Windows (the OS) does recognize it and identify it correctly.

In the screenshot below you can see the installation program prompting me to connect to the Yggdrasil. If I click the OK button, the box just pops back up. After several OK’s, the installation program aborts. You can also see in the taskbar that Windows recognizes the Yggdrasil as being attached.

So far I’ve been able to play music and for me it sounds fine (although my nicer speakers haven’t arrived yet. The cobbling together of this stereo system is still a work in progress). I exchanged a couple of emails with Schiit Audio yesterday but didn’t get any useful information. I’m going to try and contact them again today. When I initially encountered this installation problem early on in this process, I just assumed they weren’t intended for the Yggdrasil or that it didn’t really matter since the Windows 10 drivers seemed to be doing a good job. But based on everything I’m seeing I keep getting the suspicion that something about the USB in my DAC is different than earlier models. I don’t know if it’s an actual hardware change but this interface seems to be partially broken. It works fine under certain conditions so it’s not 100% broken. But if both Roon & Schiit’s software is having a problem with it, then I think that’s a clear indication something’s amiss. When I contacted Schiit via email, I sent them a link to this post but all they did was send me a one sentence reply with a hyperlink to the Roon documentation.

The ultimate goal of this exercise was to get ROCK on the NUC working as that was the hardware I had for a dedicated media device. Windows & Mac operability were simply tests to see if anything would work. But at this point, I will count any sound coming through any version of any Roon software on any platform as a win.

The DigiOne is not connected via USB, it is connected via Ethernet. Ethernet IN, SPDIF Out to DAC. In Roon terms, it is an endpoint.

For many people, not all interfaces have the same SQ, USB being a prime example. With the Yggy, they completely revamped their USB interface in the past year (not sure on the date). That is why you see Gen 5 listed, previously it was Gen 2. Before the Gen 5 USB upgrade, the users comments on the forums suggested that the order in preference (for SQ) was AES/EBU, BNC, Coax, USB and then Optical.

Thanks for the info. This particular topic is new to me and I still have a lot to learn. When doing some early research on Roon, I had come across a post describing some of the deficiencies that users had experienced with the USB interface.

When I looked at Roon’s Nucleus Server, I was a bit surprised to not see any of the higher ranked interfaces that you had listed above. I made an assumption since Roon had made USB the primary connection on their media player, that improvements had been made in the last couple of years. I had decided to try using an i7 NUC in the hopes that the extra CPU power might be useful in streaming larger files. But on that particular device I was limited to USB connectivity to the Yggdrasil. Based on previous posts from users who had used Roon with the Yggdrasil, I thought the two products would work for me as well. But so far a connectivity solution evades me.

I’m doing my best to be patient in hopes that someone out there has a solution. But my mind is now trying to come up with a plan “B”. Do I return the Yggdrasil and buy something else or do I abandon Roon as a software solution. Unless something changes, one of the two will have to go.

Well @support should be on soon to help. I’m sure the guys will get you sorted both with helping on the connectivity issue and with making sure you have enough time to trial the software when everything is sorted out.

Hello @Darryl_Caillouet,

Before we begin, I’d like to thank @Rugby for his excellent troubleshooting and diagnostics. The information you two have been able to collect is paramount to narrowing down where this issue may be occurring.

Based on what I’m able to glean from your log traces as well as your symptoms, my first thought is that this is possibly stemming from an issue with the Gen 5 Schiit USB board. We’ve had a few reports over the last year of users having issues with the Gen 5 Schiit USB products, while others (including the hardware we have in-house) do not exhibit these issues. I know on at least one occasion Schiit sent the user a replacement USB board and that ended up resolving the issue. I can’t say for certain if that is what is happening here, but based on the information we have at this moment in time, I think it’s worth discussing with Schiit.


Thanks for the reply. I have sent another email to Schiit Audio with a copy of your analysis. I will let you know what their response is. I appreciate you taking the time to look at this problem. Waiting a month for a back ordered item to arrive and then have it not work 100% has been a bit stressful. Intuition tells me that being patient is a good idea when you’re asking other busy people to give you free help. It’s still hard to do. :slight_smile:

But I’m solution-oriented. If I can get this to work, then the effort & wait will be worth it.