About trouble when iFi Audio "iGalvanic 3.0" is connected

I’m sorry for inquiring by automatic translation application

I am using Roon under the following conditions.
MacBook Pro → iFi Audio “iUSB 3.0” → USB DAC

Roon can not recognize the DAC when “iGalvanic 3.0” is inserted in this environment
→ <iGalvanic 3.0> → <iUSB 3.0> → Not recognized
→ <iUSB 3.0> → <iGalvanic 3.0> → does not recognize
However, even in this connection state, “audirvana plus 3” “itunes” recognizes USB-DAC and produces sound

With Roon running, remove iGalvanic 3.0 from the above connection and recognize the USB DAC as soon as you return to the standard connection
So it seems to be a problem on the Roon side rather than a problem on iGalvanic 3.0 side
I would like to fix it in the next update

macOS 10.12.6
roon Version 1.3
audirvana plus3 Version3.0.6

Yuutetsu Sakurai.


Hi @YUUTETSU_SAKURAI ----- Thank you for the report and sharing this observation you have made with us.

Moving forward, I have went ahead and enabled diagnostics on your account so we can have a closer look into this behavior for you. May I very kindly ask you to please run the tests mentioned above once more, provide a time frame for when the observations are made, and we’ll take a look for you :microscope:

→ <iGalvanic 3.0> → <iUSB 3.0> → Not recognized (time of observation)
→ <iUSB 3.0> → <iGalvanic 3.0> → does not recognize (time of observation)
…Remove iGalvanic 3.0 from the above connection and recognize the USB DAC (time of observation)


I tried connecting experiment of Roon
Japan time November 10, 6: 13 ~ 6: 18 minutes, I tried connecting three times four times “iGalvanic 3.0”, no connection
Again, MacBook Pro (Roon) → iGalvanic 3.0 → iUSB 3.0 → USB DAC does not recognize the DAC
For MacBook Pro → iUSB 3.0 → USB DAC, both DAC 1 and DAC 2 are recognized
I hope this will be a reference for improvement , but thank you

Thank you for touching base with me @YUUTETSU_SAKURAI, very appreciated!

Confirming that the mentioned diagnostics report has been received and has been passed over to our tech team for evaluation. Once I am provided an update from the team, I will be sure to share their thoughts/findings with you in a timely manor.

Your patience is very appreciated while we conduct our analysis.

Hi @YUUTETSU_SAKURAI ---- Thank you again for your patience while our team has been looking into this behavior you’ve reported to us while using the “iGalvanic”.

Moving forward, the team has requested some additional information to help in their evaluation of this issue you’ve reported to us. Please see below.

  • Please provide the make and models of the following devices:

    MacBook Pro → iUSB 3.0 → USB DAC, both DAC 1 and DAC 2 are recognized

  • Please provide screenshots of your “audio” tab when the following configurations are in place:

    1. MacBook Pro - > USB DAC

    2. MacBook Pro - > iGalvanic - > USB DAC


A post was split to a new topic: Thinking about getting an iFi Audio 'iGalvanic 3.0"

A post was split to a new topic: Roon + iGalvanic