Add Back Up Folder - Not Possible (MacOs Catalina & Nucleus)

Good Evening To All Of You Guys,
Out There At The Roon Killing Fields.

I have a problem adding files for Back Up my Roon installation,
I am using a Nucleus as a Core, a Macbook Pro as a remote,
both using the last update (2.0 - build 1169)
and a Weiss 502 as a Dac.
I will try to present you all the needed info here, my system,
the problem, and the actions I took through screen pictures.
I hope someone has faced the same thing as I did,
and help me solve this issue.

Macbook Pro Overview

What if you try just smb://loakeims-Macbook-Pro.local/ The issue might be the directory “share”.

Personally, I create a backup folder first, call it TESTBACKUP, and then I set a share only on that folder, not the whole drive. Then, smb://loakeims-Macbook-Pro.local/TESTBACKUP where the name of the share was the folder I created and shared.

Dear Daniel
Thank you very much for your suggestions.
Unfortunately, it doesn’t work.

Please, tell me: WHERE do you create the TESTBACKUP folder?
I mean exactly where? Owner Home File? Desktop? Music? Documents?

Also, when you say SHARE ONLY on that folder,
you mean you erase the OWNERS PUBLIC folder
which is always appearing in the FILE SHARING preferences?

I tried all what you suggested, also created a file inside the local
public folder. Nothing. Maybe I don’t write down the path way right.

Please, if you know, tell me: Is this a matter only of CATALINA mac os?
Because, I am very tired, and if it is, I would gather some money
to go with a new Macbook Pro and solve it.
Right now, I just want to bring a hammer and smash this thing in pieces!!
( I am just kidding…)

Hi loakeim,

I am sorry I cannot give better descriptions, I had, and it must have gotten removed in my original post to you, that I’m a Windows guy and don’t know the exact things to tell you for MacOS. Just relating how I do things in Windows.

I’ve just tested this because I didn’t want to give you bad info - the following works for me!

In your home folder, create a folder called “roon”…

Then in the sharing pref pane, “share” it… set “Read & Write”…

Click “Options”, check “Share using SMB”, and I’ve checked windows file sharing and added my account (which might not new necessary)…

Over in Roon, the location is: smb://<ip_address>/roon
where, <ip_address> is your Macs IP address.

The username and password are your normal login username and password.
If you get a red banner, it’s obviously not happy, and you’ll need to play with it (probably syntax)… in my case, I’m running Ventura, I needed to disable file sharing, reboot, and re-enable file sharing for it to work.

Good luck!!

1 Like

Mister mikeb, YOU ARE THE MAN!!! YEAAHHH!!!
:clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap:

And just about I was ready to throw my Macbook out of the window.
Maybe I was lucky, I don’t know… :grinning:
But I followed your steps (mikeb) and I managed to add a backup file
at last. Feeewwww…
I have not enough words to THANK YOU SO MUCH GUYS,
You Daniel also!!!
I hope I could help you in something too some day!

Listen mikeb, I have some more questions, if you will, please:
In your File Sharing preference pane, it seems you have only
the “roon” folder to share. No public folder!!
I was about to remove it too, but was afraid of a bigger damage.
Why is this? Have you removed it?

And another one here:
Now that we have fixed the issue of roon back up,
we are also stacked with a permanent (or two) sharing folders
which is an open door for the bad guys? Is this true or not?
And what are you doing about it?

That’s it. Thank you both guys so much for all your help and support
:slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :heart_eyes: :heart_eyes: :heart_eyes:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.