Adding albums from Tidal seems slow Roon continues to add in background


(simon arnold) #1

For a while now I have been seeing the performance on adding albums via Tidal to be slow. Sometimes Roon even says it’s taking longer than normal and will continue to add it in the background. I never used it get this behaviour. I got a new server over the weekend and its still doing it. I have a 200mb connection and core is hardwired and connected via a switch to the router. Prior to the new server the old one which had same issue was connected directly to router.

I have a feeling that’s it’s likely my internet connection or the modem which is separate to my router. Has anyone else ever experienced this ?


(Noris) #3

Hello @simon_arnold,

What is your model/manufacturer for the modem? Are you making use of any switches/range extenders/powerline adapters? Have you tried changing your DNS servers to Google DNS or Cloudflare yet? For some specific router manufacturers we have seen the need to adjust some settings on them, listed in our Networking Best Practices Guide here. If the switch you are using is managed, often looking for a “Flow Control” setting and turning it on has helped too.

Please let me know the model names and I can see if there is something more specific to improve for your setup.

Thanks,
Noris


(simon arnold) #4

My modem is from my ISP which is their own Virgin Media hub. I use a Netgear R7000 as my router and Ubiquiti Unifi for wireless ap which all my remotes use. Core is direct to the router. Ihave no switch in-between this only my endpoints. These are some Cisco 2960 which are in unmanaged mode. I will try Google dns and see if it helps. I have optimised my network as much as I can.


(Noris) #5

@simon_arnold - Great, let me know how the DNS change goes!

If you are still experiencing the issue after the DNS change then a screenshot or video clip of the behavior will be good to have.

Also would be good to know how large of a library you have and where you’re adding these albums, to a playlist or just to your library? Do you experience the same lag when adding directly via the TIDAL app?

Thanks,
Noris


(simon arnold) #6

Library is about 33000 songs so not huge and under 2500 albums. I don’t use playlists so it’s just adding an album to my library. I don’t really use the Tidal app but don’t remember any issue there when I have all you do is heart it and that’s it.


(Noris) #7

Thanks for letting me know @simon_arnold. Please let me know if changing the DNS helps here, as this is most likely the cause in my opinion.

Thanks,
Noris


(simon arnold) #8

@noris So far so good I changed to Cloudfare yesterday. Only time will tell if its improved throughout.


(Noris) #9

@simon_arnold - Glad to hear that! Please keep me posted if you experience any other difficulties with adding TIDAL content.

Thanks,
Noris


(simon arnold) #10

@noris s whilst I have not had the slow adding to library message any searching for albums or clicking on them from Tidal for tracks or albums thats not already in my library is taking a very long time. Going to switch some things around and see if it makes a difference.


(Noris) #11

Thanks for letting me know @simon_arnold,

I have gone ahead and enabled diagnostics mode for your account (as per the PM) and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. I will be sure to let you know once I have had a chance to review them for any possible signs of instability.

Thanks,
Noris


(simon arnold) #12

Thanks Noris.


(simon arnold) #13

12.20 GMT used Roon searching is up and down speed wise, initial search is fast bit as soon as I drop into album view from that search it slows down and adding album took longer than I would expect.

excerpt from log it

12/02 12:20:15 Info: [tidal/storage] FakeDiscovery: 12 new items discovered
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698485 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698486 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698487 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698488 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698489 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698490 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698491 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698492 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698493 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698494 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698495 from My Tidal Library
12/02 12:20:15 Debug: [music/storage] importing file 168:0:77698496 from My Tidal Library
12/02 12:20:15 Debug: [library] imported 12 tracks from storage backend 0495bb3b-556c-95f5-c998-6ebf6547b4c9 (My Tidal Library)
12/02 12:20:15 Trace: [clumping] clumping 39 tracks and 0 auxfiles
12/02 12:20:15 Trace: [library/compute] computing 12 tracks
12/02 12:20:15 Trace: [dbperf] flush 42587 bytes, 62 ops in 7 ms (cumulative 227731351 bytes, 209664 ops in 57969 ms)
12/02 12:20:15 Trace: [library] finished with 12 dirty tracks 1 dirty albums 1 dirty performers 12 clumping tracks, 0 clumping auxfiles 12 compute tracks, 0 deleted tracks, 12 tracks to (re)load, 12 tracks to retain, 0 auxfiles to (re)load, 0 auxfiles to retain, and 14 changed objects
12/02 12:20:15 Trace: [identification] <1305391> Identifying album [Thelonious Monk - Genius Of Modern Music Volume Two] with 12 tracks
12/02 12:20:15 Debug: [metadata http post req]: https://metadata5.roonlabs.com/identifier/2/album?uid=11457dfd-50c4-4002-8862-97908c412a59&lid=&token=511132e3-67fe-4318-8f4e-9ca87947f76a
12/02 12:20:15 Debug: [identification] <1305391> identifier request id: 04a4a364
12/02 12:20:15 Debug: [library/index] updating search indices: 14 ops 14 adds, 0 removes
12/02 12:20:15 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
12/02 12:20:15 Trace: [push] retrying connection in 94775ms
12/02 12:20:15 Trace: [dbperf] flush 0 bytes, 0 ops in 4 ms (cumulative 227731351 bytes, 209664 ops in 57973 ms)
12/02 12:20:15 Trace: [library] endmutation in 34ms
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10471730, Thelonious Monk - Genius Of Modern Music Volume Two - Carolina Moon IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10471986, Thelonious Monk - Genius Of Modern Music Volume Two - Hornin’ In IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10472242, Thelonious Monk - Genius Of Modern Music Volume Two - Skippy IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10472498, Thelonious Monk - Genius Of Modern Music Volume Two - Let’s Cool One IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10472754, Thelonious Monk - Genius Of Modern Music Volume Two - Suburban Eyes IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10473010, Thelonious Monk - Genius Of Modern Music Volume Two - Evonce IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10473266, Thelonious Monk - Genius Of Modern Music Volume Two - Straight No Chaser IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:15 Debug: [library/settings] updating track LibraryTrack[10473522, Thelonious Monk - Genius Of Modern Music Volume Two - Four in One IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:16 Debug: [library/settings] updating track LibraryTrack[10473778, Thelonious Monk - Genius Of Modern Music Volume Two - Nice Work (If You Can Get It) IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:16 Debug: [library/settings] updating track LibraryTrack[10474034, Thelonious Monk - Genius Of Modern Music Volume Two - Monk’s Mood IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:16 Debug: [library/settings] updating track LibraryTrack[10474290, Thelonious Monk - Genius Of Modern Music Volume Two - Who Knows? IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:16 Debug: [library/settings] updating track LibraryTrack[10474546, Thelonious Monk - Genius Of Modern Music Volume Two - Ask Me Now IsAvailable=True IsDeleted=False ] (track False clumping False)
12/02 12:20:16 Trace: [library/compute] computing 12 tracks
12/02 12:20:16 Trace: [dbperf] flush 28434 bytes, 24 ops in 0 ms (cumulative 227759785 bytes, 209688 ops in 57973 ms)
12/02 12:20:16 Trace: [library] finished with 12 dirty tracks 1 dirty albums 1 dirty performers 0 clumping tracks, 0 clumping auxfiles 12 compute tracks, 0 deleted tracks, 12 tracks to (re)load, 0 tracks to retain, 0 auxfiles to (re)load, 0 auxfiles to retain, and 14 changed objects
12/02 12:20:16 Debug: [library/index] updating search indices: 24 ops 0 adds, 0 removes
12/02 12:20:16 Trace: [library] endmutation in 23ms


(Noris) #14

Hello @simon_arnold,

Can you please try verifying if this same issue occurs with a fresh cache folder in place? Please use these instructions:

  1. Open the ROCK WebUI and Stop RoonServer from Running
  2. Find and open your ROCK’s Roon folder from another computer
  3. Locate and delete only the cache folder (Roon/Cache)
  4. Restart RoonServer from the ROCK WebUI

Thanks,
Noris


(simon arnold) #17

Hi @noris I have already done this before contacting support about the issue. I can try again but can’t see it helping as it didn’t before.


(simon arnold) #18

I have tweaked a few network settings today to see if this helps at all.


(Noris) #19

Hello @simon_arnold,

Any luck with the new network settings? I have gone ahead and started a case for you with our QA team who will be able to take a closer look at the diagnostics.

I will be sure to let you know once this case reaches their queue and they have a chance to review, but please let me know if you are able to resolve this issue with any other network settings.

Thanks,
Noris


(Noris) #20

Hello @simon_arnold,

Just wanted to check in with you here and let you know that we discussed this issue with a senior dev today and they mentioned that this is likely due to some kind of networking bottleneck. Specifically, they mentioned that if you use some kind of corporate network or a VPN/Proxy, then this could be slowing this down. Are you making use of any such software or restricted network space? Please let me know when possible.

Thanks,
Noris


(simon arnold) #21

No no VPN or anything like that. Just pure ISP connection.


(simon arnold) #22

It seems to be quicker on PC for searching now since I went with 1.1.1.1 for DNS and tweaked a few things on my access point. but my phone still seems very slow at searching on the same access point. Adding albums is still not particular quick but not had the adding in background at all since switching dns provider. So I agree its a combination of network bottleneck but its working out where that’s the issue as all music plays flawlessly and I can stream high bandwidth video too no issues. Perhaps my ISP is causing some traffic shaping.


(Noris) #23

Hey @simon_arnold,

I just wanted to check in with you here and see if there were any updates regarding this issue. Have you been able to investigate traffic shaping on the ISP side? You can also configure the DNS for your iPhone in the WiFi settings and set it to cloudflare to see if that has any change in behavior. Please let me know what you find.

Thanks,
Noris