Adding Music To Library Wheel Keeps Spinning

For at least the last two day the blue wheel towards the upper right corner has been spinning. When I click on it a message pops up indicating that “Adding Music to Library:” of 47 tracks, 47 added, 0 identified

Everything that I recently added mostly from Roon are available and playable. I did see that the last two which showed up first under Overview were missing album art which I added this morning.

I have stopped and restarted Roon running on my i5 sonic transporter a couple of times.

Any suggestions?

There might be something amiss with those tracks causing Roon to hang on them. Can you share which tracks are causing the issue (name, format, etc)?

Edit, Sorry, misread your post. I thought you meant you had some music which was added but not yet seen.

I am not sure which tracks you are referring to. The wheel was spinning before I added the last two Tidal albums

Hi @Still-One,

Can you describe where your library is stored and how it’s connected to the Core machine? If it’s networked storage, please describe your networking setup as well, including all networking hardware involved. Often times this behavior can stem from issues with the Core machine having trouble communicating with the storage location, so additional information here will definitely help.


My library is stored on a 2TB drive that is located in my SonicTransporter i5. Roon is also located on that device. That is hardwired to my network. Cable Modem–>>Netgear Orbi Wirless---->>TrendNet unmanaged Port–>sonicTransporter i5 and Vivaldi Upsampler

Thanks @Still-One.

I’d like to enable some diagnostics on your account so we can take a look at what you’re experiencing here. Before I do this, may I ask that you please do the following:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Where do I find the time stamps you require?

I have performed the second reboot and am letting it run for the 5 minutes

I have completed your request but am not positive how to provide the time stamps. Looking at the diagnostics tab I do see that most of the occurred around 13:00 on the 13th of Dec.

Hi @Still-One,

Diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @Still-One,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.

I have not been able to initiate Dropbox. I keep getting an error message. I have created a zipped the log files.


Hello @Still-One,

I have PM’d you an alternate upload method. Please let us know after you upload those files.


Working to create new logs now. Will send shortly

1 Like

I “think” they are sent. I provided the link in a reply PM.

Hello @Still-One,

Thanks for sending that log file over. Unfortunately it does not include the timestamp time of Dec 13th as that would be in the Roon_log01.txt file and not the Roon_log.txt one you have sent but I have taken a look at the log you sent and I noticed a few issues, it appears that your network or a bad Ethernet cable might be the fault here since I am seeing IO Failures in the logs. With this finding in mind, I propose the following steps:

  1. Please try a different Ethernet cable connecting your SonicTransporter to the network
  2. Is the behavior the same if you try connecting the SonicTransporter directly to the Orbi router instead of the TP Link switch?
  3. Try to disable IGMP Proxying for your Orbi setup (as mentioned in our Networking Best Practices Guide)
  4. (optional) Upload the rest of your Roon log files so we can take a look for the timestamp you mentioned

Please let me know your findings to my suggestions.


I will try another ethernet cable but I doubt that is the issue. I replaced that cable awhile back at the same time I inserted the switch between the router and my SomicTransporter and also my dCS Upsampler. I was getting frequent and regular dropouts with a direct connection (and also when I tried a TPLink switch) All dropouts immediately stopped with the Trendnet switch which was a suggestion from Andrew at SGC.

I will send over all log files soon.

I will read the Networking Best Practices.

When I was having the incessent dropout issue I was working with my dealer, Orbi support and Andrew at SGC to resolve that issue. I do not remember all of the changes the Orbi “troubleshooters” suggested so they may have had me do something to your item 3.

Logs sent under Still-oneFULLlogs12-17-18

I checked and IGMP Proxying was disabled.

I am a bit confused. The log files I am forwarding are from my laptop and based on date stamps are current. The odd part is Roon is running on my Sonictransporter and when I go to the tab I see one current file there. Why is there a log file on my laptop? I have’t run Roon there is well over a year.

@Still-One - The log files present on your Laptop are because you were using your Laptop as a Roon Remote to control the SonicTransporter. Thanks for clarifying that the files you uploaded are from your Roon Remote and not the Sonictransporter. To get the SonicTransporter logs, please use these instructions:

  • Go to the sonicTransporter web user interface from
  • Go to Settings -> Roon Server
  • Check “Expose Roon Server database” and press Save Changes
  • RoonServer will now show up under network share for device in explorer or finder
  • Locate the Logs folder and create an archive of them
  • Upload to our servers and provide the name of the Logs so we can take a look


I have uploaded the files. I initially forgot to change the zip file name so I sent two copies. You are looking for

Can I delete any or all files out of library on my laptop? Should there be log files there at all?