After editing items, Roon hangs with spinning wheel and message adding music to library

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2018, 2.2ghz 6 core intel i7, 32gb memory
roon 1.7 build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

virgin media hub
download speed 220 mbps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


After editing a single album the spinning wheel status indicated that it is adding the number of tracks in the album and 0 have been identified. If I close Roon and restart this resolves but then repeats next time i try to edit something

I also notice when i ask Roon to identify an album in the edit function it frequently provides does not identify anything and will only do so if i keep repeating the request to identify.

Sometimes when doing this i get the message “Please check your network connection and try again” but only sometimes

I checked my firewall and it says Roon is allowed

I’m wondering if this a connectivity problem between Roon, my mini mac and my network or a problem with my Roon build

I do have a very large library (700k tracks) but have not previously had this problem - started when Roon updated to latest version

Any help appreciated


Maybe the following advice:will help
Clear Roon cache

Thanks, I deleted the files in the cash but then the same ones re-appeared when i restarted Roon. I’m unsure whether this is expected but one of the files is a zip file which did seem strange to me ( and then there’s an http.cache and an http.cach_2 and then some others.

Anyway, still experiencing the same problem

i also notice a message “there was an error checking for an update” in the core box in the “about” section which i also mention in case anyone has seen all this and knows how to fix it

Did you stop Roon before deleting the cache files and after deleting I suggest rebooting. if this doesn’t work clear the image cache on the remote , this has fixed it in some situations.

Zip files in the cache are normal. All files will return when it’s restarted this is normal.

Thanks I’ve done all that and it hasn’t helped. I think a key symptom is when I try to manually search for a CD, I get a message that says please check your network connection and try again.

I could guess this means its more about the interaction of Roon with my network and so rebuilding my installation is unlikely to help but any and all advice appreciated

Ok I cleared the image cache and restarted the software. The search function worked correctly for the first title i checked but then stopped working for any title tested subsequently. Seems to be an internet connectivity problem. disabled firewall, virus software, etc. Any and all advice appreciated

Hi @number6mi,

How do you have your DNS servers configured? We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

Thanks for the response. This is beyond my technical knowledge. Do i make this change in the router or in the mac settings.

I have found where in the Mac DNS settings can be changed

In the case of my router, I know how get into the advanced settings of my router but i have no idea what i should be looking for in those advanced settings to change. Anything you could tell me about what to look for in the menu to change would be greatly appreciated

Does roon get it’s own mac/ip address or is the relevant address the address assigned to my mac?

Actually I’ve just learned the DNS cannot be changed on the virgin media router i have and i would have to convert it to operate as a modem with a separate router to change the dns at that level

I’ve changed the DNS setting on my mac to the google ip address. strangely it seemed to work when i tried to edit a title but then didn’t work for any additional titles i try to change.

This is getting increasingly frustrating…

If i just delete and rebuild, is it likely to help or is it more likely a network issue this won’t help with?

Hi @number6mi,

Thanks for giving the DNS change a try.

This sounds like a networking issue as of now, but you do also have an extremely large database.

Before we dive into the networking aspect, you can try to temporarily use a fresh database to test the database size theory out, instructions on how to do so below:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Test the search behavior
  • Once done, you can rename Roon_old back to Roon to get your old database back

Can you please let me know how this goes?

The problem got worse before your suggestion - just hung trying to add 12 tracks which nothing resolved. I found the test suggestion in an earlier thread and although on a small database, there didn’t seem to be any problems. i also noticed that the message in the core box in the “about” which indicated the build was the lates but said “there was an error checking for an update” now says “you have the latest version installed” which reinforced that the problem started with new software and that there was some problem with the update not completing properly. So on this basis I concluded it probably wasn’t a network problem and have gone ahead with rebuilding it which is 3/4 done in 6 hours. Maybe i jumped the gun if you would have had any other suggestions but we’ll see how things work after completed at this point.

1 Like

For what it’s worth, the rebuild of the database seemed to have solved the problem. Everything was loaded (c 700k tracks) and editing now works smoothly. The background audio analysis is still going but that looks like it’s going to take a couple days (even at 12 core speed). My theory is it all had to do with the message about there being an error checking for an update, even though the latest build was displayed as added. Obviously frustrating to have to rebuild like this but I could guess the size of my library is more prone to problems like this.

1 Like

Hi @number6mi,

Glad to hear that the rebuild is going well! Do let me know if there are any further issues after it completes or if it resolves the issue, thanks!

Very sadly the problem experienced 10 days ago with Roon not being able to search metadata returned. I saw the same message again in “About” in the settings that “there was an error checking for an update”.

I stopped Roon, deleted the cache, and restarted and at least for now this message has gone away and search is working. However, i notice when i first go into the editor, the album cover for the title appears to the right of the identify album button instead of directly over it which i didn’t remember before and i wonder if this suggests some problem or i just have a bad memory.

Appreciate any information about whether seeing the message “there was an error checking for an update” is a known problem and what to do about it or if it is being worked on. Also whether the appearance of the album cover to the right instead of directly over the identify button is normal behaviour or an indicator of a problem?

Thanks for any help or information that can be provided

HI @number6mi,

Yes, this is a known issue that we are working on. From the other reports, a reboot usually sorts this behavior out.

Can you share a screenshot of what you mean? If you are seeing the button I don’t believe it’s an actual issue, it could just be the scale/resolution you’re running Roon in.

Here’s the screenshot i see on searching with the picture shown skewed to the right

And here’s the screenshot I see in the about tab showing “there’s an error checking for updates”

Whenever I experience the problem described searching, this update message appears. When search is working, it does not appear. The problem is intermittent but occurs too often.

It does seem to me there is some bug involved causing this although I’ll grant you my library is really big which I’m sure makes it more likely to experience problems like this.

Any information on whether this is a known problem being addressed or what i can do to resolve it permanently would be appreciated

Hi @number6mi,

I am seeing the same on my end, I believe this is expected behavior or due to the resolution of the screen.

This almost sounds like your entire external internet is dropping off, can you try a continuous ping test to and see if you get packet loss at the time of the message?

Thx Noris.

Here are the results from the ping test on the network utility. it says no packet loss

10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 16.317/19.573/25.121/3.203 ms

Curiously, on speedtest, it shows a ? for packet loss and if I click on that I get this message:
Some Speedtest servers may not support this capability, or an error occurred with the packet loss test.

Let me know if any further thoughts

Hi @number6mi,

10 packets are not enough to say that the network is stable, I would chose the “send an unlimited number of pings” option, have that running the background and see if there’s any packet loss when Roon hangs on adding the album or you see the update error message.

well i’ve sent many packet and get a no packet error message when experiencing the issue
any other suggestions? The intermittent nature of it is really frustrating. Sometimes it works fine and sometimes it just doesn’t work