After latest update, my PC screen is black & garbled - unusable

Core Machine (Operating system/System info/Roon build number)
Windows 7. Roon 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
All has been fine for months & months. Was out of town a few days and got back. Roon said it needed to update, and I hit Update All.

After update, my screen is completely black with blue & white lettering. Not the normal view at all. When I move the mouse to hit hot spots on the screen, more letters and words overlay on top of the other letters. I can not navigate at all.

Can you get me back to prior version? Or what?


Hi @Richard_Tibbets,

There are reports of certain graphics cards not playing nicely with Roon.

What GPU is fitted to your PC?

I’ll tag @support to follow this up with you.
However, in the meantime I’d recommend checking that the latest manufacturer’s graphics drivers are installed.

Hi Carl,

I use a Lenovo ThinkPad Edge laptop to run Roon and have had no problems since 11/2017. The Lenovo is all original factory with no mods. I can’t find a GPU designation anywhere, but the Display Adapter is an AMD Radcon HD 8450G.

If you can not easily fix, can you get me back to the previous Roon version that worked fine, and then shut off future updates? At some point I’ll buy a new more powerful laptop, but I can’t do it right now.



Hi @Richard_Tibbets,

Can you share a screenshot of what you’re seeing?

This image taken after starting Roon, selecting Playlists and scrolling down a bit.

Does that help?

Thanks for the screenshot, @Richard_Tibbets.

First, can you try updating the drivers for the AMD Radeon HD 8450 GPU and let us know if that helps? If there is no change, can you then use the directions found here and send us over a set of logs using a shared Dropbox link?


OK. I was able to get an updated driver installed within Device Manager. But the display problem is still present and no change to the screen as far as I can tell.

Here is a link to the Zipped log files per your instructions:

Hope this helps.

I appreciate your efforts to fix this for me.


Thanks, @Richard_Tibbets — The team is reviewing the logs you’ve sent and I’ll be sure to update you as soon as they’ve provided further feedback on this.

EDIT — Can you verify the driver version for the GPU that you updated to?

Most recent drivers are old:


The driver provider is AMD, driver version is

When I hit Update Driver, Windows says the driver is the most current driver available (for whatever that’s worth).

1 Like

The Window’s update often lags those available from the GPU manufacturer … hence …

Google for the manufacture site and download / install the driver from there.

I downloaded & installed the AMD Catalyst Control Center and got the most current driver from there as well. The version is the same.

1 Like

Oh well, it was worth a try … back to Roon’s @support.

Thanks for trying what @Carl suggested, @Richard_Tibbets.

I’ve passed a report with all of this information to our QA team for further investigation. As soon as I have their feedback I’ll follow up with you here.

Hey @Dylan,

Can you give me an update on the resolution to my problem before your team clocks out for the weekend?

If you don’t yet have a fix identified, can you at least please tell me what this latest Roon update altered within the video related software that has affected my PC?



Hi @Richard_Tibbets,

The team investigated this and has passed a ticket over to our development team. I don’t have any specific timelines I can provide at this time but I’ll be sure to update you as soon as we have more information!

Hi Dylan,

Can I please get an update on my monitor display problem. Roon has worked great for me for over 2 years, and now it’s broken due to something within your last update. There have been no changes to my laptop at all. And the only thing to come out of your team so far is: “Check your video driver.”



Have you trying installing Build 528 that was released yesterday?

Yes. I got an offer for an update earlier today & installed it. Using my roon remote PC I verified the core is at build 528.

The problem looks the same. Still not working.


It’s been a week since any activity on this thread. Is there any encouraging update, I hope?