After Update, Network Error: Please Check Your Internet Connection

I’m receiving the same error. After updating to version 2.0 (build 1272), I can no longer login to or access the roon server on my network. I get the message "Network error: Please check your internet connection. This happens from desktop and mobile. ARC no longer connects either. It just spins indefinitely.

Just wanted to add, I uninstalled, then reinstalled Roon Server. Same issues. Also, here is a snip of the log:

05/10 23:36:20 Warn: [easyhttp] [13] Get web exception without response: An attempt was made to access a socket in a way forbidden by its access permissions. ( An attempt was made to access a socket in a way forbidden by its access permissions. (
05/10 23:36:20 Warn: [push2] request to push manager failed ( with status code: 999
05/10 23:36:20 Trace: [push2] retrying connection in 203614ms
05/10 23:36:23 Trace: [remoting/brokerserver] [initconn>] Connected
05/10 23:36:23 Warn: [remoting/brokerserver] [initconn>] failed: System.Exception: got unexpected broker id in REQ_HANDSHAKE: 6b9037e4-95bf-457d-a8fb-a7ab2d5e66ac
   at Sooloos.Broker.Distributed.InitConnectionV2.Go()

I’ve moved your post in another support thread to a new topic in the Support category of the forum, where it will be seen, and responded to, by a member of the Support team.

In order for Roon’s support team to assist you better, please fill out the template below and post it here.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they have a clear understanding of how your devices are connected. Thanks.

Can you please let Roon Support know these details so that they can better assist you? Thanks!

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell them how large your music library is, eg. “30,000 tracks”

Roon Core Machine

OS: Windows 10 22H2
Model PC: Custom Built
CPU: Ryzen 5 3600X
RAM: 32 GB 3600MHZ

Networking Gear & Setup Details
Roon Core is wired
Router: UniFi UDM Pro
Switch: UniFi US 16 150W
Switch: x3 UniFi Switch 8

Connected Audio Devices
Topping E70 DAC
Topping L70 HPA
DAC and HPA connected via XLR
DAC connected via USB 2.0

Number of Tracks in Library

To add to this issue:

I noticed I can go to the option “Use this PC” under “Setup Roon Core on this PC”, and it will let me continue to set up a new core after I log in. If I try to connect to my original core, as soon as I try to log in, that is when I get the network error. What’s funny is, the PC I am able to turn into a new core IS my Roon Core server.

Has there been any acknowledgment or response or update to this issue? Is there somewhere else I should be posting to get support?

Not as yet. The Roon Support team is small (5 people) and they work with a queue system. Once your issue reaches the head of the queue, a member of the team will respond to you here.

Hey @Ronald_Jackson_Jr,

Thanks for your patience while our team works through each thread!

You have an odd issue indeed. I’d be curious to see if a Roon database refresh may help in this case. Steps to follow below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

I’ll be on standby for your reply. :+1:

Hi Benjamin,

Thank you for your assistance on my issue. I followed the steps you recommended and still get the Network error message. I renamed the Roon server folder in local appdata. I then reinstalled Roon server. upon launch, I see my core, but when I log in I still get the network error.

Hey @Ronald_Jackson_Jr,

Thanks for giving that a try! I’m seeing the windows 10 core PC as not being online for the last two weeks. Are you able to bring the computer online at all? Did you perform the steps above on your core device, or the windows 11 remote?

It would be good to review the core diagnostics from the windows 10 device, but we’ll need you to bring it online. You can also use the directions found here and send over a set of logs to our File Uploader.

Thanks, Ronald!

Hi Benjamin,

It’s a win10 pc that is online. I use it for Roon, Plex, and other multimedia needs. I can remote into it from work right now without any issues.

I performed the steps above on the core server pc itself.

I will gather and send the logs to you as soon as I am home this evening.

Thank you for assisting me with this issue.


Hi Benjamin,

I was able to resolve this issue. When you mentioned that you were not seeing my core online for two weeks, it got me thinking. That was when I was prompted to update my core. I went back over my settings and noticed, when I tried to connect to Roon from my phone using ARC. It could not find the core. My server is behind a VPN, and after disabling my VPN, it now connects.

I’m curious why after the update, I am no longer able to connect while on VPN. I had no issue before the update.

I am using Mullvad for my VPN server.

1 Like

Hey @Ronald_Jackson_Jr,

I’m glad you were able to work things out! Because the use of VPNs are out of scope for support, I would suggest heading over to the #tinkering community category, as I’m sure many users on the form could be helpful in this area.

Happy listening! :musical_note:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.