After upgrading to latest Mac software trouble with Roon

I just upgraded to Mac OS 10.14.3 on several Macs (MacBook Pro, Mac Mini Core, iMac) also upgrading to Mac iOS 12.1.4 on an iPad4. Roon keeps quitting when I acces the program, I have to reinstall and it keeps doing it. please help.

Hello @Richard_Thorpe,

How exactly is Roon quitting, does it display the Quote screen and then exit or does it just abruptly shut down? Do you have backups of your database saved somewhere safe?


it dispays the quote screen then quits

Hi @Richard_Thorpe,

Thanks for letting me know that. As a temporary test, I would like to set your current database aside and verify if this issue still occurs when using a fresh database. To perform this step, please use these instructions:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location:
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall/Restart the Roon App to generate a new Roon folder
  • (Optional) - If everything is working as expected and you have a backup, you can restore your old database from the backup.


Noris do I do this for the Core on my MacMini. I tried it on my macbook and it quits when I select a “zone”

noris, it quits on my MacBook even when I select screen size

Hi @Richard_Thorpe,

You would have to make the above changes to your Core, not the Roon Remotes. Be aware that after you make this change you might have to go back to the “Choose your Core” screen on your Roon Remotes and re-select the Mac Mini.

– Noris

will I be able to get all my settings back or are they lost?

@Richard_Thorpe - If you have a backup from before this issue started then you will be able to get your settings back. If you don’t have a backup you will unfortunately have to reconfigure the machine as a new Core. Has my suggestion worked to stop the crashes?

– Noris

I have yet to re install the core software on my Macmini I believe it is the server software

I’ve restarted my ipod touch and it now works with Roon I’m reluctant to trash my core. I suppose this will work until Roon and Apple work things out. Untll then the only remote that works is the iPod touch and my iPhone that was not upgraded to the new Apple software

Hi @Richard_Thorpe,

Ok, no worries. One other thing that you may want to try is to clear the queue on your Roon Remotes. You can do so by pressing the “Now Playing” tab and then “Clear Upcoming” and then the “Clear All” button that appears afterwards:

– Noris

I’m running Roon Server on my headless MacMini how do I access the server to make adjustments? I can restart by rebooting the MacMini but thats it. Thank you.

Same way you access it to play music: Load Roon onto another device to use as a Control, select your MacMini as Core then drop down the hamburger menu at top left and access Settings.

Thank you, so I can delete the Roon Server on my core ( it may be corrupted) install a fresh copy then reinstall my settings from a backup?

Hi @Richard_Thorpe,

Can you elaborate a bit on what you’re trying to make adjustments to here? What kind of issues are you experiencing?

1 Like

We have been talking for days Roon keeps quiting under some conditions apparently your monitoring my core. I was told yesterday by another Roon tech that I may have to delete and reinstall the Roon server on my MacMini core.

Overnight the IP address of my core server has changed why? is that Roons doing? other than that my problem still exists.

That is your DHCP server’s doing. It is possible for a computer/device to not to renew its IP lease correctly and then when it logs back get a different IP address.

This is a part of an ongoing issue. Something is very wrong my core. it has had the same IP address for years and now since this problem with Roon it changes. Please explain? Thank you.