AirPlay No Longer Working


I have 3 different Roon Endpoints PS Audio DS Dac, Oppo 205 & Micro Rendu. All working fine, as well as an iPad i just tested.

I have a number of AirPlay devices, a Marantz Receiver with AP support, 2 Apple TV’s, and a few Airport Expresses.

All of my Air Play devices stopped working. I can stream to all of them from iTunes, but from Roon, I can see them in Audio settings, enable them, choose them as my output zone and start to play.

Only problem is that the music does not play. When you hit play the progress bar won’t move.

Signal Path: High Quality

Shows the AirPlay device name with a Green light followed by

Source with Purple light

Airport10,115 with Green light

Just no sound and no movement of the progress bar.

I tried putting a password onto Airport device & re-adding it to Room (which prompt for the password) but still no joy.

I have been using Roon for about 6 months, and it makes no difference wether I play directly from the core, or using a connected computer, or mobile remote.

All devices are connected to my single home network (mostly via CAT 7 ethernet) and everything else is normal.


Thee is a known issue with those airplay devices like airport express, applets and home pods I think that broke rooms airplay support which is currently only airplay ready and not airplay2. This might extend to other airplay2 devices.

Yes it looks like Apples recent firmware updates is causing the problem. I just pulled an older Airport (same device with older firmware) out of the closet, and I configured it exactly the same (but skipped the firmware update) and it works as expected.

I am surprised that my Marantz receiver must have gotten an auto update somehow though, because it worked fine last time I used it a few weeks ago.

I hope that Roon is aware of this issue and working on a fix in their next update. Although I did not use AirPlay a lot with Roon, it is a nice feature when needed, and I am sure that there are many users experiencing the same issues.

Same issue here for me. Using a Airport Express that is running firmware 7.8, connected via WiFi.

Hopefully Roon folks are working on a fix …

My Cambridge Audio CXN sees Roon on Airplay no problem , listening now


i have a similar problem. no airplay devices show up in roon anymore since the last roon update


OK so I just installed the latest Roon release.

The problem has not been fixed, but now you can no longer see incompatible AirPlay devices
under the Audio Tab in Roon Settings.

So rather than fixing the issue, they have hidden the non working devices.

It would be real nice if someone from Roon Support would chime in here and let us know that they are aware of the issue, and are working on a fix for it.

I can no longer see my AirPlay compatible Marantz AV receiver on the network through Roon.

It is there on the Network, along with an AirPort Express, running Apples latest firmware, but Roon no longer sees them.

My other AirPort Expresses (4 of them) all work fine, as does my 4K Apple TV, but I am scared to update the firmware on any of these devices.

Any Roon Support people on here?

Hey everyone,

At this time, we have not announced any plans regarding Airplay 2.

Apple’s latest firmware for the Airport Express removed Airplay 1 support from the device, which unfortunately means the device will no longer work with Roon once it’s running this firmware. In order to use this device with Roon, you’ll need to downgrade to the older firmware, as discussed here.

As of our most recent release, Roon will will no longer show devices that only support Airplay 2, since Roon cannot currently stream to these devices. That said, the reason Roon cannot stream to Airport Express is because of Apple’s firmware update, not because of any changes in Roon.

We’re looking into what’s going on with the Marantz recievers – any chance it took an update that disabled Airplay 1?

@support will follow up if we need more information here, but we’re looking into this.


Thanks to Support for clarifying this.

The link to downgrade the AirPort firmware should help many people.

I can only assume that my Marantz receiver must have automatically updated itself, as i did not perform any update, and it was working fine with Roon

It is a Marantz SR-7012 (current model). I will look at the firmware tomorrow and report back here.

FYI I just rolled back the Firmware of my AirPart Express by 1 version to 7.6.9
and it works fine.

As AirPlay 2 is definitely the future, I hope that the Roon Team can support it.

I was just going to buy a pair of HomePods now that they support stereo, but I will hold off
until this gets sorted out.

ok, that explains. a pity though.
workaround on the mac is selecting the mac as the playing zone and then choose the output device trough the volume menu in the taskbar

Thanks for that Workaround. I never though of that.

At least it gets me some audio into the room with the Marantz AV receiver now.

I do hope that the Roon team finds a way to support AirPlay 2. What would be even better is if we could
group different types of outputs all together no matter what format they are.

Currently I have 2 types, my PS Audio DS DAC (USB or Bridge II) goes with my other USB DACs and my Micro Rendu & then there are a number of AirPlay devices. Each type can group with others of the same type, but the 2 types can not be grouped.

Hi everyone,

We’ve just released build 363 of Roon which includes a change to address playback issues to devices that support Airplay2. Note that Roon does not support Airplay2 — This change addresses devices that recently added Airplay2 support. Please take a look at the release notes below and give the update a try.

A post was split to a new topic: Grouped Airplay Zones - Only One Device Plays