Airplay stuttering issues

(Janis) #1

HI,

I just installed Roon on Mac mini (i7 3Ghz, 16GB memory) and added library, and I’m trying it out.

I can play all files DSD, AIFF, M4A perfectly via USB to Deviate directly connected to the Mac mini.

However, Airplay playback doesn’t work properly. It recognizes immediately my three Airplay devices on the network, but playback is either with big dropouts, smaller dropouts, or almost doesn’t play at all:

  • Airport Express (quite old) connected via Ethernet - 10% of music is stuttering
  • Bose SoundTouch 30 (one year old) connected WiFi - activates and starts to play, but 90% of music doesn’t play
  • DENON CEOL piccolo (one year old) connected WiFI - 40% of music is stuttering

CPU load on Roon server is below 30%.

In my view there is problem with Roon OSx version streaming to Airplay devices. How to fix it? If I can play only on directly connected Devialet, and not on Airplay nor DLNA, then to purchase Roon license is kind of questionable.

Please advise.

Janis

(Daniel Beyer) #2

A couple of questions:

Where are your music files? Are they local to the Mac Mini?

Does the stuttering happen during all music or during specific file types like DSD? Airplay is only 16/44.1, all higher resolution music needs to be transcoded down to that resolution.

To give suggestions to help, we would need to know a bit about your network setup.

(Janis) #3

Dear Daniel

Thank you for your fast response!
My music files are on Synology NAS SMB3 connected to OSX. The dropouts are exactly the same on all files - DSD 64, AIFF 192, and basic iTunes 16/44.1 m4a files. So it is not transcoding issue. Also all import and analysis tasks are finished/ stopped. CPU is free.

All AirPlay devices are perfectly recognized by Roon, just streaming is stuttering or on Bose almost not working. At the same time Tidal or any other basic players through the same network are playing on same AirPlay devices without any issues.

On the Roon server at same time the audio quality when playing the DSD 64 on my Devialet directly connected via USB is AMAZING without any dropouts.

The issue seems to be on stream going out, not inbound traffic, or transcoding/ CPU overload.

Please let me know what other info I should provide to help to fix issue. I love Roon from moment I set it up, and look forward to get full use of it. I hope to use Roon not only for nice metadata and HIFI direct music USB payback, but finally have one server to stream them all! I’m tired to use JRiver, Plex, Tidal servers and remote apps to feed all connected devices I have.

Janis

(Tom T) #4

Hi @Janis

From where I sit, it looks like a wifi issue. You don’t mention what kind of wifi router you’re using. It’s age could have an impact. So will wifi congestion, if any, in your location.

Does the Soundlink work without stuttering when using Airplay on other applications? (With Roon shutdown.)

I would recommend a reboot of your entire wifi system. Shut down the router and all devices. Then, in sequence, turn on the router, wait for it to fully boot up and then turn on the other devices, allowing them to be assigned their own IP addresses. (In my home wifi setup - even in a rural setting with no neighboring wifi - I do this every month or so. I discovered that some cell phones/tablets get confused with IP addresses as they enter and exit the wifi network over the course of a typical day. This led to intermittent streaming lockups and the inability of some devices to connect that had previously connected fine.)

In my setup, I was able to run Roon via Airplay to my BR AppleTV within 10 minutes of downloading and installing Roon. It worked right away. I had - but have since sold - two Bose Soundlink Touch speakers that worked almost perfectly in my system. (They would often cut out/stutter when the microwave was cooking. So there’s that.) When I had problems with the Bose Soundlink Touch speakers, I reset them by removing the battery momentarily. At one point, when I moved and reconfigured my wifi network, I reset and re-setup the Bose Soundlinks. Worked right away.

If you don’t have any luck, repost your configuration including the wifi router model and age.

Good luck.

(Mr Fix It ) #5

One other issue I recall is not using jumbo frames, for NAS. It might be worth a shot to turn off jumbo frames or perhaps use smb2

(Janis) #6

Thank you Paul and Tom!

I can confirm that restarting whole NW infrastructure (Airport Extreme Tower WiFi router, Ubiquity WiFi extender, 3x Netgear switches) and WiFi connected devices helped to fix stuttering issues on the WiFi connected endpoints:

  • Bose SoundTouch 30 - WiFi connected - 100% correct playback now
  • DENON CEOL picollo - WiFi connected - 100% correct playback now

Still I have one very strange sturreting issue remaining on one of two Ethernet connected endpoints to the same Netgear switch:

  • Apple TV 4 - Ethernet connected - 100% correct playback
  • Airport Express - Ethernet connected - 10-20% of playback is stuttering on OPTICAL EXIT ONLY

More details on the Airport Express set-up:

  • Ethernet connected (WiFi module switched off) to same Netgear switch where Apple TV is playing perfectly
  • Optical connection to Antelope Zodiac DAC is stuttering, I see Zodiac DAC relay switching on and off as Airport Express is starting and droping repeatedly optical signal transmission
  • At the same time if I connect Aiport Express with analog connection to amplifier it plays perfect without any dropouts
  • Also if I launch on iPad Tidal application and play in the same set-up Ethernet-Airport Express-Optics-Antelope Zodiac DAC-analog-amplifier, there are no dropouts or stuttering

Seems to me the issue is specifically when Roon is streaming to Airport Express that is connected with optics to DAC - dropouts on optics exit only and only if Roon is playing (other Apps streaming is perfect). I think I saw already similar issue in Community forum exported on Airport Express - OPTICS - DAC set-up. How to fix it?

Paul, thank you for note - SMB and jumbo frames are not issue here. I use SMB3 and all NAS to Roon traffic is just perfect!

Janis

(Mr Fix It ) #7

I have an airport express here I can try with…but not sure I can manage an optical out, although I can’t see why optical would be much different to analogue as its derived from the same digital conversion. Ill try and find an optical and analogue option - but I have it in my laundry area where I don’t really have an audio need, but more as a wifi zone.

I have ATV2,3&4 and they all work fine using HDMI and the optical on the ATV2 works fine too.

One question on the APE is what version are you using…mine is a latest spec with the 2 Ethernet ports but I think I have a really old one like the wall wart type but I’m not sure that supports airplay. My APE is listed in Roon as an Airport10,115

My oldest APE Wallwart type is listed in Roon as an Airport4,107

(Mr Fix It ) #8

Just an update…I am playing to the old wall wart APE via optical and the newest APE via headphones in a group both wired ethernet and no issues.

I have seen the older wall wart types rather flakey in their old age.

(Tom T) #9

Hi @Janis ,

I suggest replacing that AE with a newer model or an Apple TV (3rd?) Gen with optical out.

Those older AE had jitter issues. I never experienced it since I only used mine as a network extender. Perhaps try a factory reset on it first and reconfig it for your network. That worked for me until it eventually died from an internal power supply burnout.

Glad to hear your other devices are playing well. You may need to “reboot” the network from time to time.

Good luck.

Tom

(Janis) #10

Thank you!

AEP I have is the old 1st version device (in fact repeated the set-up with two more of the same release). Factory rest and newest FW upgrade done on all of them. All other players (except Roon) with then same DAC connected via optics work without any issues. So, the problem is Roon specific.
Any of Apple TV I will not use, as it is up converting transport signal from 44.1 to 48, and corrupting quality with it. So, while I have few old ATV 2 and ATV 3 I wouldn’t use them.

No worries, if there is very strange issue with Roon compatibility to play with old AEP via optics, I will not use and will find other solution.

Just for Roon team to mark and might be to investigate the issue. As I wrote other users had the same problem (documented in the community forum).

Janis

(Tom T) #11

Thanks for answering a question I’ve had for awhile: whether the AEP up-converts to 48 like the Apple TV does. I think I might re-purpose mine for listening since it does not.

Best wishes,

T.

(Janis) #12

AEP is just transport and doesn’t upconvert=damage like ATV does. So, AEP is much better to connect HiFi DAC to network than ATV.
Unfortunately, Roon has issue pushing through AEP optical connection unlike any other players.

So, in my case not used benefit… I hope your works! Take benefit of it!

Janis

(Mr Fix It ) #13

One difference for me is that my core is on win10. I could move it to a macmini to try I guess…but kind of tied up with other stuff and traveling all next week.

(Thomas Rissman) #14

@support
Sorry to resurrect an old thread, but this describes an issue I’m currently having with Roon. I run Roon 1.2 (build 165) on a Mac Pro with 12 cores and 22GB of RAM. I am streaming to an Airplay device (a My:ro Air). This usually works well, but today I started experiencing dropouts while playing music. The dropouts lasted only one or two notes and then the music continued playing. After some random number of minutes (5-10) there would be another dropout. I expereinced this when playing ALAC from local disk and when playing TIDAL files. This does not appear to be a hardware or cabling problem because (i) iTunes playing the same ALAC files to the same device does not ever dropout, (2) TIDAL app playing the same TIDAL files to the same device does not skip and (iii) if I change the Roon settings so that Roon plays through the System Default and then set the System Default to the Airplay device it does not drop out.

This suggests to me that there is something that Apple is doing differently in its Airplay implementation than what Roon is doing. It would really be nice to be able to play Roon reliably over Airplay devices without having to route it through the System Default.

Any help much appreciated.

(Jeroen Jaspers) #15

Hi Thomas,

I was having similar skipping issue with my Arcam Airdac (only with Roon, not “normal” airplay). For some reason switching from my Airport Extreme to a generic Linksys network switch solved the stuttering for me. I don’t know why, maybe there is some sort of buffering going on in the Airport Extreme that conflicts with Roon’s airplay implementation.

Or you can try this (slightly off-topic): I think your My:ro is also capable of upnp streaming. If you are technically inclined you can find squeeze2upnp here: https://github.com/philippe44/LMS-to-uPnP/tree/master/plugin/Bin. To my ears upnp streaming using Roon’s squeezebox support and squeebox2upnp sounds slightly better compared to airpay.

Hope this helps.

Cheers,
Jeroen

(Thomas Rissman) #16

Jeroen,
Thanks for your response. I will play around with some different network switches, but this seems like a protocol issue that really should be fixed in Roon’s code. As to squeeze2upnp, I am pretty technical, but I must be missing something. I downloaded the OSX version of the code, but when I tried to create the config file using “sudo ./squeeze2upnp-osx-multi -i Config.xml” I got an error message that said the command couldn’t be found. I suspect I need to install some other piece of software (maybe an LMS server?) to make this work, but I’m not sure. Maybe it needs to be in a different directory than the one I have it in. IF you have any additional instructions, they would be much appreciated.

Thanks,

Tom

(Eric Stewart) #17

Hi @Thomas_Rissman ----- Thank you for the report and my apologies for the troubles here. We have documented a variety of reasons as to why someone may be experiencing dropouts in their setup, as seen here in our KnowledgeBase.

Typically, we often find that dropouts are linked to some kind of networking or hardware performance issue. As an example we had a user a few months ago with a very high end home audio system that was experiencing numerous dropouts during listening sessions. After much troubleshooting it was discovered that he had a NAS with a failing drive in it that was causing the issue.

To help me evaluate this problem you are experiencing, may I kindly ask you for the following information:

  1. An expanded description of your current setup as seen here. The more detail you can provide, the better :sunglasses:

  2. A description of your network configuration / topology, as well as some insight into any networking hardware that you may be implementing. I would like to get a sense of how your devices are communicating and what tools are being used to make those connections.

-Eric

(Thomas Rissman) #18

Eric,

Thanks. I think I’ve found the problem. The computer I use to run Core was running another program with significant CPU usage in the background at the time I experienced the dropouts. I’ve reconfigured that program to use no more than half the available CPU cores, and I have not heard a dropout since. I’ll keep testing for a few more days, but I think the issue may have been maxed out CPUs.

My guess is that Apple’s CoreAudio gets around this problem by having a high priority that assures it gets CPU attention. Since Roon runs in userland, it cannot get this kind of superpriority, which is likely why I got different results when running through CoreAudio. We’ll see.

Tom

1 Like
(Jeroen Jaspers) #19

Did you chmod +x on the executable? No LMS is needed. There is an execlent manual on the squeeze2upnp git site: https://github.com/philippe44/LMS-to-uPnP/tree/master/doc (if you still feel like tinkering with it).

Glad to hear you fixed the airplay stuttering issue!

(Hans van Mierlo) #20

Yesterday I have installed RoonServer on a USB 3.0 connected SSD disk to my QNAP TVS-471. Everything worked according to the descriptions. Except that AirPlay through my Linn Akurate DS, the Apple TV (3rd gen) and the Auralic Aries Mini comes with interruptions of a few seconds. Everything is CAT7 connected and I have reset everything too so I cannot imagine a network problem.
Hopefully this will not happen with the SonicOrbiter that is on order…
The search experience etcetera is great but after 7 years Linn without a problem I want to make sure that this will not happen with the Roon Ready Sonicorbiter.