Album exists on NAS, but not found by Roon

Album exists on NAS not found by Roon with meta data provided by MusicBrainz Picard. How can I discover what is going on? Is there a logfile or some other means?

What album is it? Could it have been identified by Roon as something else?
What format is it in?
Is it in the same patch as the rest of your library?

It’s Bitches Brew by Miles Davis. It is in the same path as other albums of Miles Davis. The other albums are listed in Roon.

It is in flac as all the rest.

I have set up an Unidentified bookmark for all such albums. Select Albums, Focus, Inspector, Identified. Back out of Focus to all your identified albums. Then change Focus + to - to give you all Unidentified albums. You might find lost Miles in there. Save as a bookmark as a bookmark anyways for this and future use.

Great software on all levels…especially this kind of meta data.

Try moving the folder out of your watched folders, and then add it back in. It might force Roon to re-parse it.

Both the Unidentiefied Albums and the move in and out of the watched folder did not result in finding the album. It is set up as two folders under the main folder. Like so

Miles Davis
-> Bitches Brew [1970]
–> Disk 1
–> Disk 2

I’ve checked the rights and ownership of all folders, they are all the same.

I renamed the folder. No result.

I suspect it’s the the Disk1, DIsk 2 subfolders and possibly the subsequent filename format causing the issue.

Ensure you follow this convention:

That, moving all tracks into one folder, did not work as well.

Can I find a logfile of what is going on?

It now looks as follows:

01-01 Miles Davis - Bitches Brew [1970] - Pharaoh’s Dance.flac
01-02 Miles Davis - Bitches Brew [1970] - Bitches Brew.flac
02-01 Miles Davis - Bitches Brew [1970] - Spanish Key.flac
02-02 Miles Davis - Bitches Brew [1970] - John McLaughlin.flac
02-03 Miles Davis - Bitches Brew [1970] - Miles Runs the Voodoo Down.flac
02-04 Miles Davis - Bitches Brew [1970] - Sanctuary.flac

Anyway, I find it strange that the way you store the files makes a difference… Things like that make me want to log a bug.

It can make a change in how albums are identified (or not), but I’ve yet to encounter a scenario where files aren’t at least imported and made available. I have some untagged WAV files which Roon has found and added to the library (based on folder and file names).

I’m assuming that you’ve tried forcing a rescan rather than relying on the watched folder functionality to work. I know that there have been some issues in the past with watched folders being a little blind when the folder exists on a NAS.

By chance I noticed the same problem a few days ago, with a Screamin’ Jay Hawkins album. It is a flac rip, just the same as the other SJH album in the same artist folder.
The title is “… What That is!”
I guessed that the preceding dots were confusing things, but editing the metadata to remove them didn’t work. Then I edited the folder name to remove them, forced another rescan, and the album immediately appeared.
Don’t know if it will work for you, but changing the name of the album folder may help.

I also tried forcing a rescan. I also removed the watched folder completely. Both do not work. I will try to rename the files to to match the track-[0…9] pattern and force the scan again.

Hey @Rob_Kamp1give this a read and if you’re still stuck just flag @support and we can take a deeper look for you.


Just before we dive in any further. MusicBrainz Picard reports the tracks has four channels. Could this be the cause of the trouble?

Yes sounds like that’s it. Roon does to support multi channel files as yet and so does not add them into your library.

Thanks. Until now all the players I used could handle the files with ease. Haha, so maybe I should stick to runeaudio or musicbox. Even the players in Windows and macOS play the files.

Is multi-channel a feature coming soon?

I know that the album was originally released in stereo and quad, but I wasn’t aware of any multi-channel digital releases. Was this ripped from a CD or DVD or SACD?

Regardless, this sounds like more of a tagging issue than anything else. Unless you’re certain they’re multi-channel tracks try changing the number of channels to 2 and re-scanning.

More info here:

Cheers Mike. That’s greatly appreciated!