Albums appearing in library although folder and files do not exist [Solved]

@support for some reason, I have a few albums that appear in my library although the corresponding folder and files are not there.

This come probably from a deletion some time in the past. The problem is that I cannot remove these from the library because I get the error that the file is not found.

I alo trie to clean up the library from the Settings menu, but they still remain there. Any guidance how ti fix that is very much appreaciated.

Me too. It came about because I deleted the files using the OS. In the end, I admitted defeat, put them back, and deleted them via Roon.

1 Like

Thanks for this info. Problem is I do not have these files any more. Any further ideas?

You could try creating dummy files with the same names, and then let Roon remove them.

Have you tried rescanning the storage location from Roon?

It happened to me sometimes too, when I was to quick deleting in Windows instead of Roon.
The deleted album showed still up as excisted, and also deleting in Roon was imppossible. But after a few days (tdon’t know why it is not impossible that it doesn’t show up inmediately) I can clean the library, and the album(s) is gone. So just wait a few days and try again.

Yes, it did not help unfortunately.

Thanks for the feedback. I will check in a couple of days and hopefully it will be resolved. Otherwise I will try the suggestion from @Ratbert

Clean the database?

This is the whole point: How do I clean up the database?

Settings/Library/Clean Up Library

Did that already, and Roon says there are 0 files to clean.

Hello @Vassilis_Papaeconomo,

Thank you for contacting support, the feedback is appreciated! I also want to give a quick thank you to the other users who commented on your post giving suggestions about cleaning up the Library as that would have been my initial suggestion as well.

I would like to see if we can trigger a change in behavior here by asking you to please “disable” (not “remove”) the watched folder that had previously contained the media temporarily. After it has been “disabled”, please relaunch the application, re-enable, and try deleting the mentioned “ghost tracks”.

Looking forward to hearing your observations!

@noris many thanks for your input. I tried out what you told me and actually things got worse: Roon created a duplicate of the albums that have this problem. So I now have 8 albums with exactly the same problem instead of 4. 4 of them are duplicates.

Getting frustrated…

Did you “remove” the folder?

No, I disabled it, following the instructions from noris

Hello @Vassilis_Papaeconomo,

Thank you for the follow up and sharing the observations made after having tried the suggestion in my previous post. Sorry to hear of the continued troubles.

I would like to enable diagnostics on your account so our technical staff can get some more insight into what’s going on here. What this action will do is the next time the application is active on your core device a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. I will be sure to update this thread once the report has been received so you know we have it.

In the meantime, may I ask you to please provide me with the following:

  • Please provide the name of the albums that are exhibiting this behavior?

  • Please provide a screenshot of the “file info” window for a single track in one the mentioned “ghost albums” above. You can obtain this information by navigating to the album in Roon -> clicking the 3-dot menu to the right of the track > selecting “file info”. It should look something like this:


@noris, thanks a lot! Appreciate your great support on this.
To answer your questions:

  1. The albums identified (so far) with this issue:
  • Vulture Culture from Alan Parsons
  • Flying Colours from Chris de Burgh
  • Lucille from BB King
  • The Opera Album - Aria from Andrea Bocelli
    Please bear in mind these albums appear twice in my library
  1. Unfortunately file info gives me the following error: No Info - Track not in your library

Regarding the diagnostics:
Do I need to shut down the Roon Core server? I actually never shut down normally this machine, so please let me know in case I do need to reboot it.


@noris , just a short update: I restarted the machine and guess what: duplicate albums diasappeared, and I can view the file info of individual track in these albums. I did absolutely nothing apart from rebooting. I can even listed to some tracks (not tested all of them)!

I will not do anything (apart from listen to music) until you collect the information you need and tell me all is OK.


Hi @Vassilis_Papaeconomo,

Thank you for the continued feedback! I am pleased to hear that the duplicates are no longer present after the core had been rebooted.

Continuing forward, I can confirm that the mentioned diagnostics report has been received and is in our tech team’s queue for evaluation. Once the team has updated your ticket I will be sure to share their thoughts/findings with you in a timely manner. Your patience during this process is very appreciated!