All End point icons Missing

Hi I have tried and failed to find a solution but failed so far.
Full fresh install using as main core i have to endpoints.
Main core has no endpoint icons But the 2 end points have icons.
Can anybody help pls

Hey @Mark_Mcelroy — Thanks for sharing your observation with us, we appreciate the feedback!

Have you tried power cycling your Core machine since noticing this behavior? If not, give that a try and let us know if you’re still seeing this behavior.

Additionally, are you using a remote to access the Core machine, or is this the Core machine directly that you’re seeing this on?


HI dylan
This is the core when i select a remote there is no icon on core that show up on remotes
By power cycling ???

Thanks for the info, @Mark_Mcelroy.

Please follow the instructions listed below and let me know if you’re still having issues after:

  1. Close Roon
  2. Find and open your Roon database
  3. Navigate to /Library/Roon/Cache/
  4. Move the file elsewhere, like your desktop


1 Like

HI Dylan
Tried twice still not luck

I can confirm.

Thanks @Mark_Mcelroy,

After doing the above, have you tried rebooting your Core machine? Give that a try and let me know!


I have many times still nothing

@dylan fyi I’ve also rebooted the core machine. No luck. I can see my Chromecast speaker but not the other endpoints.

Hey @jaguone and @Mark_Mcelroy,

I have enabled diagnostics on your accounts so our technical staff can get some more insight into what’s going on here. The next time your Cores are active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


1 Like

Great News Dylan
If you need anything else just let me know
Restarting core now with remotes active.
Thank you

I rebooted each endpoint and now everything is working again. All endpoints are ok:smiley:

1 Like

Followed you but still the same :cry:

Hey @Mark_Mcelroy,

Thanks for your patience while the team has looked into this. I spoke with the team regarding their investigation today and wanted to pass along their feedback.

In the diagnostics report the team has found that Roon is having trouble accessing the database files that store the images. It appears that there may be some settings on the Mac that are preventing this.

Can you try enabling OSX file sharing and then try restarting Roon and let us know if you’re still experiencing these troubles?


Sorry No luck Its just like there not there

Thanks for giving that a try, @Mark_Mcelroy.

Next, I’d like to temporarily test using a fresh database and see if there’s any change. Please see the steps listed below:

  • Make a backup
  • Shut down your Roon Core
  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install


Done but still nothing.:cry:

Hey @Mark_Mcelroy,

In order to better understand where this behavior may be stemming from, I’d like to propose a test. Can you create a new user profile on the Mac and then install Roon on that user profile? When you do this does the same behavior occur?


Sorry for late reply
I done that at the weekend still the same.
Could it be a case that the end point files are missing.
Don’t worry about it maybe the next update will fix the issue. Im sure there are more important issues then mine. Ill keep trying if i find something ill let you guys know.
Cheers Dylan