Endpoint Device Icons Missing

Core Machine (Windows 10/AMD 2950X, 64GB DDR4 2966/RTX 2080TI/Roon 1.6, Build 416, 64bit)

Network Details (WiFi to Ubiquiti APHD to Ubiquiti Network Stack)**

Audio Devices (Schiit Gungnir - USB/Google Home Max - Wifi/Google Home Mini - Wifi/Chord Mojo - USB)

Description Of Issue:

All of the endpoint icons, except for the default Speaker-image, are blank on my core machine. I used to have specialized icons for my Google speakers and my Chord Mojo. I’ve included pictures to illustrate.

Actions Taken:

  • Rebooting Roon
  • Rebooting core machine
  • Rebooting network
  • Ensuring all drivers and updates are updated to latest public builds
  • Removing devices and then adding them again.

Additionally, I’ve taken all the actions describedin an older thread where the user seemed to have the same issue - though no solution was arrived at.

Hi @Kalen_Rixon,

Can you please try the following?

  1. Close the Roon application on your PC
  2. Open “File Explorer”
  3. Navigate to your database location
  4. Navigate to the Roon folder
  5. Open the folder named “Cache” inside your Roon folder
  6. Delete the file named “Devicedb-prod.zip” and “Devicedb-prod.zip.etag” if you have that file as well

Once you have deleted these files, reopen Roon and see if there is any change.

Hi Dylan,

This didn’t work for me. Both files were present and I deleted them both.

I just tried to reset all my settings and remove/add the audio devices in question.

On my laptop, where I run Roon as a control/bridge, I can see the icons perfectly. Same on my Android tablets and phone.

I want to avoid a complete reinstall if I can - and would doing so even fix my problem?

Hi @Kalen_Rixon,

Apologies for the delay here.

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi Dylan,

I just wanted to add that the icons are still missing after the 1.7 update. I also tried deleting the “Devicedb-prod.zip” and “Devicedb-prod.zip.etag” files again to no avail.

Just wondering if there’s any further info regarding this problem. Thanks!

Hi @Kalen_Rixon,

I’ve requested an update from the team, I know they’re still looking into this but I’ll reach out as soon as I hear from them.

A post was split to a new topic: Missing device icons

I just wanted to check in to see if there’s been an update/fix. The issue has persisted after uninstalling and reinstalling. No issues on my other computers, just the one that is the server.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.