Missing device icons

Just letting you know that I have the exact same issue on a fresh PC build in terms of missing endpoint icons. I didn’t have the issue on 1.7 with my old now decommissioned PC, only the new one. I have taken the same actions as suggested to the OP in this thread, and like him to no avail. Feel free to enable diagnostics logging on my account as well.

Hi @darkless,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

To confirm, you have tried the following:

  • Reboot of Roon Core
  • Reboot of networking gear
  • Deleted the files named “Devicedb-prod.zip” and “Devicedb-prod.zip.etag”

Is this issue occurring on all remote devices?

Hi @dylan,

My Samsung Galaxy S9 phone using Roon Remote does not suffer from this issue. It only occurs on my Roon Core workstation. Audio is output either through USB or optical out from the motherboard to a Chord Hugo M Scaler.

Rebooting Roon Core doesn’t work. Rebooting networking gear doesn’t work. Shutting down Roon, deleting the two Devicedb files from the AppData\Local\Roon\Cache folder and then restarting Roon also didn’t work. Files were immediately recreated afterwards.

I tried completely uninstalling Roon, reinstall Roon and then look into the very first Roon_log.txt. I came across a few entries like this:
02/22 00:24:46 Error: Error loading image (immediate): The remote server returned an error: (426) Upgrade Required. (http://localhost:9100/devicedb/db24c4281b318978c38b4b93916a38dbf40b844b.png)

The referenced .png appears to match the Chord Hugo M Scaler device that I use. The 426 status code hints that it might be due to a protocol mismatch.

I hope that’s enough for you to proceed with the bug hunting. Otherwise, feel free to send me a Roon build with more fine-grained logging around the relevant service endpoints. I’m a C# developer by trade and I’ll be happy to assist any way I can.

Specs for the PC running Roon:
OS: Windows 10 Pro (1903)
CPU: Intel i9-9900K
MB: Gigabyte Z390 Aurus Master
RAM: 64 GB DDR4 Corsair Vengeance LPX
GFX: nVidia RTX 2070 Super
WLAN: ASUS PCE-AC88 802.11ac

The computer is connected wirelessly to a TPLINK RE650 access point which itself is wired directly into an ASUS router connected to the internet via a fiber box. I usually pull up to 350 mbit up/down with only 2-4 ms delay to my ISP.


UPDATE: After upgrading Windows to the latest build (1909) the endpoint device icons were able to populate again. I’ll leave this here in case someone else ends up with the same problem.

Go here to download the Windows 10 Update Assistant.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.