All my library art disappeared

Hmm… None of my library art is showing on my Roon PC client now (still working fine on the ios app), only the qobuz window and new releases are showing art. This happened immediately after I deleted from my library an album added from Qoboz, which may be significant. Have tried clearing the image cache, restarting, but still no banana. Anyone know what is likely going on?

Please add some system details, OS, graphics card, etc. Also, make sure you’re using the latest graphics drivers if possible.

Windows 10 latest version, Nvidia gtX 1080 latest driver, INTEL i7 +16gb RAM, Roon core is on the PC SSD, local flacs on a QNAP NAS.

hmm… Strange. Is now working again, no idea what went wrong.

And now it is borked out again. I sense this is going to be tricky to fix.

Just stopped the roon server whilst the roon client was running (should have said I’m running roon server and the roon client on the same machine), then restarted the roon server and the library art is back. That indicates I may have some timing/priority problem. Bit at least it is working for the moment…

Hi @Roqxide — Thanks for the report!

Do you have any active firewall or antivirus on the Core machine? If so, any change if you disable them temporarily?

And just to be clear — You’re running RoonServer and Roon client both on the same machine, correct?

Thanks for responding… Yes right, client and server on the same machine. It was working fine for the last few days until I removed an album from Qoboz from the library this morning (something I did before without issues). I already disabled the firewall on my local network before I installed Roon to allow other clients access over the network. Have also tried disabling the anti virus entirely and I have also set exclusions for the Roon app folders for normal usage.

As I mentioned in my last post it will work, but only when I close and then restart Roon server, whilst the client application is already running. That makes me think that starting normally (i.e. loading roon server at system startup before I start the client) is not triggering the client process that reads in the library art data from the server’s roon core for some reason.

Hmm - happened again in normal usage. This time when using the ios client to get a new album from Qoboz, then most of the art went blank on the iphone screen. Went downstairs to the PC, then quit and restarted the Roon server and the artwork is back.

Hi @Roqxide,

We did some additional testing on our end and confirmed that this type of setup should be working without any issues — Do you have any other Windows PC on the network that you can temporarily try another setup with? The goal here is to understand if it’s something specific to the network or if it’s something specific to the Core machine.

Unfortunately no, there is only one PC on my internal network. Just to summarise what the problems are:

  1. If I start the Roon server when the client is not running and then launch the client no art appears (except art for Qobuz discovery). So I need to quit the roon server (by right clicking on the icon in the windows tray and select quit) and then launch it again, whilst the client is still running. I have to actually relaunch - disconnecting and then reconnecting in the settings does not refresh images.
  2. Sometimes (only 3 times in the last 3 or 4 days), the art will spontaneously disapear. This has happened when doing something involving interaction with Qoboz, in the PC client and once whilst using the ios app. This may not be significant, but it suggests to me that Roon may be handing off control to another process/thread whilst accessing Qobuz, then when control returns it doesn’t correctly update the image cache… That is what I would check for if I had the source code :).

As to why these things are happening on my setup and not yours, I have no idea, and have tried to disable everything that might be a problem… it isn’t easy for Roon working with so much disparate hardware.

Hi @Roqxide,

Is there a specific reason you’re using RoonServer + Roon instead of just an all-in-one installation of Roon?

Hi dylan

Yes I am aware of course that you can install it all in one, but there are several reasons why I didn’t want to do that, not least that I’ll probably want to put the core on another machine at some stage, since this PC is my main client machine. I did want to put it on my NAS, but that isn’t quite powerful enough being about 5 years old… I understand that if you can’t replicate the problem there is little you can do about it except perhaps bear it in mind if someone else reports something similar.

Hi @Roqxide,

Thanks for clarifying — I just wanted to make sure that there was a specific reason and it might not be simpler to use the all-in-one setup.

One option might be to try clearing the network stack on the device and let us know if that helps. Here is an article about this:

Hi Dylan

Thanks. That didn’t work… As of now, this is just a minor annoyance, as it takes little time to fix and only needs to be done on rebooting. In any case it hasn’t stopped me subscribing to Roon :). Whilst I’m planning some major updates to my network and music systems, that won’t be for a while and if it I still have a problem (will likely replace my NAS with a Nuc or something like that) I can address it then or maybe in the mean time I’ll find what is causing the problem by happenstance as often occurs. It is nice to know though that you go out of your way to support your product. So thanks for all the help!

Hi @Roqxide,

Thanks for the follow up! I’m sorry that this didn’t work for you either. It’s hard to say for sure what might be going on here since we aren’t able to reproduce or seeing widespread reports of this. Understanding if this is limited to this one machine or not would definitely be helpful, but I understand that’s not an easy test to perform.

If you have any other theories about what might make your setup unique, or if you have any other questions or issues, please always feel free to reach out and we’ll be happy to help!

A post was split to a new topic: Artwork disappeared