Allo USBridge board


(David Fung) #1192

It is the latest built downloaded from dietpi website. Roonbridge was installed by default. Also, Allo Web GUI is not working.


(David Fung) #1193

The dietPI on eMMC inside the USBridge also cannot be detected by Roon after update (That’s why I try the latest built on MicroSD). I remember I have selected backup before update on the eMMC. Can someone tell me how to restore the backup? Thanks !


(David Fung) #1194

Problem solved after studying the previous discussion below:


(Michael Grant) #1195

AND…


(Fernando Pereira) #1196

Much obliged, it worked like a charm!


(SoulEye) #1197

Does anyone know what the max voltage one could use for the Usbridge? Got my hand on a Pro-Ject Accu Box and checking if it could be used to power both Pre Box S2 and Usbridge?
Accu Box S2 has a 5v USB output and another 15v. If this is too much for Sparky/Usbridge, what could one do to reduce the voltage (I remember hearing about cabling :blush:that could do that?)


(Fernando Pereira) #1198

In DietPi 6.14, Shairport, which I use to listen to YouTube videos occasionally, was choking after a couple of minutes, so I downgraded it as @Michael_Grant kindly suggested. I just upgraded to 6.15. Shairport works well, but then it does not release the USBridge, and Roon claims it does see the USBridge. Going to Roon’s Settings>Audio and clicking “retry” for the correct device fixes it. Not a big deal, but I thought it would be useful to report in case someone else gets stuck this way.


(Scott Dempsey) #1199

I’m expecting my USBridge loaded with DietPi tomorrow, along with their USB WiFi dongle. Should I expect any problems out the wifi setup?

I should also ask, are the wifi adapter drivers already installed on the Sparky?


(Derek Morais) #1200

I think the driver is included. if not its here
Driver

fairly straight forward setup through dietpi-config


(Mark) #1201

If you can connect via Ethernet to start with and update DietPi to the latest version you will be okay.
I don’t think the drivers were included with earlier version. DietPi should now be at v6.16.

Myself and @Sean2016 have used an ASUS wifi dongle and we had to manually install the drivers but they are now included. Mine has been pretty solid since I started using it a few months back although I “clench” every time I do a software update. My USBridge hasn’t dropped the wi-fi connection whilst in use but sometimes when I re-boot it doesn’t connect until I pull the dongle out and re-insert it.


(Scott Dempsey) #1202

Is it easy to update DietPi?


(simon arnold) #1203

Yes ssh in and type dietpi-update and follow instructions.


(simon arnold) #1204

My edimax one uses the same chip and driver and never works unless I remove it and recompile it every time there is an update. Never auto installs. Bloody annoying.


(Mark) #1205

Here are some instructions I posted earlier, they will differ slightly in your case. I hope they help, if not shout out.

You should replace root@10.0.0.41 with root@(IP address of USBridge on your network) or root@dietpi.local.


(Scott Dempsey) #1206

I got everything in, removed the J28 jumper, am powering Sparky with the supplied PS, the USBridge with an iFi power. Installed the Wifi dongle. Roon saw everything as soon as it was up. Everything is working, easy as “pi”.

The only thing is that I thought Roon now did more of a full decode of Tidal in software, so unfortunately I’m still limited to 24/96 :frowning:

Now, if anyone can tell me which unneeded services to get rid of an how, it’d be appreciated. :slight_smile:


(simon arnold) #1207

Roon only does first unfold of MQA as it acts as a decoder only this is how it’s always been with MQA. The rendering stage that gives full MQA resolution requires an MQA supported DAC after the Allo.

Ots pretty slim already so go into dietpi-software in a shell and uninstall apps you don’t need. I found it made little difference having other stuff running or not YMMV. I use mine as a multipurpose device for Roon, Qobuz and Spotify. So have MPD, upmpdcli and Raspotify running as well as Roon Bridge.


(Geoff Smith) #1208

Just checking in with folks here… is 6.16 the latest version of DietPI for Sparky/USBridge (I find it hard to tell from the main DietPI site/forums)? Also, the Allo GUI hasn’t worked for me for the last few updates, I assume I need to re-flash the MMC to get it working again? Is there a command line tool that will show the current audio stream characteristics (e.g. sample rate, bit depth, etc.)? Roon just reports ‘ALSA’ when clicking the signal path icon.


(Lukas Luis) #1209

Is there really a need to always update the software? I haven’t updated mine since I bought it a few months back. I’m using it as roon endpoint only, directly connected to my NUC on a separate network segment so the USBridge is not connected to the Internet. Is there a sonic benefit for the latest software?


(Scott Dempsey) #1210

@rahulkc_s
Ok, Roon is not seeing my DAC that’s connected to my USBridge anymore.

lsusb:
Bus 004 Device 002: ID 0424:2412 Standard Microsystems Corp.
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 0bda:818b Realtek Semiconductor Corp.
Bus 003 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t:
/: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=aotg_hcd/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/2p, 480M
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=aotg_hcd/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=rtl8192eu, 480M
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M

Three ALSA showing up in roon, but not my DAC.

I have a PS Audio Stellar GCD. It was just working fine.

I have DietPi 6.16. The Roon module is active according to the web interface. Also, when I choose the sound card as usb-dac, it defaults back to none.


(Geoff Smith) #1211

In re: getting alsa to output the current sample rate – on my system it works out to:

cat /proc/asound/card1/pcm0p/sub0/hw_params

…which, at the moment, playing an MQA track off Tidal, yields:

access: RW_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 96000 (96000/1)
period_size: 1920
buffer_size: 3840